Recherchev : resultat N/A

Le
José Cordy
Bonjour,

J'utilise la formule suivante :
=SI(ESTNA(RECHERCHEV("U"&E$2&"K"&$D3;Permissions!$A$1:$H$8040;7;FAUX));"";RECHERCHEV("U"&E$2&"K"&$D3;Permissions!$A$1:$H$8040;7;FAUX))
pour ne pas obtenir le fameux N/A en cas ou le recherchev ne trouve pas
exactement une correspondance. C'est bien mais je voudrais que cette cellule
soit vide, or avec cela elle n'est pas vide (la valeur !)
Une idée comment faire ?

Merco d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #18235581
Bonjour.
Il ne faut alors pas utiliser de formule, mais une macro.
Cordialement.
Daniel

Bonjour,

J'utilise la formule suivante :
=SI(ESTNA(RECHERCHEV("U"&E$2&"K"&$D3;Permissions!$A$1:$H$8040;7;FAUX));"";RECHERCHEV("U"&E$2&"K"&$D3;Permissions!$A$1:$H$8040;7;FAUX))
pour ne pas obtenir le fameux N/A en cas ou le recherchev ne trouve pas
exactement une correspondance. C'est bien mais je voudrais que cette cellule
soit vide, or avec cela elle n'est pas vide (la valeur !)
Une idée comment faire ?

Merco d'avance


LSteph
Le #18238311
Bonsoir,

Pour le même contexte Index Equiv serait préférable à recherchev
mais

quelle que soit la formule (valide) employée
et
quel que soit le résultat renvoyé par cette formule,
la cellule contiendra quoiqu'il arrive la formule employée.

--
lSteph




José Cordy a écrit :
Bonjour,

J'utilise la formule suivante :
=SI(ESTNA(RECHERCHEV("U"&E$2&"K"&$D3;Permissions!$A$1:$H$8040;7;FAUX));"";RECHERCHEV("U"&E$2&"K"&$D3;Permissions!$A$1:$H$8040;7;FAUX))
pour ne pas obtenir le fameux N/A en cas ou le recherchev ne trouve pas
exactement une correspondance. C'est bien mais je voudrais que cette cellule
soit vide, or avec cela elle n'est pas vide (la valeur !)
Une idée comment faire ?

Merco d'avance


Publicité
Poster une réponse
Anonyme