Reconnexion réseau avec guessnet & ifupdown

Le
David BERCOT
Bonjour,

J'ai un petit problème lorsque je connecte, à chaud, un câbl=
e réseau
sur mon ordinateur Debian. Ainsi, j'utilise guessnet pour configurer
automatiquement le réseau en fonction du lieu. Si je suis en DHCP, tout
roule. En revanche, si je suis en mode "statique", ça ne fonctionne
qu'au boot de la machine. Lors d'un branchement à chaud, il semble
passer outre la bonne détection et me met en mode DHCP (mode par
défaut).
Auriez-vous l'explication de ce comportement ?
Tant que j'y suis, sur ma machine actuelle, le test du cable débranch=
é
ne marche pas alors qu'il était ok sur mon portable précéden=
t

A titre d'info, voici la structure de mon fichier interfaces :
<INTERFACES>
auto lo eth0
iface lo inet loopback
iface dhcp inet dhcp
iface cable_debranche inet manual
test missing-cable
pre-up false
mapping eth0
script guessnet-ifupdown
map default: dhcp
map verbose: true
map debug: true
iface travail inet dhcp
test peer address 10.x.x.x mac xx:xx:xx:xx:xx:xx
iface maison inet static
address 192.168.1.2
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 80.10.246.2 80.10.246.129
test peer address 192.168.1.1 mac xx:xx:xx:xx:xx:xx
</INTERFACE>

Merci d'avance.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20110220102529.3df62be6@debian-david
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bernard Schoenacker
Le #23142621
Le Sun, 20 Feb 2011 10:25:29 +0100,
David BERCOT
Bonjour,

J'ai un petit problème lorsque je connecte, à chaud, un câble rés eau
sur mon ordinateur Debian. Ainsi, j'utilise guessnet pour configurer
automatiquement le réseau en fonction du lieu. Si je suis en DHCP,
tout roule. En revanche, si je suis en mode "statique", ça ne
fonctionne qu'au boot de la machine. Lors d'un branchement à chaud,
il semble passer outre la bonne détection et me met en mode DHCP
(mode par défaut).
Auriez-vous l'explication de ce comportement ?
Tant que j'y suis, sur ma machine actuelle, le test du cable débranché
ne marche pas alors qu'il était ok sur mon portable précédent...

A titre d'info, voici la structure de mon fichier interfaces :
<INTERFACES>
auto lo eth0
iface lo inet loopback
iface dhcp inet dhcp
iface cable_debranche inet manual
test missing-cable
pre-up false
mapping eth0
script guessnet-ifupdown
map default: dhcp
map verbose: true
map debug: true
iface travail inet dhcp
test peer address 10.x.x.x mac xx:xx:xx:xx:xx:xx
iface maison inet static
address 192.168.1.2
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 80.10.246.2 80.10.246.129
test peer address 192.168.1.1 mac xx:xx:xx:xx:xx:xx
</INTERFACE>

Merci d'avance.

David.



bonjour,

voici la partie concernant interfaces :

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

ce qui est important c'est d'activer hotplug ....


slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
David BERCOT
Le #23144071
Le Sun, 20 Feb 2011 10:50:07 +0100,
Bernard Schoenacker
Le Sun, 20 Feb 2011 10:25:29 +0100,
David BERCOT > Bonjour,
>
> J'ai un petit problème lorsque je connecte, à chaud, un cà ¢ble réseau
> sur mon ordinateur Debian. Ainsi, j'utilise guessnet pour configurer
> automatiquement le réseau en fonction du lieu. Si je suis en DHCP,
> tout roule. En revanche, si je suis en mode "statique", ça ne
> fonctionne qu'au boot de la machine. Lors d'un branchement à chaud,
> il semble passer outre la bonne détection et me met en mode DHCP
> (mode par défaut).
> Auriez-vous l'explication de ce comportement ?

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

ce qui est important c'est d'activer hotplug ....



J'ai testé... sans succès. Il n'a pas l'air de changer quoi que c e soit
et reste en mode DHCP. Ce qui est assez bizarre car, si je fais un
ifdown eth0 suivi d'un ifup eth0, il semble effectuer correctement le
boulot (côté guessnet), mais je me retrouve pourtant avec une IP donnée
par le serveur DHCP :-(

Y'a un truc qui m'échappe...

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Erwan David
Le #23144141
On 20/02/11 19:01, David BERCOT wrote:
Le Sun, 20 Feb 2011 10:50:07 +0100,
Bernard Schoenacker
Le Sun, 20 Feb 2011 10:25:29 +0100,
David BERCOT
Bonjour,

J'ai un petit problème lorsque je connecte, à chaud, un câble réseau
sur mon ordinateur Debian. Ainsi, j'utilise guessnet pour configurer
automatiquement le réseau en fonction du lieu. Si je suis en DHCP,
tout roule. En revanche, si je suis en mode "statique", ça ne
fonctionne qu'au boot de la machine. Lors d'un branchement à chaud,
il semble passer outre la bonne détection et me met en mode DHCP
(mode par défaut).
Auriez-vous l'explication de ce comportement ?



# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

ce qui est important c'est d'activer hotplug ....



J'ai testé... sans succès. Il n'a pas l'air de changer quoi que ce soit
et reste en mode DHCP. Ce qui est assez bizarre car, si je fais un
ifdown eth0 suivi d'un ifup eth0, il semble effectuer correctement le
boulot (côté guessnet), mais je me retrouve pourtant avec une IP donnée
par le serveur DHCP :-(

Y'a un truc qui m'échappe...

David.




Y'aurait pas network manager qui tourne ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #23144481
Le Sun, 20 Feb 2011 19:01:05 +0100,
David BERCOT
Le Sun, 20 Feb 2011 10:50:07 +0100,
Bernard Schoenacker > Le Sun, 20 Feb 2011 10:25:29 +0100,
> David BERCOT > > Bonjour,
> >
> > J'ai un petit problème lorsque je connecte, à chaud, un câble
> > réseau sur mon ordinateur Debian. Ainsi, j'utilise guessnet pour
> > configurer automatiquement le réseau en fonction du lieu. Si je
> > suis en DHCP, tout roule. En revanche, si je suis en mode
> > "statique", ça ne fonctionne qu'au boot de la machine. Lors d'un
> > branchement à chaud, il semble passer outre la bonne détection et
> > me met en mode DHCP (mode par défaut).
> > Auriez-vous l'explication de ce comportement ?
>
> # The loopback network interface
> auto lo
> iface lo inet loopback
>
> # The primary network interface
> allow-hotplug eth0
> iface eth0 inet dhcp
>
> ce qui est important c'est d'activer hotplug ....

J'ai testé... sans succès. Il n'a pas l'air de changer quoi que ce
soit et reste en mode DHCP. Ce qui est assez bizarre car, si je fais
un ifdown eth0 suivi d'un ifup eth0, il semble effectuer correctement
le boulot (côté guessnet), mais je me retrouve pourtant avec une IP
donnée par le serveur DHCP :-(

Y'a un truc qui m'échappe...

David.



bonjour,

serait il possible d'obtenir la liste des paquets installés
ayant trait à une connection réseau ?


à titre indicatif et pour un ordi portable : whereami est
parfaitement indiqué ...

en revanche rien ne sert de mettre en place un ensemble de
gadets qui alourdirons l'ensemble et pourront nuire au
déverminage ....

script :

# for pkg in avahi network ;do dpkg -l |grep ii |grep $pkg ;done

rendre compte sur la liste ...

slt
Bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
David BERCOT
Le #23144561
Le Sun, 20 Feb 2011 20:33:10 +0100,
Bernard Schoenacker
Le Sun, 20 Feb 2011 19:01:05 +0100,
David BERCOT
> Le Sun, 20 Feb 2011 10:50:07 +0100,
> Bernard Schoenacker > > Le Sun, 20 Feb 2011 10:25:29 +0100,
> > David BERCOT > > > Bonjour,
> > >
> > > J'ai un petit problème lorsque je connecte, à chaud, un c âble
> > > réseau sur mon ordinateur Debian. Ainsi, j'utilise guessnet po ur
> > > configurer automatiquement le réseau en fonction du lieu. Si je
> > > suis en DHCP, tout roule. En revanche, si je suis en mode
> > > "statique", ça ne fonctionne qu'au boot de la machine. Lors d' un
> > > branchement à chaud, il semble passer outre la bonne déte ction
> > > et me met en mode DHCP (mode par défaut).
> > > Auriez-vous l'explication de ce comportement ?
> >
> > # The loopback network interface
> > auto lo
> > iface lo inet loopback
> >
> > # The primary network interface
> > allow-hotplug eth0
> > iface eth0 inet dhcp
> >
> > ce qui est important c'est d'activer hotplug ....
>
> J'ai testé... sans succès. Il n'a pas l'air de changer quoi q ue ce
> soit et reste en mode DHCP. Ce qui est assez bizarre car, si je fais
> un ifdown eth0 suivi d'un ifup eth0, il semble effectuer
> correctement le boulot (côté guessnet), mais je me retrouve
> pourtant avec une IP donnée par le serveur DHCP :-(
>
> Y'a un truc qui m'échappe...
>
> David.
>
bonjour,

serait il possible d'obtenir la liste des paquets installés
ayant trait à une connection réseau ?


à titre indicatif et pour un ordi portable : whereami est
parfaitement indiqué ...

en revanche rien ne sert de mettre en place un ensemble de
gadets qui alourdirons l'ensemble et pourront nuire
au déverminage ....

script :

# for pkg in avahi network ;do dpkg -l |grep ii |grep $pkg ;done

rendre compte sur la liste ...

slt
Bernard



S'il n'y a que ça pour te faire plaisir ;-)

ii avahi-autoipd
0.6.28-3 Avahi IPv4LL network address
configuration daemon ii avahi-daemon
0.6.28-3 Avahi mDNS/DNS-SD daemon ii
libapache2-mod-dnssd
0.6-2 Zeroconf support for Apache 2 via
avahi ii libavahi-client3
0.6.28-3 Avahi client library ii
libavahi-common-data
0.6.28-3 Avahi common data files ii
libavahi-common3
0.6.28-3 Avahi common library ii
libavahi-core7
0.6.28-3 Avahi's embeddable mDNS/DNS-SD
library ii libavahi-glib1
0.6.28-3 Avahi glib integration library ii
libavahi-gobject0
0.6.28-3 Avahi GObject library ii
libavahi-ui0
0.6.28-3 Avahi GTK+ User interface library
ii amule
2.2.6+debian0-8 client for the eD2k and Kad
networks, like eMule ii avahi-autoipd
0.6.28-3 Avahi IPv4LL network address
configuration daemon ii gnome-nettool
2.30.0-3 network information tool for GNOME
ii guessnet
0.53-2 Guess which LAN a network device
is connected to ii ifupdown
0.6.10 high level tools to configure
network interfaces ii iproute
20110107-2 networking and traffic control
tools ii iputils-ping
3:20100418-3 Tools to test the reachability of
network hosts ii libnet1
1.1.4-2 library for the construction and
handling of network packets ii libnm-glib2
0.8.2-5 network management framework (GLib
shared library) ii libnm-util1
0.8.2-5 network management framework
(shared library) ii libqt4-network
4:4.6.3-4 Qt 4 network module ii
net-tools
1.60-23 The NET-3 networking toolkit ii
netbase
4.45 Basic TCP/IP networking system ii
python-ipy
1:0.72-1 Python module for handling IPv4
and IPv6 addresses and networks ii
python-wicd
1.7.0+ds1-6 wired and wireless network manager
- Python module ii traceroute
1:2.0.15-1 Traces the route taken by packets
over an IPv4/IPv6 network ii wicd
1.7.0+ds1-6 wired and wireless network manager
- metapackage ii wicd-daemon
1.7.0+ds1-6 wired and wireless network manager
- daemon ii wicd-gtk
1.7.0+ds1-6 wired and wireless network manager
- GTK+ client ii xvnc4viewer
4.1.1+X4.3.0-37 Virtual network computing client
software for X

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
David BERCOT
Le #23144571
Le Sun, 20 Feb 2011 19:26:45 +0100,
Erwan David
On 20/02/11 19:01, David BERCOT wrote:
> Le Sun, 20 Feb 2011 10:50:07 +0100,
> Bernard Schoenacker >> Le Sun, 20 Feb 2011 10:25:29 +0100,
>> David BERCOT >>> Bonjour,
>>>
>>> J'ai un petit problème lorsque je connecte, à chaud, un c âble
>>> réseau sur mon ordinateur Debian. Ainsi, j'utilise guessnet pour
>>> configurer automatiquement le réseau en fonction du lieu. Si je
>>> suis en DHCP, tout roule. En revanche, si je suis en mode
>>> "statique", ça ne fonctionne qu'au boot de la machine. Lors d'un
>>> branchement à chaud, il semble passer outre la bonne détect ion et
>>> me met en mode DHCP (mode par défaut).
>>> Auriez-vous l'explication de ce comportement ?
>>
>> # The loopback network interface
>> auto lo
>> iface lo inet loopback
>>
>> # The primary network interface
>> allow-hotplug eth0
>> iface eth0 inet dhcp
>>
>> ce qui est important c'est d'activer hotplug ....
>
> J'ai testé... sans succès. Il n'a pas l'air de changer quoi q ue ce
> soit et reste en mode DHCP. Ce qui est assez bizarre car, si je
> fais un ifdown eth0 suivi d'un ifup eth0, il semble effectuer
> correctement le boulot (côté guessnet), mais je me retrouve
> pourtant avec une IP donnée par le serveur DHCP :-(
>
> Y'a un truc qui m'échappe...
>
> David.
>
Y'aurait pas network manager qui tourne ?



Non, j'utilise Wicd.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #23144691
Le Sun, 20 Feb 2011 21:05:44 +0100,
David BERCOT
Le Sun, 20 Feb 2011 20:33:10 +0100,
Bernard Schoenacker > Le Sun, 20 Feb 2011 19:01:05 +0100,
> David BERCOT >
> > Le Sun, 20 Feb 2011 10:50:07 +0100,
> > Bernard Schoenacker > > > Le Sun, 20 Feb 2011 10:25:29 +0100,
> > > David BERCOT > > > > Bonjour,
> > > >
> > > > J'ai un petit problème lorsque je connecte, à chaud, un câb le
> > > > réseau sur mon ordinateur Debian. Ainsi, j'utilise guessnet
> > > > pour configurer automatiquement le réseau en fonction du
> > > > lieu. Si je suis en DHCP, tout roule. En revanche, si je suis
> > > > en mode "statique", ça ne fonctionne qu'au boot de la
> > > > machine. Lors d'un branchement à chaud, il semble passer
> > > > outre la bonne détection et me met en mode DHCP (mode par
> > > > défaut). Auriez-vous l'explication de ce comportement ?
> > >
> > > # The loopback network interface
> > > auto lo
> > > iface lo inet loopback
> > >
> > > # The primary network interface
> > > allow-hotplug eth0
> > > iface eth0 inet dhcp
> > >
> > > ce qui est important c'est d'activer hotplug ....
> >
> > J'ai testé... sans succès. Il n'a pas l'air de changer quoi que ce
> > soit et reste en mode DHCP. Ce qui est assez bizarre car, si je
> > fais un ifdown eth0 suivi d'un ifup eth0, il semble effectuer
> > correctement le boulot (côté guessnet), mais je me retrouve
> > pourtant avec une IP donnée par le serveur DHCP :-(
> >
> > Y'a un truc qui m'échappe...
> >
> > David.
> >
> bonjour,
>
> serait il possible d'obtenir la liste des paquets installés
> ayant trait à une connection réseau ?
>
>
> à titre indicatif et pour un ordi portable : whereami est
> parfaitement indiqué ...
>
> en revanche rien ne sert de mettre en place un ensemble de
> gadets qui alourdirons l'ensemble et pourront nuire
> au déverminage ....
>
> script :
>
> # for pkg in avahi network ;do dpkg -l |grep ii |grep $pkg ;done
>
> rendre compte sur la liste ...
>
> slt
> Bernard

S'il n'y a que ça pour te faire plaisir ;-)

ii avahi-autoipd
0.6.28-3 Avahi IPv4LL network address
configuration daemon ii avahi-daemon
0.6.28-3 Avahi mDNS/DNS-SD daemon ii
libapache2-mod-dnssd
0.6-2 Zeroconf support for Apache 2 via
avahi ii libavahi-client3
0.6.28-3 Avahi client library ii
libavahi-common-data
0.6.28-3 Avahi common data files ii
libavahi-common3
0.6.28-3 Avahi common library ii
libavahi-core7
0.6.28-3 Avahi's embeddable mDNS/DNS-SD
library ii libavahi-glib1
0.6.28-3 Avahi glib integration library ii
libavahi-gobject0
0.6.28-3 Avahi GObject library ii
libavahi-ui0
0.6.28-3 Avahi GTK+ User interface library
ii amule
2.2.6+debian0-8 client for the eD2k and Kad
networks, like eMule ii avahi-autoipd
0.6.28-3 Avahi IPv4LL network address
configuration daemon ii gnome-nettool
2.30.0-3 network information tool for
GNOME ii guessnet
0.53-2 Guess which LAN a network device
is connected to ii ifupdown
0.6.10 high level tools to configure
network interfaces ii iproute
20110107-2 networking and traffic control
tools ii iputils-ping
3:20100418-3 Tools to test the reachability of
network hosts ii libnet1
1.1.4-2 library for the construction and
handling of network packets ii libnm-glib2
0.8.2-5 network management framework
(GLib shared library) ii libnm-util1
0.8.2-5 network management framework
(shared library) ii libqt4-network
4:4.6.3-4 Qt 4 network module ii
net-tools
1.60-23 The NET-3 networking toolkit ii
netbase
4.45 Basic TCP/IP networking system ii
python-ipy
1:0.72-1 Python module for handling IPv4
and IPv6 addresses and networks ii
python-wicd
1.7.0+ds1-6 wired and wireless network
manager
- Python module ii traceroute
1:2.0.15-1 Traces the route taken by packets
over an IPv4/IPv6 network ii wicd
1.7.0+ds1-6 wired and wireless network
manager
- metapackage ii wicd-daemon
1.7.0+ds1-6 wired and wireless network
manager
- daemon ii wicd-gtk
1.7.0+ds1-6 wired and wireless network
manager
- GTK+ client ii xvnc4viewer
4.1.1+X4.3.0-37 Virtual network computing client
software for X

David.



bonjour,


quelles sont les raisons d'employer ceci :


avahi-autoipd
gnome-nettool
guessnet
libavahi-gobject0
libnet1

libapache2-mod-dnssd

tu crois pas que ça se mélange un peut trop les crayons
et les pinceaux ?

reprend la conf en prenant les choses les plus basiques et
tu pourra avancer ...


slt
bernard




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme