Récupération de la 1ère ligne d'une cellule

Le
fidecourt
Bonjour à tous,



j'ai une colonne (D) qui comporte soit une description avec une seule
ligne, soit une description avec plusieurs lignes

j'ai créé une seconde colonne (E) qui récupère que la première li=
gne
des cellules à plusieurs lignes

avec la fonction :

=GAUCHE(D2;(TROUVE(CAR(10);D2))-1)

cela fonctionne bien sur toutes les cellules comportant plusieurs
lignes

sur les cellules à une seule ligne, j'obtiens : #VALEUR!

j'ai créé une nouvelle colonne où je dis :

=SI(ESTREF(E2);D2;GAUCHE(D2;(TROUVE(CAR(10);D2))-1))



Et là problème, car j'obtiens bien la valeur de la colonne (D) pour
les cellules à une ligne, mais pour les cellules à plusieurs lignes,
cela me renvoie l'intégralité de la cellule présentée comme suit :

SAC 5 BOMBES 75MM LAMPI¨A190502A¨1 BOMBE 75MM BQT BLEU + MARRON
TITANE¨A190509A



Ma question est : pourquoi la fonction =GAUCHE. ne fonctionne pas
après la condition SI ?



Quelqu'un a t il une idée sur ce qui cloche ?

d'avance merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
garnote
Le #18102871
Salut,

Essaie cette formule en attendant plus court :

=SI(ESTERREUR(TROUVE(CAR(10);D2;1));D2;GAUCHE(D2;(TROUVE(CAR(10);D2))-1))

Serge


Bonjour à tous,



j'ai une colonne (D) qui comporte soit une description avec une seule
ligne, soit une description avec plusieurs lignes

j'ai créé une seconde colonne (E) qui récupère que la première ligne
des cellules à plusieurs lignes

avec la fonction :

=GAUCHE(D2;(TROUVE(CAR(10);D2))-1)

cela fonctionne bien sur toutes les cellules comportant plusieurs
lignes

sur les cellules à une seule ligne, j'obtiens : #VALEUR!

j'ai créé une nouvelle colonne où je dis :

=SI(ESTREF(E2);D2;GAUCHE(D2;(TROUVE(CAR(10);D2))-1))



Et là problème, car j'obtiens bien la valeur de la colonne (D) pour
les cellules à une ligne, mais pour les cellules à plusieurs lignes,
cela me renvoie l'intégralité de la cellule présentée comme suit :

SAC 5 BOMBES 75MM LAMPI¨A190502A¨1 BOMBE 75MM BQT BLEU + MARRON
TITANE¨A190509A



Ma question est : pourquoi la fonction =GAUCHE.... ne fonctionne pas
après la condition SI ?



Quelqu'un a t il une idée sur ce qui cloche ?

d'avance merci de votre aide
garnote
Le #18102831
Un poil plus court :

=SI(ESTERR(TROUVE(CAR(10);D2));D2;GAUCHE(D2;(TROUVE(CAR(10);D2))-1))

Serge


"garnote"
Salut,

Essaie cette formule en attendant plus court :

=SI(ESTERREUR(TROUVE(CAR(10);D2;1));D2;GAUCHE(D2;(TROUVE(CAR(10);D2))-1))

Serge



Bonjour à tous,



j'ai une colonne (D) qui comporte soit une description avec une seule
ligne, soit une description avec plusieurs lignes

j'ai créé une seconde colonne (E) qui récupère que la première ligne
des cellules à plusieurs lignes

avec la fonction :

=GAUCHE(D2;(TROUVE(CAR(10);D2))-1)

cela fonctionne bien sur toutes les cellules comportant plusieurs
lignes

sur les cellules à une seule ligne, j'obtiens : #VALEUR!

j'ai créé une nouvelle colonne où je dis :

=SI(ESTREF(E2);D2;GAUCHE(D2;(TROUVE(CAR(10);D2))-1))



Et là problème, car j'obtiens bien la valeur de la colonne (D) pour
les cellules à une ligne, mais pour les cellules à plusieurs lignes,
cela me renvoie l'intégralité de la cellule présentée comme suit :

SAC 5 BOMBES 75MM LAMPI¨A190502A¨1 BOMBE 75MM BQT BLEU + MARRON
TITANE¨A190509A



Ma question est : pourquoi la fonction =GAUCHE.... ne fonctionne pas
après la condition SI ?



Quelqu'un a t il une idée sur ce qui cloche ?

d'avance merci de votre aide




fidecourt
Le #18102991
On 10 déc, 16:22, "garnote"
Un poil plus court :

=SI(ESTERR(TROUVE(CAR(10);D2));D2;GAUCHE(D2;(TROUVE(CAR(10);D2))-1))

Serge

"garnote"
> Salut,

> Essaie cette formule en attendant plus court :

> =SI(ESTERREUR(TROUVE(CAR(10);D2;1));D2;GAUCHE(D2;(TROUVE(CAR(10);D2)) -1))

> Serge

> >
> Bonjour à tous,

> j'ai une colonne (D) qui comporte soit une description avec une seule
> ligne, soit une description avec plusieurs lignes

> j'ai créé une seconde colonne (E) qui récupère que la premièr e ligne
> des cellules à plusieurs lignes

> avec la fonction :

> =GAUCHE(D2;(TROUVE(CAR(10);D2))-1)

> cela fonctionne bien sur toutes les cellules comportant plusieurs
> lignes

> sur les cellules à une seule ligne, j'obtiens : #VALEUR!

> j'ai créé une nouvelle colonne où je dis :

> =SI(ESTREF(E2);D2;GAUCHE(D2;(TROUVE(CAR(10);D2))-1))

> Et là problème, car j'obtiens bien la valeur de la colonne (D) pour
> les cellules à une ligne, mais pour les cellules à plusieurs lignes ,
> cela me renvoie l'intégralité de la cellule présentée comme sui t :

> SAC 5 BOMBES 75MM LAMPI¨A190502A¨1 BOMBE 75MM BQT BLEU + MARRON
> TITANE¨A190509A

> Ma question est : pourquoi la fonction =GAUCHE.... ne fonctionne pas
> après la condition SI ?

> Quelqu'un a t il une idée sur ce qui cloche ?

> d'avance merci de votre aide



Merci Serge,
cela fonctionne pour 90 % des cellules à plusieurs lignes sauf
certaines

Comment peut on voir dans une cellule s'il existe bien retour
chariot ?
je pense que les cellules qui sont récalcitrantes ont dues être
paramétrées différemment
mais comment voir cela ?

d'avance merci si tu as une idée
Françoise
garnote
Le #18103391
Bonjour Françoise,

La coutume ici est de répondre au-dessus des
questions posées ;-)

Quant au 10% où ma magnifique formule ( ! )
n'opère pas, il me faudrait voir tes données.
Tu peux toujours envoyer ton document sur Cjoint :
http://cjoint.com/


Merci Serge,
cela fonctionne pour 90 % des cellules à plusieurs lignes sauf
certaines
Comment peut on voir dans une cellule s'il existe bien retour
chariot ?
je pense que les cellules qui sont récalcitrantes ont dues être
paramétrées différemment
mais comment voir cela ?
d'avance merci si tu as une idée

Françoise
garnote
Le #18103801
Sélectionne ta cellule et clique sur
Format/ Cellule... et décoche
"Renvoyer à la ligne automatiquement".
S'il y a des retours chariot, tu verras
de petits points d'interrogation dans
un carré.

Serge


Comment peut on voir dans une cellule s'il existe bien retour
chariot ?

Françoise
fidecourt
Le #18103771
On 10 déc, 17:32, "garnote"
Sélectionne ta cellule et clique sur
Format/ Cellule... et décoche
"Renvoyer à la ligne automatiquement".
S'il y a des retours chariot, tu verras
de petits points d'interrogation dans
un carré.

Serge

Comment peut on voir dans une cellule s'il existe bien retour
chariot ?

Françoise



Merci beaucoup Serge pour ces infos, j'ai testé la visu des retours
chariots, mais je ne vois rien, donc afin de ne pas bloquer et compte
tenu du nombre restreint par rapport à mon fichier total, j'ai fait le
retour à la ligne moi même et là bien évidemment tes 2 formules
fornctionnent !

Encore merci pour ton aide précieuse
A+
Françoise
garnote
Le #18103761
Tu pourrais aussi utiliser cette formule :
=SI(ESTERR(TROUVE(CAR(10);D2;1));"Pas de retour chariot";"Retour chariot")

Comment peut on voir dans une cellule s'il existe bien retour
chariot ?

Françoise
Publicité
Poster une réponse
Anonyme