Redemarrer le reseau ?

Le
olivier.marti
Bonjour,

J'ai des soucis avec mon Mac (MacBook sous Mac OS X 10.6.4) : je perd le
réseau filaire ! Le tableau de bord se met à indiquer que j'ai une
adresse IP locale, ou que l'état de ma connection ne peut être
déterminée. Je suis branché sur le réseau de mon labo, et je suis le
seul à avoir ce soucis (70 IP dans mon bâtîment, environ 400 pour le
réseau du labo et le serveur DHCP, une vingtaine de Macs dans le tas).
Changer de prise réseau, il y a en a deux dans mon bureau, ne résout
rien.

La seule solution est de redémmarrer la machine, ce qui est parfois
pénible.

Existe t'il un moyen d'arréter et de redémmarrer le logiciel qui gère le
réseau, pour voir si ça peut marcher ? J'ai un peu cherché dans les
process qui tournent sur la machine, sans repérer un truc pertinent.

Une idée pour redémmarer le réseau ?

En prime, si quelqu'un a une idée sur le pourquoi de ces soucis, ou sur
comment progresser dans mon diagnostic, je suis preneur.

Olivier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Franck
Le #22319031
On 01/07/2010 15:10, Olivier Marti wrote:
J'ai un peu cherché dans les
process qui tournent sur la machine, sans repérer un truc pertinent.



Normal, il n'y en a pas, c'est le noyau qui gère (enfin plus exactement
une extension noyau chargée par le noyau dans son propre espace).

Une idée pour redémmarer le réseau ?



Eventuellement en déchargeant l'extension qui gère la carte et en la
rechargeant (commande kextload/kextunload a utiliser depuis le compte
root), mais encore faut-il déterminer quelle extension (qui va dépend re
du hardware du mac)...
benoit.sansspam
Le #22319151
Olivier Marti
Une idée pour redémmarer le réseau ?



Désactiver/réactiver l'Etheret dans les préférences.

En prime, si quelqu'un a une idée sur le pourquoi de ces soucis, ou sur
comment progresser dans mon diagnostic, je suis preneur.



Si tu es sous DHCP, je ne sais pas trop, si tu es en IP fixe, là
par contre il y a peut-être un conflit avec une autre machine. Il y a
des utilitaires qui permettent de scanner un réseau et connaître les IP
utilisées, cela peut t'aider.

Sinon, tu as ta prise ethernet qui a un soucis, ou le câble. Tu
dis avoir tester la prise murale, mais le cordon ? Ton connecteur ?

--
Benoît http://picasaweb.google.com/leraillez/

Avec des fumeurs c'est difficile de s'arrêter. Avec des branleurs,
là, par contre, c'est difficile de continuer.
olivier.marti
Le #22319131
Benoit
Olivier Marti
> Une idée pour redémmarer le réseau ?

Désactiver/réactiver l'Etheret dans les préférences.



J'ai un peu tout essayé de ce coté la. Sans succès.


> En prime, si quelqu'un a une idée sur le pourquoi de ces soucis, ou sur
> comment progresser dans mon diagnostic, je suis preneur.

Si tu es sous DHCP, je ne sais pas trop, si tu es en IP fixe, là
par contre il y a peut-être un conflit avec une autre machine. Il y a
des utilitaires qui permettent de scanner un réseau et connaître les IP
utilisées, cela peut t'aider.

Sinon, tu as ta prise ethernet qui a un soucis, ou le câble. Tu
dis avoir tester la prise murale, mais le cordon ? Ton connecteur ?



La aussi, j'ai testé une autre prise, un autre câble. Qu'appelles tu le
connecteur. Si c'est la prise sur le Mac, elle est peut-être en cause,
mais comment savoir ?

Olivier
olivier.marti
Le #22319141
Franck
On 01/07/2010 15:10, Olivier Marti wrote:
> J'ai un peu cherché dans les
> process qui tournent sur la machine, sans repérer un truc pertinent.

Normal, il n'y en a pas, c'est le noyau qui gère (enfin plus exactement
une extension noyau chargée par le noyau dans son propre espace).



Groumpffff !!!


> Une idée pour redémmarer le réseau ?

Eventuellement en déchargeant l'extension qui gère la carte et en la
rechargeant (commande kextload/kextunload a utiliser depuis le compte
root), mais encore faut-il déterminer quelle extension (qui va dépendre
du hardware du mac)...



Ca c'est facile. Information système me dit que la carte est une Yukon,
et que l'extension qui la gère est
/System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/Appl
eYukon2.kext

J'essaye ça la prochaine fois que le soucis se manifeste.

Merci pour la piste !

Olivier
Le Moustique
Le #22319241
Le 01/07/10 15:10, Olivier Marti a écrit :
En prime, si quelqu'un a une idée sur le pourquoi de ces soucis, ou s ur
comment progresser dans mon diagnostic, je suis preneur.



Il suffit probablement de faire un reset de la SMC, comme indiqué sur l e
site d'Apple.
Voici la manipulation pour le MacBook :

Éteignez l’ordinateur.
Déconnectez l’adaptateur secteur MagSafe de l’ordinateur, s’il es t connecté.
Retirez la batterie.
Maintenez le bouton d’alimentation enfoncé pendant cinq secondes.
Relâchez le bouton d’alimentation.
Replacez la batterie et rebranchez l’adaptateur secteur MagSafe.
Appuyez sur le bouton d’alimentation pour allumer l’ordinateur.

Il faudra peut-être recréer les préférences réseau.

--
/)
-:oo= Guillaume
)
Je nettoyais mon clavier, et le coup est parti tout seul.
olivier.marti
Le #22319551
Le Moustique
Il suffit probablement de faire un reset de la SMC, comme indiqué sur le
site d'Apple.



Je n'ai pas trouvé d'indication de lien enter des soucis réseau et ls
SMC. Tu as vu ça quelque part ?

Olivier
Le Moustique
Le #22319641
Le 01/07/10 17:11, Olivier Marti a écrit :

Il suffit probablement de faire un reset de la SMC, comme indiqué su r le
site d'Apple.



Je n'ai pas trouvé d'indication de lien enter des soucis réseau et ls
SMC. Tu as vu ça quelque part ?



Ca m'est déjà arrivé sur un iMac, et c'était la procédure conse illée. Je
l'ai suivie, ça a réglé le problème. La procédure étant à p eu près
identique (modulo le retrait de batterie), je me suis dit que ça devait
être tout aussi efficace, et comme ça ne détruit rien...


--
/)
-:oo= Guillaume
)
Je nettoyais mon clavier, et le coup est parti tout seul.
olivier.marti
Le #22319881
Le Moustique
Le 01/07/10 17:11, Olivier Marti a écrit :

>> Il suffit probablement de faire un reset de la SMC, comme indiqué sur le
>> site d'Apple.
>
> Je n'ai pas trouvé d'indication de lien enter des soucis réseau et ls
> SMC. Tu as vu ça quelque part ?

Ca m'est déjà arrivé sur un iMac, et c'était la procédure conseillée. Je
l'ai suivie, ça a réglé le problème. La procédure étant à peu près
identique (modulo le retrait de batterie), je me suis dit que ça devait
être tout aussi efficace, et comme ça ne détruit rien...



OK. Bon, je garde ça comme idée. J'essayerais la prochaine fois.

Merci

Olivier
xavier
Le #22319871
Olivier Marti
Une idée pour redémmarer le réseau ?



Préférence Système -> Réseau -> Avancé -> TCP/IP
cliquer sur "renouveler le bail DHCP"

--
XAv - recasé
gilbert.olivier
Le #22320281
Xavier
Olivier Marti
> Une idée pour redémmarer le réseau ?

Préférence Système -> Réseau -> Avancé -> TCP/IP
cliquer sur "renouveler le bail DHCP"



ou une légère variante:
Choisir (ou en créer une si besoin) une autre config réseau,
l'appliquer, puis revenir à la première et de nouveau l'appliquer... et
croiser les doigts.

--
Gilbert
Publicité
Poster une réponse
Anonyme