Refuser cellules identiques

Le
Richard Fortin
Bonjour,

J'aimerais dans une colonne ne pas avoir l'autorisation d'inscrire deux
nombres identiques.

Merci de votre aide
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
News CI
Le #4602811
Salut,

Voici une solution que je te propose :

Par exemple, si ta plage à vérifier est dans a1:a20,
- mets la formule =NB.SI($A$1:$A$20;A1) dans b1
- copie la dans b2:b20
- selectionne la plage a1:a20
- va dans Données/Validation
- choisis Personnalisé dans Autoriser
- mets dans formule ±<=1

A+




"Richard Fortin" message de news:
Bonjour,

J'aimerais dans une colonne ne pas avoir l'autorisation d'inscrire deux
nombres identiques.

Merci de votre aide



garnote
Le #4602801
Salut Richard,

Un exemple :
1) Sélectionne A1:A100
2) Clique sur Données / Validation...
3) Clique sur l'onglet « Options » et :
Autoriser : Personnalisé
Formule : =nb.si($a$1:$a$100;A1)=1
4) Clique sur l'onglet « Alerte d'erreur » et :
Style : Arrêt
Titre : Ce que tu veux
Message d'erreur : Ce que tu veux.

Serge


"Richard Fortin"
Bonjour,

J'aimerais dans une colonne ne pas avoir l'autorisation d'inscrire deux
nombres identiques.

Merci de votre aide


garnote
Le #4602791
Et si tu veux étendre la validation à toutes
les cellules de la colonne A, sélectionne la
colonne A et dans Formule, entre ceci :
=NB.SI($A:$A;A1)=1

Serge

"garnote"
Salut Richard,

Un exemple :
1) Sélectionne A1:A100
2) Clique sur Données / Validation...
3) Clique sur l'onglet « Options » et :
Autoriser : Personnalisé
Formule : =nb.si($a$1:$a$100;A1)=1
4) Clique sur l'onglet « Alerte d'erreur » et :
Style : Arrêt
Titre : Ce que tu veux
Message d'erreur : Ce que tu veux.

Serge


"Richard Fortin"
Bonjour,

J'aimerais dans une colonne ne pas avoir l'autorisation d'inscrire deux
nombres identiques.

Merci de votre aide






Publicité
Poster une réponse
Anonyme