Renvoie valeur conditionnel sur une ligne et 3 colonnes.

Le
IlEstOuLeYouki
Bonjour,

J'ai un petit problème à vous soumettre :

La feuille se présente ainsi :

col1 - col2 - col3 col4
Ligne1- P 10 115 x

"x" étant le résultat automatique avec la (les) formule(s) suivante(s) :

Pour une même ligne :

- SI col1 =P, ET SI col2 <col3, ALORS col4 = P, SINON B
- SI col1 =B, ET SI col2 <col3, ALORS col4 = B, SINON P

La colonne 1 ne peut avoir comme valeur que P ou B.

Vous en remerciant par avance,

Cordialement.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #24977642
Bonjour,

Une façon de faire :

J'ai remplacé dans ton énoncé les col1 à Col4 par l'adresse
des cellules A1 à D1

=SI(ET(A2="B";B2<C2);"B";SI(ET(A2="P";B2<C2);"P";""))




MichD
---------------------------------------------------------------
MichD
Le #24977722
Pour que la formule soit complète, il manquait un petit bout.... dont voici!

=SI(ET(A2="B";B2<C2);"B";SI(ET(A2="P";B2<C2);"P";SI(A2="B";"P";"B")))


MichD
---------------------------------------------------------------
IlEstOuLeYouki
Le #24977772
Merci MichD,

J'essaye de suite cette formule.

Cordialement.

"MichD" news:k8fp2o$va8$
Pour que la formule soit complète, il manquait un petit bout.... dont
voici!

=SI(ET(A2="B";B2<C2);"B";SI(ET(A2="P";B2<C2);"P";SI(A2="B";"P";"B")))


MichD
---------------------------------------------------------------

IlEstOuLeYouki
Le #24977882
Merci mille fois, ça marche super.

cordialement.

"MichD" news:k8fp2o$va8$
Pour que la formule soit complète, il manquait un petit bout.... dont
voici!

=SI(ET(A2="B";B2<C2);"B";SI(ET(A2="P";B2<C2);"P";SI(A2="B";"P";"B")))


MichD
---------------------------------------------------------------

Jacky
Le #24977912
Bonjour,

Ceci devrait être suffisant

=SI(B2<C2;A2;SI(A2="B";"P";"B"))

--
Salutations
JJ


"IlEstOuLeYouki" 50ab7299$0$23465$
Merci mille fois, ça marche super.

cordialement.

"MichD"
Pour que la formule soit complète, il manquait un petit bout.... dont voici!

=SI(ET(A2="B";B2<C2);"B";SI(ET(A2="P";B2<C2);"P";SI(A2="B";"P";"B")))


MichD
---------------------------------------------------------------




IlEstOuLeYouki
Le #24978022
Re,

Oui les deux fonctionnent, mais je remarque un problème.
Puisque la feuille se remplie au fur et à mesure, la cellule de résultat
prend la valeur B même si la ligne est vide.(elle devrait rester vide si A2
est vide).
J'ai donc remplacé la fin de la formule par SI(A2="B";"P";"")))
Mais là je ne peux avoir qu'un résultat B, le P n'apparaissant pas.

Cordialement.

"Jacky" news:k8fsku$8as$
Bonjour,

Ceci devrait être suffisant

=SI(B2<C2;A2;SI(A2="B";"P";"B"))

--
Salutations
JJ


"IlEstOuLeYouki" 50ab7299$0$23465$
Merci mille fois, ça marche super.

cordialement.

"MichD" news:k8fp2o$va8$
Pour que la formule soit complète, il manquait un petit bout.... dont
voici!

=SI(ET(A2="B";B2<C2);"B";SI(ET(A2="P";B2<C2);"P";SI(A2="B";"P";"B")))


MichD
---------------------------------------------------------------








Jacky
Le #24978012
Re...
(elle devrait rester vide si A2 est vide).



=SI(A2="";"";SI(B2<C2;A2;SI(A2="B";"P";"B")))

--
Salutations
JJ


"IlEstOuLeYouki" 50ab7c2f$0$21229$
Re,

Oui les deux fonctionnent, mais je remarque un problème.
Puisque la feuille se remplie au fur et à mesure, la cellule de résultat prend la valeur B même si la ligne
est vide.(elle devrait rester vide si A2 est vide).
J'ai donc remplacé la fin de la formule par SI(A2="B";"P";"")))
Mais là je ne peux avoir qu'un résultat B, le P n'apparaissant pas.

Cordialement.

"Jacky"
Bonjour,

Ceci devrait être suffisant

=SI(B2<C2;A2;SI(A2="B";"P";"B"))

--
Salutations
JJ


"IlEstOuLeYouki" 50ab7299$0$23465$
Merci mille fois, ça marche super.

cordialement.

"MichD"
Pour que la formule soit complète, il manquait un petit bout.... dont voici!

=SI(ET(A2="B";B2<C2);"B";SI(ET(A2="P";B2<C2);"P";SI(A2="B";"P";"B")))


MichD
---------------------------------------------------------------











Jacky
Le #24978002
Ou encore

S'il manque une donnée en A2 ou B2 ou C2
=SI(NBVAL(A2:C2)<>3;"";SI(B2<C2;A2;SI(A2="B";"P";"B")))

;o)
--
Salutations
JJ


"Jacky"
Re...
(elle devrait rester vide si A2 est vide).



=SI(A2="";"";SI(B2<C2;A2;SI(A2="B";"P";"B")))

--
Salutations
JJ


"IlEstOuLeYouki" 50ab7c2f$0$21229$
Re,

Oui les deux fonctionnent, mais je remarque un problème.
Puisque la feuille se remplie au fur et à mesure, la cellule de résultat prend la valeur B même si la ligne
est vide.(elle devrait rester vide si A2 est vide).
J'ai donc remplacé la fin de la formule par SI(A2="B";"P";"")))
Mais là je ne peux avoir qu'un résultat B, le P n'apparaissant pas.

Cordialement.

"Jacky"
Bonjour,

Ceci devrait être suffisant

=SI(B2<C2;A2;SI(A2="B";"P";"B"))

--
Salutations
JJ


"IlEstOuLeYouki" 50ab7299$0$23465$
Merci mille fois, ça marche super.

cordialement.

"MichD"
Pour que la formule soit complète, il manquait un petit bout.... dont voici!

=SI(ET(A2="B";B2<C2);"B";SI(ET(A2="P";B2<C2);"P";SI(A2="B";"P";"B")))


MichD
---------------------------------------------------------------















IlEstOuLeYouki
Le #24978172
Vous savez quoi les gars ?
Vous êtes formidables.

Merci,
cordialement.


"Jacky" news:k8furm$drd$
Ou encore

S'il manque une donnée en A2 ou B2 ou C2
=SI(NBVAL(A2:C2)<>3;"";SI(B2<C2;A2;SI(A2="B";"P";"B")))

;o)
--
Salutations
JJ


"Jacky" k8fuh2$d0v$
Re...
(elle devrait rester vide si A2 est vide).



=SI(A2="";"";SI(B2<C2;A2;SI(A2="B";"P";"B")))

--
Salutations
JJ


"IlEstOuLeYouki" 50ab7c2f$0$21229$
Re,

Oui les deux fonctionnent, mais je remarque un problème.
Puisque la feuille se remplie au fur et à mesure, la cellule de résultat
prend la valeur B même si la ligne est vide.(elle devrait rester vide si
A2 est vide).
J'ai donc remplacé la fin de la formule par SI(A2="B";"P";"")))
Mais là je ne peux avoir qu'un résultat B, le P n'apparaissant pas.

Cordialement.

"Jacky" news:k8fsku$8as$
Bonjour,

Ceci devrait être suffisant

=SI(B2<C2;A2;SI(A2="B";"P";"B"))

--
Salutations
JJ


"IlEstOuLeYouki" 50ab7299$0$23465$
Merci mille fois, ça marche super.

cordialement.

"MichD" news:k8fp2o$va8$
Pour que la formule soit complète, il manquait un petit bout.... dont
voici!

=SI(ET(A2="B";B2<C2);"B";SI(ET(A2="P";B2<C2);"P";SI(A2="B";"P";"B")))


MichD
---------------------------------------------------------------



















Publicité
Poster une réponse
Anonyme