Requêtes googlebot étranges

Le
Sam
Bonjour,

Pour mon site http://www.artiste-peintre.com/ j'essaie d'optimiser le
code et les liens (rewriting url).
Les logs IIS m'indiquent des requêtes de googlebot à la racine des
sous-répertoire en appellant la page par défaut du sous-répertoire qui
n'existe pas :

2008-02-09 03:26:18 66.249.70.48 - W3SVC2 80 GET /fr/tableaux/perso/1/ -
404 3 1273 249 0 HTTP/1.1 www.artiste-peintre.com
Mozilla/5.0+(compatible;+Googlebot/2.1;++http://www.google.com/bot.html) - -

au lieu de demander : /fr/tableaux/perso/1/index.html

Est-ce normal ou j'ai fait une boulette quelque part et google a
mémorisé des mauvais liens ?

Toute remarque sur le fond et la forme est bienvenue.

Sam.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
SAM
Le #22082321
Sam a écrit :
Bonjour,

Pour mon site http://www.artiste-peintre.com/ j'essaie d'optimiser le
code et les liens (rewriting url).
Les logs IIS m'indiquent des requêtes de googlebot à la racine des
sous-répertoire en appellant la page par défaut du sous-répertoire qui
n'existe pas :

2008-02-09 03:26:18 66.249.70.48 - W3SVC2 80 GET /fr/tableaux/perso/1/ -
404 3 1273 249 0 HTTP/1.1 www.artiste-peintre.com
Mozilla/5.0+(compatible;+Googlebot/2.1;++http://www.google.com/bot.html)
- -

au lieu de demander : /fr/tableaux/perso/1/index.html

Est-ce normal ou j'ai fait une boulette quelque part et google a
mémorisé des mauvais liens ?

Toute remarque sur le fond et la forme est bienvenue.



Même si le tien est très beau, je n'aime pas qu'on me bouffe mon écran
avec de larges (et haut !) bandeaux d'en-tête.
D'autant plus que ça finit par KKbouiller les diaporamas.

la page :
http://www.artiste-peintre.com/fr/tableaux/perso/1/
n'existe pas ... hop ... 404
et là que me dit la 404 ?
Vous allez être redirigé dans *3* secondes
Pourtant, que vois-je ? :

en fait ... on n'a pas le temps de la voir ... ! ?

Est-ce que c'est ça dont tu parles à propos de rewrite ?

Ha ? ! Ben ? Tiens ? la page index.html y serait dans ce dossier ?
pourquoi ne se charge t-elle pas par défaut ?

Tu as un fichier-guide pour les robots ?

C'est tout stylé par class, c'est dommage, j'aurais bien aimé avoir un
div pour la partie diaporama afin que le changement de tableau puisse
pointer sur cette ancre et que je ne remonte pas en haut de page à
chaque nouveau tableau.


Le tableau 12 liste 1 n'est pas présenté dans le bon sens.
(à tourner d'1/4 de tour à droite)

--
sm
Sam
Le #22082311
Bonjour et merci de répondre,

SAM a écrit :
Sam a écrit :
Bonjour,

Pour mon site http://www.artiste-peintre.com/ j'essaie d'optimiser le
code et les liens (rewriting url).
Les logs IIS m'indiquent des requêtes de googlebot à la racine des
sous-répertoire en appellant la page par défaut du sous-répertoire qui
n'existe pas :

2008-02-09 03:26:18 66.249.70.48 - W3SVC2 80 GET /fr/tableaux/perso/1/
- 404 3 1273 249 0 HTTP/1.1 www.artiste-peintre.com
Mozilla/5.0+(compatible;+Googlebot/2.1;++http://www.google.com/bot.html)
- -

au lieu de demander : /fr/tableaux/perso/1/index.html

Est-ce normal ou j'ai fait une boulette quelque part et google a
mémorisé des mauvais liens ?

Toute remarque sur le fond et la forme est bienvenue.



Même si le tien est très beau, je n'aime pas qu'on me bouffe mon écran
avec de larges (et haut !) bandeaux d'en-tête.
D'autant plus que ça finit par KKbouiller les diaporamas.



Il y a une petite croix juste au dessus qui permet de réduire ce bandeau.

la page :
http://www.artiste-peintre.com/fr/tableaux/perso/1/
n'existe pas ... hop ... 404
et là que me dit la 404 ?
Vous allez être redirigé dans *3* secondes
Pourtant, que vois-je ? :
<meta http-equiv="refresh" content="0;
url=http://www.artiste-peintre.com/">

en fait ... on n'a pas le temps de la voir ... ! ?

Est-ce que c'est ça dont tu parles à propos de rewrite ?



Non, j'ai une seule page Index.asp dynamique, les sous-dossiers ne
servent qu'a envoyer des valeurs :
http://www.artiste-peintre.com/fr/tableaux/perso/1/index.html
donne :
http://www.artiste-peintre.com/Index.asp?langue=fr&page=tableaux&rubrique=perso&tableau=1

Ha ? ! Ben ? Tiens ? la page index.html y serait dans ce dossier ?
pourquoi ne se charge t-elle pas par défaut ?



Il faut une page par défaut pour un sous-répertoire ?
J' ai toujours fait mes liens en terminant par page.html
Ce que je ne comprends pas, c'est que le moteur supprime cette page.html
dans sa requête pour demander une page par défaut.

Tu as un fichier-guide pour les robots ?



Je vais bien lire ça.

C'est tout stylé par class, c'est dommage, j'aurais bien aimé avoir un
div pour la partie diaporama afin que le changement de tableau puisse
pointer sur cette ancre et que je ne remonte pas en haut de page à
chaque nouveau tableau.



Bonne idée. Je vais voir.

Le tableau 12 liste 1 n'est pas présenté dans le bon sens.
(à tourner d'1/4 de tour à droite)



Ah ?

Merci bien.
Sam.
Sam
Le #22082301
Bonjour et merci de répondre,

SAM a écrit :
Sam a écrit :
Bonjour,

Pour mon site http://www.artiste-peintre.com/ j'essaie d'optimiser le
code et les liens (rewriting url).
Les logs IIS m'indiquent des requêtes de googlebot à la racine des
sous-répertoire en appellant la page par défaut du sous-répertoire qui
n'existe pas :

2008-02-09 03:26:18 66.249.70.48 - W3SVC2 80 GET /fr/tableaux/perso/1/
- 404 3 1273 249 0 HTTP/1.1 www.artiste-peintre.com
Mozilla/5.0+(compatible;+Googlebot/2.1;++http://www.google.com/bot.html)
- -

au lieu de demander : /fr/tableaux/perso/1/index.html

Est-ce normal ou j'ai fait une boulette quelque part et google a
mémorisé des mauvais liens ?

Toute remarque sur le fond et la forme est bienvenue.



Même si le tien est très beau, je n'aime pas qu'on me bouffe mon écran
avec de larges (et haut !) bandeaux d'en-tête.
D'autant plus que ça finit par KKbouiller les diaporamas.



Il y a une petite croix juste au dessus qui permet de réduire ce bandeau.

la page :
http://www.artiste-peintre.com/fr/tableaux/perso/1/
n'existe pas ... hop ... 404
et là que me dit la 404 ?
Vous allez être redirigé dans *3* secondes
Pourtant, que vois-je ? :
<meta http-equiv="refresh" content="0;
url=http://www.artiste-peintre.com/">

en fait ... on n'a pas le temps de la voir ... ! ?

Est-ce que c'est ça dont tu parles à propos de rewrite ?



Non, j'ai une seule page Index.asp dynamique, les sous-dossiers ne
servent qu'a envoyer des valeurs :
/fr/tableaux/perso/1/index.html
donne :
/Index.asp?langue=fr&page=tableaux&rubrique=perso&tableau=1

Ha ? ! Ben ? Tiens ? la page index.html y serait dans ce dossier ?
pourquoi ne se charge t-elle pas par défaut ?



Il faut une page par défaut pour un sous-répertoire ?
J' ai toujours fait mes liens en terminant par page.html
Ce que je ne comprends pas, c'est que le moteur supprime cette page.html
dans sa requête pour demander une page par défaut.

Tu as un fichier-guide pour les robots ?



Je vais bien lire ça.

C'est tout stylé par class, c'est dommage, j'aurais bien aimé avoir un
div pour la partie diaporama afin que le changement de tableau puisse
pointer sur cette ancre et que je ne remonte pas en haut de page à
chaque nouveau tableau.



Bonne idée. Je vais voir.

Le tableau 12 liste 1 n'est pas présenté dans le bon sens.
(à tourner d'1/4 de tour à droite)



Ah pourquoi ?

Merci bien.
Sam.
SAM
Le #22082281
Sam a écrit :

Le tableau 12 liste 1 n'est pas présenté dans le bon sens.
(à tourner d'1/4 de tour à droite)





Je parle de celui-là :

Ah pourquoi ?



Je préfère, il prend un sens.

C'est pratique ces sites bien rangés
... un bon support pour des tests :-)
(on voit bien que j'ai encore à parfaire mon slide-show)

--
sm
SAM
Le #22082271
Sam a écrit :

au lieu de demander : /fr/tableaux/perso/1/index.html







sans doute parce que, normalement, la page index.html est celle par
défaut et qu'il n'est pas besoin de la mentionner dans un lien ?

Est-ce normal ou j'ai fait une boulette quelque part et google a
mémorisé des mauvais liens ?







il a sans doute mémorisé en raccourcis

Idée en l'air :
essaie d'avoir une page index moins courante ?
(ni home ni index)

ou de refaire tes liens vers l'asp sans mentionner 'index.html' ?
(puisque de toutes façons il ne sert à rien)

Même si le tien est très beau, je n'aime pas qu'on me bouffe mon écran
avec de larges (et haut !) bandeaux d'en-tête.
D'autant plus que ça finit par KKbouiller les diaporamas.



Il y a une petite croix juste au dessus qui permet de réduire ce bandeau.



Oui, j'ai fini par la voir après coup.

Non, j'ai une seule page Index.asp dynamique, les sous-dossiers ne
servent qu'a envoyer des valeurs :
/fr/tableaux/perso/1/index.html
donne :
/Index.asp?langue=fr&page=tableaux&rubrique=perso&tableau=1



Bon là ça me dépasse.
(ça me semble bien compliqué ?!)
(pourquoi ne pas mettre directement ce que ça donne ?)

Ha ? ! Ben ? Tiens ? la page index.html y serait dans ce dossier ?
pourquoi ne se charge t-elle pas par défaut ?



Il faut une page par défaut pour un sous-répertoire ?



non, pas dans ceux vers lesquels aucun lien ne pointe
(mais là il y a bien un lien qui exprime clairement path et file)
encore que ça peut aider à éviter qques fouilles-merde

J' ai toujours fait mes liens en terminant par page.html



oui mais comme ils sont bidons ... (à ce que j'ai compris)

de plus ce n'est même pas vrai puisque tu cites ton site comme :
;-)

--
sm
Sam
Le #22082261
SAM a écrit :
Sam a écrit :

au lieu de demander : /fr/tableaux/perso/1/index.html







sans doute parce que, normalement, la page index.html est celle par
défaut et qu'il n'est pas besoin de la mentionner dans un lien ?



Mais c'est bien sûr !
C'est en effet le lien commun aux requêtes à la racine du répertoire.

Est-ce normal ou j'ai fait une boulette quelque part et google a
mémorisé des mauvais liens ?







il a sans doute mémorisé en raccourcis

Idée en l'air :
essaie d'avoir une page index moins courante ?
(ni home ni index)



Je vais renommer pour voir.

[...]

Non, j'ai une seule page Index.asp dynamique, les sous-dossiers ne
servent qu'a envoyer des valeurs :
/fr/tableaux/perso/1/index.html
donne :
/Index.asp?langue=fr&page=tableaux&rubrique=perso&tableau=1



Bon là ça me dépasse.
(ça me semble bien compliqué ?!)
(pourquoi ne pas mettre directement ce que ça donne ?)



Plusieurs raisons :

- Certains moteurs ont du mal avec les liens dynamiques.
- Visuellement le lien est plus explicite pour tout le monde.
- Ca m'oblige à être plus ordonné dans l'organisation des liens.

Ha ? ! Ben ? Tiens ? la page index.html y serait dans ce dossier ?
pourquoi ne se charge t-elle pas par défaut ?



Il faut une page par défaut pour un sous-répertoire ?



non, pas dans ceux vers lesquels aucun lien ne pointe
(mais là il y a bien un lien qui exprime clairement path et file)
encore que ça peut aider à éviter qques fouilles-merde



Un grand merci.
Sam.
Publicité
Poster une réponse
Anonyme