reseau domU etch-amd64 on xen 3.0.3

Le
Patrick CAO HUU THIEN
bonjour,

suite de mes aventures pour installer debian en domU sur xen:

Apres avoir demarré la machine virtuelle, je n'ai pas de réseau !

le fichier de conf du domU (rien d'extravagant)
<code>
name = 'alcea'
memory = 256
vcpus = 2
disk = [ 'phy:/dev/VGdomU/debian-etch-1,hda1,w' ]
vif = ['bridge=xenbr0']
kernel = '/boot/domU-debian-etch-vmlinuz-2.6.18-6-xen-amd64'
ramdisk = '/boot/domU-debian-etch-initrd.img-2.6.18-6-xen-amd64'
root = '/dev/hda1 ro'
</code>

Lors du boot j'ai des messages:
<code>
Configuring network interfacesSIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
SIOCSIFNETMASK: No such device
SIOCSIFBRDADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
Failed to bring up eth0.
</code>

voici le message que j'ai dans dmesg (extrait qui me semble etre ne
rapport avec le reseau)

<code>
Bootdata ok (command line is root=/dev/hda1 ro)
Linux version 2.6.18-6-xen-amd64 (Debian 2.6.18.dfsg.1-18etch1)
(waldi@debian.or
g) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1
SMP Sun Feb 10
18:02:52 UTC 2008

NET: Registered protocol family 16
IP route cache hash table entries: 4096 (order: 3, 32768 bytes)
TCP established hash table entries: 16384 (order: 6, 262144 bytes)
TCP bind hash table entries: 8192 (order: 5, 131072 bytes)
TCP: Hash tables configured (established 16384 bind 8192)
TCP reno registered

Xen virtual console successfully installed as tty1
Event-channel device installed.
netfront: Initialising virtual ethernet driver.
Registering block device major 3
pnp: the driver 'i8042 kbd' has been registered
pnp: the driver 'i8042 aux' has been registered
pnp: the driver 'i8042 kbd' has been unregistered
pnp: the driver 'i8042 aux' has been unregistered
i8042.c: No controller found.
mice: PS/2 mouse device common for all mice
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
NET: Registered protocol family 8
NET: Registered protocol family 20
netfront: device eth0 has flipping receive path.
</code>


Si quelqu'un a une piste ???

--
Patrick CAO HUU THIEN

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilles Mocellin
Le #9701371
--nextPart60281456.97YbNp4n50
Content-Type: text/plain;
charset="iso-8859-15"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le Tuesday 11 March 2008 18:40:11 Patrick CAO HUU THIEN, vous avez écrit  :
bonjour,

suite de mes aventures pour installer debian en domU sur xen:

Apres avoir demarré la machine virtuelle, je n'ai pas de réseau !

le fichier de conf du domU (rien d'extravagant)
<code>
name = 'alcea'
memory = 256
vcpus = 2
disk = [ 'phy:/dev/VGdomU/debian-etch-1,hda1,w' ]
vif = ['bridge=xenbr0']
kernel = '/boot/domU-debian-etch-vmlinuz-2.6.18-6-xen-amd64'
ramdisk = '/boot/domU-debian-etch-initrd.img-2.6.18-6-xen-amd64'
root = '/dev/hda1 ro'
</code>

Lors du boot j'ai des messages:
<code>
Configuring network interfaces...SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
SIOCSIFNETMASK: No such device
SIOCSIFBRDADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
Failed to bring up eth0.
</code>

voici le message que j'ai dans dmesg (extrait qui me semble etre ne
rapport avec le reseau)

<code>
Bootdata ok (command line is root=/dev/hda1 ro)
Linux version 2.6.18-6-xen-amd64 (Debian 2.6.18.dfsg.1-18etch1)
(
g) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1
SMP Sun Feb 10
18:02:52 UTC 2008
...
NET: Registered protocol family 16
IP route cache hash table entries: 4096 (order: 3, 32768 bytes)
TCP established hash table entries: 16384 (order: 6, 262144 bytes)
TCP bind hash table entries: 8192 (order: 5, 131072 bytes)
TCP: Hash tables configured (established 16384 bind 8192)
TCP reno registered
...
Xen virtual console successfully installed as tty1
Event-channel device installed.
netfront: Initialising virtual ethernet driver.
Registering block device major 3
pnp: the driver 'i8042 kbd' has been registered
pnp: the driver 'i8042 aux' has been registered
pnp: the driver 'i8042 kbd' has been unregistered
pnp: the driver 'i8042 aux' has been unregistered
i8042.c: No controller found.
mice: PS/2 mouse device common for all mice
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
NET: Registered protocol family 8
NET: Registered protocol family 20
netfront: device eth0 has flipping receive path.
</code>


Si quelqu'un a une piste ???

--
Patrick CAO HUU THIEN



Il me semble avoir déjà vu ça.
Comme tu ne spécifie pas d'adresse MAC pour l'interace réseau à la li gne vif,
il doit en prendre une aléatoire à chaque démarrage de la VM.
Le script udev des cartes réseau doit ajouter à chaque fois une carte e th1,
eth2....

Vérifie dans /etc/udev/rules.d/z25_persistent-net.rules

Si c'est ien ça, tu as le choix entre :
- spécifier une adresse MAC à dans la config du DomU
- désactiver la règle udev, ou la modifiée pour que ça ne crée pas une
nouvelle insterface à chaque fois

--nextPart60281456.97YbNp4n50
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBH1xJyDltnDmLJYdARAqBMAKC3GuBXZZFFekSv91uXpvnDzFl6qgCfUeRV
YTfJCwSPNwK53GfzrpgNoyQ =Sq2D
-----END PGP SIGNATURE-----

--nextPart60281456.97YbNp4n50--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Patrick CAO HUU THIEN
Le #9700051
Gilles Mocellin a dit le 03/11/2008 11:14 PM:

Il me semble avoir déjà vu ça.
Comme tu ne spécifie pas d'adresse MAC pour l'interace réseau à la ligne vif,
il doit en prendre une aléatoire à chaque démarrage de la VM.
Le script udev des cartes réseau doit ajouter à chaque fois une carte eth1,
eth2....

Vérifie dans /etc/udev/rules.d/z25_persistent-net.rules



je n'est pas ce fichier dans mon dom0. Cela doit etre normale car il
ne s'agit pas d'une debian mais d'une centos 5 !!

Mais .... en retestant aujourd'hui ça marche.

pour archibes je remets la config du domU
<code>
name = 'alcea'
memory = 256
vcpus = 2
disk = [ 'phy:/dev/VGdomU/debian-etch-1,hda1,w' ]
vif = ['bridge=xenbr0']
kernel = '/boot/domU-debian-etch-vmlinuz-2.6.18-6-xen-amd64'
ramdisk = '/boot/domU-debian-etch-initrd.img-2.6.18-6-xen-amd64'
root = '/dev/hda1 ro'
</code>

moralité: certains jours - mieux vaux rester chez soi et s'occuper
de sa femme et ces enfants :)

PS: désolé pour le bruit

--
Patrick CAO HUU THIEN

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gilles Mocellin
Le #9699761
--nextPart13877390.rf2M3YJcEp
Content-Type: text/plain;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le Thursday 13 March 2008 15:33:12 Patrick CAO HUU THIEN, vous avez éc rit :
Gilles Mocellin a dit le 03/11/2008 11:14 PM:
> Il me semble avoir déjà vu ça.
> Comme tu ne spécifie pas d'adresse MAC pour l'interace réseau à la ligne
> vif, il doit en prendre une aléatoire à chaque démarrage de la VM.
> Le script udev des cartes réseau doit ajouter à chaque fois u ne carte
> eth1, eth2....
>
> Vérifie dans /etc/udev/rules.d/z25_persistent-net.rules

je n'est pas ce fichier dans mon dom0. Cela doit etre normale car il
ne s'agit pas d'une debian mais d'une centos 5 !!



Je pensais bien à l'intérieur du domU...

Mais .... en retestant aujourd'hui ça marche.



Moi, j'aime pas les trucs qui tombe en panne, puis en marche, sans savoir
pourquoi...

--nextPart13877390.rf2M3YJcEp
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBH2bBADltnDmLJYdARAsD/AKCppyhXEu+fOEOU/gJ5YH1Xj3iZrQCg1D/o
sEAloustDWk28Ly4aYr9nC8 =Ta7N
-----END PGP SIGNATURE-----

--nextPart13877390.rf2M3YJcEp--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Patrick CAO HUU THIEN
Le #9699711
j'ai parlé trop vite !!!!

le message d'erreur est revenu lorsque j'ai redémarré la VM !!

Mais apres avoir spécifié une adresse MAC et mis la meme dans le
domU debian dans le fichier
/etc/udev/rules.d/z25_persistent-net.rules ça remarche

merci bcp

--
Patrick CAO HUU THIEN

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme