Réseau: iMac: 1 port = plusieurs VLANs

Le
jean-pierre poindessault
Bonsoir,

Mon pb est dans le titre.
J'ai appliqué la recette de l'admin réseau sur un switch Alcatel 6024, mais mon
iMac ne peut se connecter au réseau via aucun des VLAN dans lesquels j'ai mis le
port auquel je souhaite qu'il reste connecté.
Question: plusieurs VLANs sur le port auquel est connecté ceiMac, c'est possible
?

Swich Alcatel Omnistack 6024
iMac 20" Intel Core Duo (Juillet 2006)
Je veux accéder du iMac aux VLANs 6, 8 et 10
L'IP est fixe dans chacun des VLANs.
Actuellement, je change de prise murale quand je veux changer de VLAN (1 prise
par VLAN)

config 1:
via l'interface VLAN Port configuration
je mets le port sur le VLAN poubelle 99 par défaut (untagged)
via l'interface VLAN Static Table, successivement pour les VLANs 6,8 et 10
je mets le port dans le VLAN
je vérifie qu'il n'est pas dans la liste des "untagged"
Le port est donc "untagged" en 99 et "tagged" dans les VLANs 6,8 et 10
Mon iMac ne se connecte à rien.

config 2:
via l'interface VLAN Port configuration
je mets le port sur le VLAN 8 par défaut (untagged)
via l'interface VLAN Static Table, successivement pour les VLANs 6 et 10
je mets le port dans le VLAN
je vérifie qu'il n'est pas dans la liste des "untagged"
Le port est donc "untagged" en 8 et "tagged" dans les VLANs 6 et 10
Mon iMac ne se connecte à rien.

Merci pour vos conseils.

Jean-Pierre
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Zythum
Le #779744
Bonsoir,

Mon pb est dans le titre.
J'ai appliqué la recette de l'admin réseau sur un switch Alcatel 6024, mais mon
iMac ne peut se connecter au réseau via aucun des VLAN dans lesquels j'ai mis le
port auquel je souhaite qu'il reste connecté.
Question: plusieurs VLANs sur le port auquel est connecté ceiMac, c'est possible
?


Ca dépend du switch et du matériel raccordé dessus et comme je ne
connais ni les switch Alcatel et ni le monde des MAC ....


Swich Alcatel Omnistack 6024
iMac 20" Intel Core Duo (Juillet 2006)
Je veux accéder du iMac aux VLANs 6, 8 et 10
L'IP est fixe dans chacun des VLANs.
Actuellement, je change de prise murale quand je veux changer de VLAN (1 prise
par VLAN)

config 1:
via l'interface VLAN Port configuration
je mets le port sur le VLAN poubelle 99 par défaut (untagged)
via l'interface VLAN Static Table, successivement pour les VLANs 6,8 et 10
je mets le port dans le VLAN
je vérifie qu'il n'est pas dans la liste des "untagged"
Le port est donc "untagged" en 99 et "tagged" dans les VLANs 6,8 et 10
Mon iMac ne se connecte à rien.


Ca me parait normal (si le nom "poubelle" correspond bien à l'usage du VLAN)


config 2:
via l'interface VLAN Port configuration
je mets le port sur le VLAN 8 par défaut (untagged)
via l'interface VLAN Static Table, successivement pour les VLANs 6 et 10
je mets le port dans le VLAN
je vérifie qu'il n'est pas dans la liste des "untagged"
Le port est donc "untagged" en 8 et "tagged" dans les VLANs 6 et 10
Mon iMac ne se connecte à rien.



Ben normalement il devrait causer aux machines dans le VLAN 8 (si elles
sont dans la même plage @IP que le MAC).

Merci pour vos conseils.


Juste quelques rappels (sur les VLAN par ports):

1-Port "tagged" pour un VLAN
Dans ce mode les trames appartenant à ce VLAN et qui sortent de ce port
seront au format 802.1Q
Ce format rajoute 4 octets à la trame Ethernet standard => ces trames ne
sont lisibles que par les équipements qui gèrent les trames au format 802.1Q
Dans le monde PC, par défaut, les cartes réseaux ne lisent pas ce format.
La plupart des PC arrive à lire les trames au format 802.1Q si, dans les
paramètres de la carte réseaux, on active la gestion de la QOS (802.1p,
qui utilise le même format que 802.1Q)

2-Port "untagged" pour un VLAN
Dans ce mode les trames appartenant à ce VLAN et qui sortent de ce port
seront au format Ethernet standard et pourront être lues par n'importe
quel équipement Ethernet.

3-PVID (Port VLAN ID)
Cette notion n'est pas "visible" sur tous les switch. Cette notion
concerne le trafic entrant par le port.
Toute trame au format Ethernet standard qui entre dans le switch sera
placé dans le VLAN indiqué par le PVID.
Un port peut être "untagged" dans le VLAN A (ça concernera le trafic
SORTANT) et avoir son PVID dans le VLAN B (ça concernera le trafic ENTRANT).
Sur les switch où la notion n'apparaît pas, cela veut simplement dire
que si un port est "untagged" dans le VLAN A alors son PVID est aussi
égal à A et dans ce cas le switch n'acceptera pas qu'un port puisse être
"untagged" pour plusieurs VLAN en même temps.

Maintenant parlons du coté PC (ça doit pas être très différent dans le
monde MAC)

Par défaut (même avec le 802.1p activé) un PC émet ces trames au format
Ethernet standard (ie "non tagguées").
Aussi quand le switch reçoit la trame il la place dans le VLAN
correspondant au PVID du port.
Dans ta config 1 si le PVID est de 99 et que ce VLAN te sert
effectivement de poubelle, on comprend aisément ton désarroi :-).
Dans ta config 2 si le PVID est de 8, le MAC est en mesure de causer aux
machines dans le VLAN 8.

Pour certaines cartes réseaux, les constructeurs ont fait l'effort de
développer des pilotes permettant l'émission de trames au format 802.1Q.
Ce pose alors le problème à la machine de déterminer dans quel VLAN la
trame doit être émise (sachant que le PC n'émet pas deux fois la trame
et qu'une trame ne peut être que dans un seul VLAN à la fois).
Généralement, une fois que l'on déclaré les VLAN sur le PC, on voit
autant de cartes réseaux virtuelles que de VLAN. Ensuite on défini une
@IP par carte virtuelle les @ étant de préférence dans des sous-réseaux
distinct. Ensuite c'est l'@ IP de destination qui va permettre de
déterminer qu'elle est la carte virtuelle qui va faire l'émission et
ainsi déterminer dans quel VLAN doit être marquée la trame.

Quand on cherche à faire de la communication inter-VLAN, il est plus
simple de faire du routege entre les VLAN.
Pour chaque VLAN on définit une plage d'adresses distincte. Chaque port
du switch est dans un seul VLAN à la fois et untagged, le routeur lui à
une patte dans chaque VLAN.
Bien sur, sur un LAN, si on utilise un routeur lambda on se prend une
claque en terme de performances (où alors c'est le portefeuille), aussi
généralement on utilise un switch de niveau 3 (ce que ne semble pas être
le 6024).

Pour finir, il est possible de faire de la communication inter-VLAN via
de la commutation de niveau 2 mais je ne conseille pas car très
dépendant de ce que sait faire le switch comme acrobatie et à mon avis
vite ingérable sur de gros réseaux.

Au fait quand tu postes la même questions dans plusieurs forum il est
bon de positionner le suivi sur un seul

Merci à ceux qui ont lu jusqu'au bout ;-)

--
Zythum

Nina Popravka
Le #779743
On Sun, 15 Apr 2007 09:39:16 +0200, Zythum
Merci à ceux qui ont lu jusqu'au bout ;-)


C'était beau et lumineux :-)
--
Nina

jean-pierre poindessault
Le #779742
In article
Bonsoir,

Mon pb est dans le titre.
J'ai appliqué la recette de l'admin réseau sur un switch Alcatel 6024, mais
mon
iMac ne peut se connecter au réseau via aucun des VLAN dans lesquels j'ai
mis le
port auquel je souhaite qu'il reste connecté.
Question: plusieurs VLANs sur le port auquel est connecté ceiMac, c'est
possible
?


Ca dépend du switch et du matériel raccordé dessus et comme je ne
connais ni les switch Alcatel et ni le monde des MAC ....
.............


Merci à ceux qui ont lu jusqu'au bout ;-)


J'ai lu et te remercie vivement de cet exposé qui clarifie bien des choses dans
ce que j'ai lu jusqu'ici.

JEan-Pierre


jean-pierre poindessault
Le #779741
In article Nina Popravka
On Sun, 15 Apr 2007 09:39:16 +0200, Zythum
Merci à ceux qui ont lu jusqu'au bout ;-)


C'était beau et lumineux :-)


Nina, tu as déjà mis un Mac sur plusieurs VLANs ?

Jean-Pierre


Nina Popravka
Le #779501
On Sun, 15 Apr 2007 22:31:28 +0200, jean-pierre poindessault

Nina, tu as déjà mis un Mac sur plusieurs VLANs ?


Bin non, sinon je t'aurais répondu, désolée...
--
Nina

Nina Popravka
Le #779500
On Sun, 15 Apr 2007 09:39:16 +0200, Zythum
La plupart des PC arrive à lire les trames au format 802.1Q si, dans les
paramètres de la carte réseaux, on active la gestion de la QOS (802.1p,
qui utilise le même format que 802.1Q)


Du coup, j'ai découvert que la carte 3Com de mon portable très vieux
sait le faire, alors que l'Intel de mon desktop moins vieux ne sait
pas. Dell tous les deux.
Ca m'agace...
--
Nina

Eric Masson
Le #779499
Nina Popravka
'Lut,

Du coup, j'ai découvert que la carte 3Com de mon portable très vieux
sait le faire, alors que l'Intel de mon desktop moins vieux ne sait
pas. Dell tous les deux.


Pour une EtherExpress Pro/100, amha, c'est un problème de driver, la
carte supporte VLAN_MTU depuis ses premières révisions, si j'en crois la
manpage vlan du FreeBSD installé sur ma babasse et la sortie ifconfig
suivante sur une machine chez un de mes clients :
fxp0: flagsˆ43<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=b<RXCSUM,TXCSUM,VLAN_MTU>
inet 10.93.0.5 netmask 0xffffff00 broadcast 10.93.0.255
inet6 fe80::202:b3ff:fea1:d2f%fxp0 prefixlen 64 scopeid 0x1
ether 00:02:b3:a1:0d:2f
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active

Et c'est une 82559 toute simple qui a 6 ans maintenant.

--
GA> Je propose donc pour le vote :le déplacement de tous les groupes
GA> avec renommage de fcol.moderated en fcol.modere
Mes nommages madame.
-+- FB in :
Nina Popravka
Le #779497
On Mon, 16 Apr 2007 11:41:05 +0200, Eric Masson
Pour une EtherExpress Pro/100, amha, c'est un problème de driver, la
carte supporte VLAN_MTU depuis ses premières révisions,


C'est une Pro 1000 MT, et la doc dit en effet qu'elle le fait.
Le problème, c'est que j'ai le dernier driver de chez Dell, et dans
les options y a Flow Control, LinkSpeed & Duplex, et Wake on Settings,
point barre.
Chuis vexée comme un pou :-(
Je vais quand même aller faire un tour chez Intel...
--
Nina

Eric Masson
Le #779496
Nina Popravka
C'est une Pro 1000 MT, et la doc dit en effet qu'elle le fait.


Pas la même bête que la Pro/100, mais avec une bonne réputation.

Le problème, c'est que j'ai le dernier driver de chez Dell, et dans
les options y a Flow Control, LinkSpeed & Duplex, et Wake on Settings,
point barre.


Faut voir du coté de chez Intel, en fonction du hardware, cette famille
de cartes supporte les Jumbo frames, le checksum offloading et les
vlans.

--
Suffit d'être suffisamment nombreux et tu feras moins le malin.
Voter con est une chose, s'en vanter en est une autre...
Vous êtes grotesques et dangereux.
-+- Rocou In GNU - Le quantitatif supléra-t-il le qualitatif ? -+-

Dominique ROUSSEAU
Le #779234
Le lun, 16 avr 2007 at 10:01 GMT, Nina Popravka
On Mon, 16 Apr 2007 11:41:05 +0200, Eric Masson
Pour une EtherExpress Pro/100, amha, c'est un problème de driver, la
carte supporte VLAN_MTU depuis ses premières révisions,


C'est une Pro 1000 MT, et la doc dit en effet qu'elle le fait.
Le problème, c'est que j'ai le dernier driver de chez Dell, et dans
les options y a Flow Control, LinkSpeed & Duplex, et Wake on Settings,
point barre.
Chuis vexée comme un pou :-(


Mauvais OS, changer OS ? ;-)


Publicité
Poster une réponse
Anonyme