Resultat monétaire tronquer

Le
serlep
Bonjour,
J'ai un probleme, le resultat de mon tableau est tronquer sur
certain ordinateur.

Exemple

vem_Total est un tableau de 8 monetaire

vm_Prix = 99.18

vem_Total[1] = vm_Prix

Lors de l'affichage de mon tableau il s'affiche vem_Total[1] = 99.18
mais sur certain autre ordinateur qui fonctionne sur Windows server
2003 en espagnol il affiche vem_Total[1] = 99

Est ce que quelqu'un a deja eu le meme probleme

Merci
Serge
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
patrice
Le #14502411
a écrit :
Bonjour,
J'ai un probleme, le resultat de mon tableau est tronquer sur
certain ordinateur.

Exemple

vem_Total est un tableau de 8 monetaire

vm_Prix = 99.18

vem_Total[1] = vm_Prix

Lors de l'affichage de mon tableau il s'affiche vem_Total[1] = 99.18
mais sur certain autre ordinateur qui fonctionne sur Windows server
2003 en espagnol il affiche vem_Total[1] = 99

Est ce que quelqu'un a deja eu le meme probleme

Merci
Serge



ca serait pas une histoire avec le paramétrage du . ou de la virgule,
dans les parametres internatonaux ?
Jérémy
Le #14502371
patrice a écrit :
a écrit :
Bonjour,
J'ai un probleme, le resultat de mon tableau est tronquer sur
certain ordinateur.

Exemple

vem_Total est un tableau de 8 monetaire

vm_Prix = 99.18

vem_Total[1] = vm_Prix

Lors de l'affichage de mon tableau il s'affiche vem_Total[1] = 99.18
mais sur certain autre ordinateur qui fonctionne sur Windows server
2003 en espagnol il affiche vem_Total[1] = 99

Est ce que quelqu'un a deja eu le meme probleme

Merci
Serge



ca serait pas une histoire avec le paramétrage du . ou de la virgule,
dans les parametres internatonaux ?



Bonjour,

Si c'est lors de l'affichage dans une table ou un champs, regardez pour
le type monétaire quel masque de saisie vous utilisez. Car effectivement
cela doit venir des paramètres régionaux et dans ce cas si vous utilisez
monétaire système cela posera problème. Essayez peut être de
personnaliser le masque.

Jérémy
serlep
Le #14498101
On 19 juin, 04:15, Jérémy
patrice a écrit :





> a écrit :
>> Bonjour,
>>     J'ai un probleme, le resultat de mon tableau est tronquer sur
>> certain ordinateur.

>> Exemple

>> vem_Total est un tableau de 8 monetaire

>> vm_Prix = 99.18

>> vem_Total[1] = vm_Prix

>> Lors de l'affichage de mon tableau il s'affiche vem_Total[1] = 99.18
>> mais sur certain autre ordinateur qui fonctionne sur Windows server
>> 2003 en espagnol il affiche vem_Total[1] = 99

>> Est ce que quelqu'un a deja eu le meme probleme

>> Merci
>> Serge

> ca serait pas une histoire avec le paramétrage du . ou de la virgule,
> dans les parametres internatonaux ?

Bonjour,

Si c'est lors de l'affichage dans une table ou un champs, regardez pour
le type monétaire quel masque de saisie vous utilisez. Car effectivemen t
cela doit venir des paramètres régionaux et dans ce cas si vous utili sez
monétaire système cela posera problème. Essayez peut être de
personnaliser le masque.

Jérémy- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Tous les parametres regionaux sont correct et toutes les variables
fonctionnent correctement sauf les variables tableaux en monetaire ou
reel avec decimales ne s'affiche pas correctement sur certain PC

Merci
Jérémy
Le #14498051
> Tous les parametres regionaux sont correct et toutes les variables
fonctionnent correctement sauf les variables tableaux en monetaire ou
reel avec decimales ne s'affiche pas correctement sur certain PC

Merci



Attention a l'utilisation des reels, j'ai deja eu des problemes
d'arrondis que j'ai resolu en utilisant des monetaire à la place.

Sinon l'affichage dont vous parlez est fait par une zone saisie/libelle,
une table préalablement chargee de votre du tableau, un info() ou dans
le debugueur ?

Avez vous comparez les parametres regionnaux de vos serveurs francais et
espagnol, utilisation de la virgule ou du point en separateur de
decimals ? A part ca je en vois pas trop sinon, si qq'un a une autre
idee ...
serlep
Le #14497931
On 19 juin, 11:32, Jérémy
> Tous les parametres regionaux sont correct et toutes les variables
> fonctionnent correctement sauf les variables tableaux en monetaire ou
> reel avec decimales ne s'affiche pas correctement sur certain PC

> Merci

Attention a l'utilisation des reels, j'ai deja eu des problemes
d'arrondis que j'ai resolu en utilisant des monetaire à la place.

Sinon l'affichage dont vous parlez est fait par une zone saisie/libelle,
une table préalablement chargee de votre du tableau, un info() ou dans
le debugueur ?

Avez vous comparez les parametres regionnaux de vos serveurs francais et
espagnol, utilisation de la virgule ou du point en separateur de
decimals ? A part ca je en vois pas trop sinon, si qq'un a une autre
idee ...



Oui nous avons meme comparer sur deux serveur espagnol avec les memes
parametre regionaux et il fonctionne correctement sur le premier
et tronque les decimales sur le deuxieme (a ni rien comprendre)
Publicité
Poster une réponse
Anonyme