Rétablir Grub

Le
capfree_knop
Bonjour

Je ne peux plus accéder à ma Mdv-2008.1 installée sur mon DD Sata.
Le DD IDE comportant les archives de mes instal. précédentes est en
primary master, ma carte mère n'a qu'un connecteur IDE.

Pour réparer le PC Windows d'un ami j'y ai mis son DD IDE à sa place, le
lecteur DVD étant resté en slave.
Réparé, repartitionné, (je n'ai pas manqué l'occasion d'y adjoindre la
Mdv) ça se corse: plus d'accès à mon système.

Après des recherches infructueuses, je suis arrivé à tenter de
réhabiliter le boot Grub,.. sans succès:
comme je ne trouve pas (encore?) les UUID très maniables alors à
partir de fstab et de fdisk -l je vérifie et modifie éventuellement le
menu.lst (n'oubliant pas son décalage) pour le régénérer en dur - selon
l'expression.

Mais le boot s'arrête avant l'appel de Grub, est-ce que ce menu.lst est
seul déjà pour lancer ce stade; sans passer par Grub > setup?
D'autre part je suppose que le mbr du DD IDE a imparablement la
priorité? Avec ces manoeuvres, là je me suis bien perdu :-(

Le mode rescue du CD n'a pas abouti bien sûr, et je ne veux pas tout
réinstaller.

Merci beaucoup à ceux que mon problème motivent.

--
capfree
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
moulin
Le #19626351
capfree_knop a écrit :
Bonjour

Je ne peux plus accéder à ma Mdv-2008.1 installée sur mon DD Sata.
Le DD IDE comportant les archives de mes instal. précédentes est en
primary master, ma carte mère n'a qu'un connecteur IDE.

Pour réparer le PC Windows d'un ami j'y ai mis son DD IDE à sa place, le
lecteur DVD étant resté en slave.
Réparé, repartitionné, (je n'ai pas manqué l'occasion d'y adjoindre la
Mdv) ça se corse: plus d'accès à mon système.

Après des recherches infructueuses, je suis arrivé à tenter de
réhabiliter le boot Grub,.. sans succès:
comme je ne trouve pas (encore?) les UUID très maniables alors à
partir de fstab et de fdisk -l je vérifie et modifie éventuellement le
menu.lst (n'oubliant pas son décalage) pour le régénérer en dur - selon
l'expression.

Mais le boot s'arrête avant l'appel de Grub, est-ce que ce menu.lst est
seul déjà pour lancer ce stade; sans passer par Grub > setup?
D'autre part je suppose que le mbr du DD IDE a imparablement la
priorité? Avec ces manoeuvres, là je me suis bien perdu :-(

Le mode rescue du CD n'a pas abouti bien sûr, et je ne veux pas tout
réinstaller.

Merci beaucoup à ceux que mon problème motivent.



Salut regarde ici :
http://doc.ubuntu-fr.org/tutoriel/comment_recuperer_ubuntu_apres_installation_windows#restaurer_grub_automatiquement
capfree_knop
Le #19631601
jp willm wrote:
moulin a écrit :

Salut regarde ici :
http://doc.ubuntu-fr.org/tutoriel/comment_recuperer_ubuntu_apres_installation_windows#restaurer_grub_automatiquement



où il y a un lien vers cette page :
http://doc.ubuntu-fr.org/tutoriel/comment_restaurer_grub




Oui, je l'ai vu, mais ça marche pas.

Avec Mdv rescue avant, j'avais bien eu un moment l'erreur Grub 15
«15: File not found. Cette erreur est retournée si le fichier n'est pas
trouvé, mais le reste est correct (comme les informations du disque et
de la partition)».

Et avec le CD Knoppix, déjà que Icedove et Icewaesel ne se lancent pas,
pourtant le lecteur est neuf et ce CD va bien sur un autre PC. En tapant
/media/sda3/sbin/grub je me suis ramassé une "exception en point
flottant"! faut le faire :-(
Mais enfin allant dans sbin, grub s'ouvre : root (hd1,2) pour coincer à
setup: error 11 Unrecognized device string, quand ça veut pas

pourtant fdisk -l :
/dev/hda1 etc.....
/dev/sda3 c'est bien la /

À son propre niveau il y a toujours une solution, je vais récupérer un
espace vite fait sur le IDE et installer une Mdv allégée rien que pour
régénérer le Grub sur le Sata

Merci

--
capfree
Fabien LE LEZ
Le #19631771
On Tue, 23 Jun 2009 17:59:04 +0200, capfree_knop
:

D'autre part je suppose que le mbr du DD IDE a imparablement la
priorité?



Ça dépend du BIOS. Normalement c'est réglable, d'autant que ta carte
mère n'est pas trop vieille (puisqu'elle a un port SATA).
Fabien LE LEZ
Le #19631761
On Thu, 25 Jun 2009 01:38:19 +0200, capfree_knop
:

Et avec le CD Knoppix, déjà que Icedove et Icewaesel ne se lancent pas,
pourtant le lecteur est neuf et ce CD va bien sur un autre PC. En tapant
/media/sda3/sbin/grub je me suis ramassé une "exception en point
flottant"! faut le faire :-(



Comme d'hab', les "traductions" en français sont... intéressantes, à
défaut d'être instructives.

Enfin bon, tu as des erreurs bizarres avec plusieurs OS, aussi ne
saurai-je trop te conseiller de vérifier soigneusement ton matériel.
capfree_knop
Le #19631921
Fabien LE LEZ wrote:
On Thu, 25 Jun 2009 01:38:19 +0200, capfree_knop
:

Et avec le CD Knoppix, déjà que Icedove et Icewaesel ne se lancent pas,
pourtant le lecteur est neuf et ce CD va bien sur un autre PC. En tapant
/media/sda3/sbin/grub je me suis ramassé une "exception en point
flottant"! faut le faire :-(



Comme d'hab', les "traductions" en français sont... intéressantes, à
défaut d'être instructives.

Enfin bon, tu as des erreurs bizarres avec plusieurs OS, aussi ne
saurai-je trop te conseiller de vérifier soigneusement ton matériel.




Ça pourrait bien être lui, je viens de faire l'install - 15 mn :-)
mais avec deux gels, un pour passer au champ suivant du mot de passe;
l'autre devinez où, configurer le lanceur ! Attente puis j'ai fini par
mitrailler l'entrée et les leds ont clignoté (pas convaincu la-dessus),
choix Mbr du Sata
redémarrage No active
Any key to reboot_

Je débranche le DD IDE qui est en master,
contact GRUB Loading stage1.5.

GRUB loading, please wait...
Error 21

Je remet un DD quelconque,
contact GRUB Loading stage1.5.

GRUB loading, please wait...
Error 15

ré-essai = Error 21, la led des DD reste allumée

Mise à jour hardware: carte mère Asus, processeur Intel 2 core, 2 GB Ram
Kingston du début de l'année, DD Sata de deux ans anciennement dans un
boîtier USB, graveur DVD de 2 mois à peine.

manque plus que l'âge du capitaine désemparé et pas jeune......
je cherche les boîtes noires ;-(


--
capfree
Fabien LE LEZ
Le #19631941
On Thu, 25 Jun 2009 04:11:46 +0200, capfree_knop
:

2 GB Ram
Kingston du début de l'année



Et soigneusement vérifiée par memtest86+ ?
Toute configuration RAM + CM doit être considérée comme défectueuse
tant qu'elle n'a pas été testée.
Vérifie aussi les câbles. Un de mes PC a fonctionné sans problème
pendant un sacré bout de temps. Un jour, j'ai voulu installer
Windows 2000[*], mais pas moyen -- plantages, erreurs bizarres, etc.
Au finale, il a fallu changer le câble IDE.


[*] Non, ce n'est pas si vieux que ça -- j'ai tendance à ne pas me
jeter sur les dernières versions des logiciels.
moi-meme
Le #19632211
Le Thu, 25 Jun 2009 04:36:40 +0200, Fabien LE LEZ a écrit :


Et soigneusement vérifiée par memtest86+ ?



sans couloir en rajouter :
j'ai eu des plantages du même style et c'était lié à la carte graphique.

Il n'y a pas que la mémoire qui flanche :-((
moi-meme
Le #19640151
Le Thu, 25 Jun 2009 09:21:38 +0200, Olivier Miakinen a écrit :

Le 25/06/2009 08:46, moi-meme a écrit :

Il n'y a pas que la mémoire qui flanche :-((



Je m'souviens plus très bien...



http://fr.lyrics-copy.com/jeanne-moreau/jai-la-memoire-qui-flanche.htm
capfree_knop
Le #19643731
capfree_knop wrote:
Bonjour

Je ne peux plus accéder à ma Mdv-2008.1 installée sur mon DD Sata.



[...]

Merci beaucoup à ceux que mon problème motivent.



>

Si cela aidait au diagnostic, et avant que j'aille plus loin dans le
matos mais après /cou...rageusement/ avoir débranché le DD SATA,
réinstallation Mdv allégée qui s'arrête en mode texte,
- startx:
échec avec ces mots ailés:

Module Loader present
Markers:... (==) default setting, (II) informational,

(==) Log file: "/var/log/Xorg.0.log" , Time: Thu Jun 25 19:21:51 2009
(==) Using config file: "/etc/X11/xorg.conf
(II) Module "ddc" already built-in
(II) Module "i2c" already built-in
(II) Module "ramdac already built-in
expected keysyn, got XF86Info: line 959 of inet
expected keysyn, got XF86Info: line 959 of inet
The XKEYBOARD keymap compiler (xkbcomp) reports:
- Warning: Type "ONE LEVEL" has 1 level, but <RALT> has 2 symbols
- Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

--
capfree
Publicité
Poster une réponse
Anonyme