samba et exim4 incompatibles sous lenny?

Le
patrick
--=-NM3ec7vgScI2hqv0IJRn
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Ne peut-on installer exim4 et samba sur la même bécane ???

Provisoirement (j'espère), j'ai installé samba 2:3.2.0-4 car la m=
ise à jour de sécurité de samba3 sous lenny n'est pas insta=
llable:
- en effet libldap-2.4-2 qui est une dépendance d'exim4-daemon-heavy e=
t libldap2 (une dépendance de samba dans la dernière version de s=
écurité de lenny: 3.0.28-1~lenny1) sont en conflit.

Cette incompatibilité existe depuis la correction du bug #475856 et le=
changement de librairie LDAP depuis la dernière mise à jour de s=
écurité de samba :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=475856

$ apt-cache policy samba
samba:
Installé : 2:3.2.0-4
Candidat : 2:3.2.0-4
Table de version :
*** 2:3.2.0-4 0
986 http://ftp.fr.debian.org lenny/main Packages
98 http://ftp.fr.debian.org sid/main Packages
100 /var/lib/dpkg/status
3.0.28-1~lenny1 0
988 http://security.debian.org lenny/updates/main Packages
3.0.24-6etch10 0
982 http://ftp.fr.debian.org etch/main Packages
984 http://security.debian.org etch/updates/main Packages

$ apt-cache show smbclient | grep Depends
Depends: samba-common (= 2:3.2.0-4), libc6 (>= 2.7-1), libcomerr2 (>==
1.33-3), libkrb53 (>= 1.6.dfsg.2), libldap-2.4-2 (>= 2.4.7), libncurse=
s5 (>= 5.6+20071006-3), libpopt0 (>= 1.14), libreadline5 (>= 5.2), li=
btalloc1, libwbclient0 (>= 2:3.2.0)
Depends: samba-common (= 3.0.28-1~lenny1), libc6 (>= 2.7-1), libcap1, l=
ibcomerr2 (>= 1.33-3), libkrb53 (>= 1.6.dfsg.2), libldap2 (>= 2.1.17-=
1), libncurses5 (>= 5.6+20071006-3), libpopt0 (>= 1.10), libreadline5 (=
>= 5.2)
Depends: samba-common (= 3.0.24-6etch10), libc6 (>= 2.3.6-6), libcomerr=
2 (>= 1.33-3), libkrb53 (>= 1.4.2), libldap2 (>= 2.1.17-1), libncurse=
s5 (>= 5.4-5), libpopt0 (>= 1.10), libreadline5 (>= 5.2)


$ apt-cache show exim4-daemon-heavy | grep Depends
Depends: exim4-base (>= 4.69), libc6 (>= 2.7-1), libdb4.6, libgnutls26 =
(>= 2.4.0-0), libldap-2.4-2 (>= 2.4.7), libmysqlclient15off (>= 5.0.2=
7-1), libpam0g (>= 0.99.7.1), libpcre3 (>= 7.4), libperl5.10 (>= 5.10=
.0), libpq5 (>= 8.3~beta1), libsasl2-2, libsqlite3-0 (>= 3.5.9), debcon=
f (>= 0.5) | debconf-2.0
Depends: exim4-base (>= 4.63), libc6 (>= 2.3.6-6), libdb4.3 (>= 4.3.2=
8-1), libgnutls13 (>= 1.4.0-0), libldap2 (>= 2.1.17-1), libmysqlclient1=
5off (>= 5.0.24-2), libpam0g (>= 0.76), libpcre3 (>= 4.5), libperl5.8=
(>= 5.8.8), libpq4 (>= 8.1.4), libsasl2-2, libsqlite3-0 (>= 3.3.8), =
debconf (>= 0.5) | debconf-2.0

S'agit-il d'un bug à signaler? Une prochaine mise à jour corriger=
a t-elle cette incompatibilité?
Est-il urgent d'attendre? ;-)


merci de votre aide.

--=-NM3ec7vgScI2hqv0IJRn
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: Ceci est une partie de message
=?ISO-8859-1?Q?numériquement?= =?ISO-8859-1?Q?_signée?=

--BEGIN PGP SIGNATURE--
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkiXAUIACgkQyHPpqz6NiwfD9gCfcvEhbW+84IjGSJVCGNXI8Yfq
zqUAnRTXiU28erau+xz+AdonIGUNjKE2
=fVq5
--END PGP SIGNATURE--

--=-NM3ec7vgScI2hqv0IJRn--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thomas Preud'homme
Le #16475241
--nextPart1274642.s2h0aQkpS5
Content-Type: text/plain;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le lundi 4 août 2008, patrick a écrit :
Ne peut-on installer exim4 et samba sur la même bécane ???

Provisoirement (j'espère), j'ai installé samba 2:3.2.0-4 car la mise
à jour de sécurité de samba3 sous lenny n'est pas install able: - en
effet libldap-2.4-2 qui est une dépendance d'exim4-daemon-heavy et
libldap2 (une dépendance de samba dans la dernière version de
sécurité de lenny: 3.0.28-1~lenny1) sont en conflit.

Cette incompatibilité existe depuis la correction du bug #475856 et
le changement de librairie LDAP depuis la dernière mise à jour de
sécurité de samba :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugG5856

$ apt-cache policy samba
samba:
Installé : 2:3.2.0-4
Candidat : 2:3.2.0-4
Table de version :
*** 2:3.2.0-4 0
986 http://ftp.fr.debian.org lenny/main Packages
98 http://ftp.fr.debian.org sid/main Packages
100 /var/lib/dpkg/status
3.0.28-1~lenny1 0
988 http://security.debian.org lenny/updates/main Packages
3.0.24-6etch10 0
982 http://ftp.fr.debian.org etch/main Packages
984 http://security.debian.org etch/updates/main Packages

$ apt-cache show smbclient | grep Depends
Depends: samba-common (= 2:3.2.0-4), libc6 (>= 2.7-1), libcomerr2 (> =
1.33-3), libkrb53 (>= 1.6.dfsg.2), libldap-2.4-2 (>= 2.4.7),
libncurses5 (>= 5.6+20071006-3), libpopt0 (>= 1.14), libreadline5 (> =
5.2), libtalloc1, libwbclient0 (>= 2:3.2.0) Depends: samba-common (=
3.0.28-1~lenny1), libc6 (>= 2.7-1), libcap1, libcomerr2 (>= 1.33-3),
libkrb53 (>= 1.6.dfsg.2), libldap2 (>= 2.1.17-1), libncurses5 (>=
5.6+20071006-3), libpopt0 (>= 1.10), libreadline5 (>= 5.2) Depends:
samba-common (= 3.0.24-6etch10), libc6 (>= 2.3.6-6), libcomerr2 (>=
1.33-3), libkrb53 (>= 1.4.2), libldap2 (>= 2.1.17-1), libncurses5 (> =
5.4-5), libpopt0 (>= 1.10), libreadline5 (>= 5.2)



Hummmmm étrange. La version de samba dans sid et lenny sont identiques
d'après http://packages.qa.debian.org/s/samba.html pourtant tu as des
dépendances différentes que les miennes pour smbclient. Es-tu sur une
architecture autre que x86 (je ne sais pas si des dépendances peuvent
être différentes suivant les archis).



$ apt-cache show exim4-daemon-heavy | grep Depends
Depends: exim4-base (>= 4.69), libc6 (>= 2.7-1), libdb4.6,
libgnutls26 (>= 2.4.0-0), libldap-2.4-2 (>= 2.4.7),
libmysqlclient15off (>= 5.0.27-1), libpam0g (>= 0.99.7.1), libpcre3
(>= 7.4), libperl5.10 (>= 5.10.0), libpq5 (>= 8.3~beta1), libsasl2- 2,
libsqlite3-0 (>= 3.5.9), debconf (>= 0.5) | debconf-2.0 Depends:
exim4-base (>= 4.63), libc6 (>= 2.3.6-6), libdb4.3 (>= 4.3.28-1),
libgnutls13 (>= 1.4.0-0), libldap2 (>= 2.1.17-1), libmysqlclient15off
(>= 5.0.24-2), libpam0g (>= 0.76), libpcre3 (>= 4.5), libperl5.8 (> =
5.8.8), libpq4 (>= 8.1.4), libsasl2-2, libsqlite3-0 (>= 3.3.8),
debconf (>= 0.5) | debconf-2.0

S'agit-il d'un bug à signaler? Une prochaine mise à jour corrig era
t-elle cette incompatibilité? Est-il urgent d'attendre? ;-)


merci de votre aide.



Cordialement,

Thomas Preud'homme

--
Why Debian : http://www.debian.org/intro/why_debian

--nextPart1274642.s2h0aQkpS5
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkiXB8YACgkQuQM2KpxEui451wCeKEb0n88PsLDSk6X2UUOboYOp
tQsAn1FslIY0K/QMquqDMgy4vLCvU9Sq
=0Qmc
-----END PGP SIGNATURE-----

--nextPart1274642.s2h0aQkpS5--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Charles Plessy
Le #16475231
Le Mon, Aug 04, 2008 at 03:18:10PM +0200, patrick a écrit :
Ne peut-on installer exim4 et samba sur la même bécane ???

Provisoirement (j'espère), j'ai installé samba 2:3.2.0-4 car la mise à
jour de sécurité de samba3 sous lenny n'est pas installable: - en
effet libldap-2.4-2 qui est une dépendance d'exim4-daemon-heavy et
libldap2 (une dépendance de samba dans la dernière version de sécurité
de lenny: 3.0.28-1~lenny1) sont en conflit.



Rebonjour,

je pense que si la version de Lenny est supérieure à celle de
security.debian.org, c'est bien celle-là qu'il faut installer, et que
donc il n'y a pas de problème.

Amicalement,

--
Charles Plessy
Debian Med packaging team,
Tsurumi, Kanagawa, Japan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Charles Plessy
Le #16475221
Le Mon, Aug 04, 2008 at 03:44:38PM +0200, Thomas Preud'homme a écrit :
> Table de version :
> *** 2:3.2.0-4 0
> 986 http://ftp.fr.debian.org lenny/main Packages
> 98 http://ftp.fr.debian.org sid/main Packages
> 100 /var/lib/dpkg/status
> 3.0.28-1~lenny1 0
> 988 http://security.debian.org lenny/updates/main Packages
> 3.0.24-6etch10 0
> 982 http://ftp.fr.debian.org etch/main Packages
> 984 http://security.debian.org etch/updates/main Packages
>
> $ apt-cache show smbclient | grep Depends
> Depends: samba-common (= 2:3.2.0-4), libc6 (>= 2.7-1), libcomerr2 (> > > 1.33-3), libkrb53 (>= 1.6.dfsg.2), libldap-2.4-2 (>= 2.4.7),
> libncurses5 (>= 5.6+20071006-3), libpopt0 (>= 1.14), libreadline5 (> > > 5.2), libtalloc1, libwbclient0 (>= 2:3.2.0) Depends: samba-common ( > > 3.0.28-1~lenny1), libc6 (>= 2.7-1), libcap1, libcomerr2 (>= 1.33-3),
> libkrb53 (>= 1.6.dfsg.2), libldap2 (>= 2.1.17-1), libncurses5 (> > > 5.6+20071006-3), libpopt0 (>= 1.10), libreadline5 (>= 5.2) Depends:
> samba-common (= 3.0.24-6etch10), libc6 (>= 2.3.6-6), libcomerr2 (> > > 1.33-3), libkrb53 (>= 1.4.2), libldap2 (>= 2.1.17-1), libncurses5 (> > > 5.4-5), libpopt0 (>= 1.10), libreadline5 (>= 5.2)

Hummmmm étrange. La version de samba dans sid et lenny sont identiques
d'après http://packages.qa.debian.org/s/samba.html pourtant tu as des
dépendances différentes que les miennes pour smbclient.



J'ai aussi été enduit d'erreur un moment, mais en y regardant bien, on
voit que ce sont les dépendances pour chacune des trois versions
disponibles. (Le mot-clé « Depends: » apparaît trois fois ci-dessus).

Bonne soirée,

--
Charles

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thomas Preud'homme
Le #16475541
--nextPart9258144.qGNfjWX6Bp
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le lundi 4 août 2008, Charles Plessy a écrit :
Le Mon, Aug 04, 2008 at 03:44:38PM +0200, Thomas Preud'homme a écrit :
> > Table de version :
> > *** 2:3.2.0-4 0
> > 986 http://ftp.fr.debian.org lenny/main Packages
> > 98 http://ftp.fr.debian.org sid/main Packages
> > 100 /var/lib/dpkg/status
> > 3.0.28-1~lenny1 0
> > 988 http://security.debian.org lenny/updates/main
> > Packages 3.0.24-6etch10 0
> > 982 http://ftp.fr.debian.org etch/main Packages
> > 984 http://security.debian.org etch/updates/main Packages
> >
> > $ apt-cache show smbclient | grep Depends
> > Depends: samba-common (= 2:3.2.0-4), libc6 (>= 2.7-1), libcomerr2
> > (>= 1.33-3), libkrb53 (>= 1.6.dfsg.2), libldap-2.4-2 (>= 2.4.7),
> > libncurses5 (>= 5.6+20071006-3), libpopt0 (>= 1.14), libreadline5
> > (>= 5.2), libtalloc1, libwbclient0 (>= 2:3.2.0) Depends:
> > samba-common (= 3.0.28-1~lenny1), libc6 (>= 2.7-1), libcap1,
> > libcomerr2 (>= 1.33-3), libkrb53 (>= 1.6.dfsg.2), libldap2 (>=
> > 2.1.17-1), libncurses5 (>= 5.6+20071006-3), libpopt0 (>= 1.10),
> > libreadline5 (>= 5.2) Depends: samba-common (= 3.0.24-6etch10),
> > libc6 (>= 2.3.6-6), libcomerr2 (>= 1.33-3), libkrb53 (>= 1.4.2),
> > libldap2 (>= 2.1.17-1), libncurses5 (>= 5.4-5), libpopt0 (>=
> > 1.10), libreadline5 (>= 5.2)
>
> Hummmmm étrange. La version de samba dans sid et lenny sont
> identiques d'après http://packages.qa.debian.org/s/samba.html
> pourtant tu as des dépendances différentes que les miennes pour
> smbclient.

J'ai aussi été enduit d'erreur un moment, mais en y regardant bien,
on voit que ce sont les dépendances pour chacune des trois versions
disponibles. (Le mot-clé « Depends: » apparaît trois fois ci-de ssus).

Bonne soirée,

--
Charles



Ah oui en effet cela se voyait beaucoup moins une fois le texte formatté
par kmail avec des > et la coupure à 80 caractères. Quoiqu'il en soit
la version qu'il a installé est bien la bonne pour lenny puisque son
numéro de version est plus récent que celui dans les dépôts securit y.

Cordialement,

Thomas Preud'homme

--
Why Debian : http://www.debian.org/intro/why_debian

--nextPart9258144.qGNfjWX6Bp
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkiXEhgACgkQuQM2KpxEui412wCgnaukUkxwSHycO/T5rSOMjJMn
CnYAnRFQhKqK/yvo8QTl0+qbhlZwhbNN
=OTiZ
-----END PGP SIGNATURE-----

--nextPart9258144.qGNfjWX6Bp--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
patrick
Le #16476101
--=-DQB1JHAqGDDXfKYT7cHt
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

> Hummmmm étrange. La version de samba dans sid et lenny sont identi ques
> d'après http://packages.qa.debian.org/s/samba.html pourtant tu as des
> dépendances différentes que les miennes pour smbclient.

J'ai aussi été enduit d'erreur un moment, mais en y regardant b ien, on
voit que ce sont les dépendances pour chacune des trois versions
disponibles. (Le mot-clé « Depends: » apparaît trois fois ci-dessus).



Rebonjour à tous et bonsoir à Charles,

Les lignes "Depends" étaient bien alignées sagement chez moi quan d j'ai
composé le message mais après reformatage à 80 c/lignes c'es t vrai que
c'est le binz': donc, I'm sorry.

Je me suis lourdement planté effectivement:
- exim4 et samba dans leur version lenny sont compatibles! Dans ma
migration etch -> lenny, en installant la dernière version, c'est d'ai lleurs ce que j'ai fait comme Mr
Jourdain de la prose sans le savoir...

Debian c'est décidément top moumoutte! En particulier, le sources .list
au carré: http://forum.debian-fr.org/viewtopic.php?f=8&tV59





--
-----------------------------------------------------------------------
Ma cle GPG est disponible sur http://www.keyserver.net (0x3E8D8B07)
A6FD F7B5 1D15 0294 F4E1 E6D8 C873 E9AB 3E8D 8B07
-----------------------------------------------------------------------


--=-DQB1JHAqGDDXfKYT7cHt
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: Ceci est une partie de message
=?ISO-8859-1?Q?numériquement?= =?ISO-8859-1?Q?_signée?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkiXJQIACgkQyHPpqz6NiwfLZQCcCA9J7V0pIjdYAZ2FNKe0+AzG
XTcAn2DOFWFtQdXJlWII+JqjPuK9l7/a
=JeML
-----END PGP SIGNATURE-----

--=-DQB1JHAqGDDXfKYT7cHt--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme