scanner usb non reconnu

Le
Christophe Diaz
Bonjour à tous,

Mon problème:
*****************
le scanner usb (Agfa snapscan 1212U) n'est pas reconnu, ni par lsusb qui
trouve la souris et l'appareil photo, ni par scanimage qui me renvoie
"scanimage: no SANE devices found" en root ou en user.
sane-find-scanner ne trouve rien non plus (root ou user).


La situation
**************
- le scanner est bien branché,

- Debian etch, noyau Linux 2.6.18-5-k7

- user est dans le groupe scanner

- dans etc/udev/libsane.rules il y a une ligne qui me semble
correspondre à mon scanner à savoir :
# AGFA SnapScan 1212U
SYSFS{idVendor}=="06bd", SYSFS{idProduct}=="0001", MODE="664",
GROUP="scanner"

- ce scanner marchait sur une installation similaire précédente, je
n'avais rien eu à modifier

- dans /dev, il n'y a pas de fichier scanner

- l'appareil photo, qui est aussi relié en usb, est accessible.

- la sortie de ll /dev/usb* me donne :
crw-rw- 1 root root 442, 0 2008-02-17 17:17 usbdev1.1_ep00
crw-rw- 1 root root 442, 0 2008-02-17 17:17 usbdev1.1_ep81
crw-rw- 1 root root 442, 2 2008-02-17 17:17 usbdev1.3_ep00
crw-rw- 1 root root 442, 2 2008-02-17 17:17 usbdev1.3_ep81
crw-rw- 1 root plugdev 442, 3 2008-02-17 18:09 usbdev1.4_ep00
crw-rw- 1 root plugdev 442, 3 2008-02-17 18:09 usbdev1.4_ep02
crw-rw- 1 root plugdev 442, 3 2008-02-17 18:09 usbdev1.4_ep81
crw-rw- 1 root plugdev 442, 3 2008-02-17 18:09 usbdev1.4_ep83
crw-rw- 1 root root 442, 2048 2008-02-17 17:17 usbdev2.1_ep00
crw-rw- 1 root root 442, 2048 2008-02-17 17:17 usbdev2.1_ep81

Voilà l'impasse dans laquelle je suis, est-ce que quelqu'un a une idée
pour en sortir ?
Merci pour votre aide et pour tous les échanges de la liste qui
m'apprennent beaucoup.

Christophe







--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier HUMBERT
Le #9713611
salut
que donne un dmesg après connexion du scanner ?
Amicalement,
Olivier


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Christophe Diaz
Le #9713601
Olivier HUMBERT a écrit :
salut
que donne un dmesg après connexion du scanner ?
Amicalement,
Olivier





Salut et merci de te pencher sur ce problème,

J'ai mis ci-dessous les lignes de dmesg qui me semblaient avoir un
rapport avec l'usb, mais c'est du chinois pour moi.

Bonne interprétation...
Cordialement

Christophe


---------- début des extraits de dmesg -----------------------------
usbcore: registered new driver usbfs
usbcore: registered new driver hub
.../...
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 10 ports detected
.../...
usb 1-2: new low speed USB device using ohci_hcd and address 2
usb 1-2: configuration #1 chosen from 1 choice
usbcore: registered new driver hiddev
input: Logitech USB-PS/2 Optical Mouse as /class/input/input1
input: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on
usb-0000:00:02.0-2
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
.../...
ehci_hcd 0000:00:02.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 10 ports detected
usb 1-2: USB disconnect, address 2
.../...
usb 1-2: new low speed USB device using ohci_hcd and address 3
usb 1-2: configuration #1 chosen from 1 choice
input: Logitech USB-PS/2 Optical Mouse as /class/input/input2
input: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on
usb-0000:00:02.0-2
.../...
usb 1-4: new full speed USB device using ohci_hcd and address 4
usb 1-4: configuration #1 chosen from 1 choice
usb 1-4: USB disconnect, address 4
---------- fin des extraits de dmesg -----------------------------



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Olivier HUMBERT
Le #9713571
Christophe Diaz wrote:
Salut et merci de te pencher sur ce problème,
J'ai mis ci-dessous les lignes de dmesg qui me semblaient avoir un
rapport avec l'usb, mais c'est du chinois pour moi.

Bonne interprétation...
Cordialement

Christophe


De rien ;)
On verra bien si j'arrive à te dépatouiller de là, car je n'en sais pas
vraiment plus que toi.

Peux-tu envoyer aussi le résultat d'un lsusb ?

Voilà pour l'instant
Amicalement,
Olivier

PS: peux-tu éviter de m'envoyer un message privé en même temps qu'un
message sur la liste, j'y suis abonné.
Merci


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Christophe Diaz
Le #9713551
Olivier HUMBERT a écrit :
.../...
Peux-tu envoyer aussi le résultat d'un lsusb ?




Le voici


Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 046d:c03f Logitech, Inc.
Bus 001 Device 001: ID 0000:0000

Avec le scanner branché bien sûr. Logitech, c'est ma souris usb.
IL y a 4 ports usb, 3 sont branchés en permanence côté ordi, le scanner,
la souris et le cable pour l'apn mais l'appareil photo n'est pas
forcément branché à l'autre bout. Est-ce que ceci explique pourquoi j'ai
3 ligne dans lsusb ?

Si je déplace l'un des cables usb, celui du scanner justement, j'obtiens
alors:
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 006: ID 06bd:0001 AGFA-Gevaert NV SnapScan 1212U
Bus 001 Device 003: ID 046d:c03f Logitech, Inc.
Bus 001 Device 001: ID 0000:0000
Et maintenant le scanner marche.
Par contre, en mettant l'appareil photo sur le port usb où était le
scanner, il ne marche pas. C'est donc le port usb de la carte mère qui
est mort.
Merci pour tes questions qui m'ont mise sur la piste.
PS: peux-tu éviter de m'envoyer un message privé en même temps qu'un
message sur la liste, j'y suis abonné.
Merci



Désolé, c'était une erreur de manip, je m'en suis rendu compte trop tard.

Cordialement
Christophe


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Olivier HUMBERT
Le #9713541
Christophe Diaz wrote:
Olivier HUMBERT a écrit :
.../...
Peux-tu envoyer aussi le résultat d'un lsusb ?




Le voici


Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 046d:c03f Logitech, Inc.
Bus 001 Device 001: ID 0000:0000

Avec le scanner branché bien sûr. Logitech, c'est ma souris usb.
IL y a 4 ports usb, 3 sont branchés en permanence côté ordi, le
scanner, la souris et le cable pour l'apn mais l'appareil photo n'est
pas forcément branché à l'autre bout. Est-ce que ceci explique
pourquoi j'ai 3 ligne dans lsusb ?

Si je déplace l'un des cables usb, celui du scanner justement,
j'obtiens alors:
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 006: ID 06bd:0001 AGFA-Gevaert NV SnapScan 1212U
Bus 001 Device 003: ID 046d:c03f Logitech, Inc.
Bus 001 Device 001: ID 0000:0000
Et maintenant le scanner marche.
Par contre, en mettant l'appareil photo sur le port usb où était le
scanner, il ne marche pas. C'est donc le port usb de la carte mère qui
est mort.
Merci pour tes questions qui m'ont mise sur la piste.


De rien, ça aurait été le prochain conseil que je t'aurai donné, changer
le scanner de port usb.
Content que tu aies trouvé ta panne !
(désolé pour ton port usb ... :/)

Amicalement,
Olivier


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme