Seamonkey 1.1.18 et Windows media player pour fichier MIDI

Le
René ALBERT
Salut à tous !

Il y avait longtemps que j'avais abandonné ma manie de sonoriser mes
sites, mais voila, un copain me demande de lui montrer comment on fait

Alors je lui insère cela, comme d'hab :

> <embed src="001.MID" autoplay="true" autostart="true"
> mime-type="audio/midi" loop="infinite" align="left" height="30"
> width="50">


Et la, la cata, le fichier ne s'ouvre pas, car le navigateur affiche
l'icone bleue qui demande un plugin : mais hélas seuls Quick Time et un
autre truc peu connu sont proposés par Mozilla.

Et je constate que le plugin WMP de Seamonkey ne comporte plus les
fichiers MIDI !
Et pourtant WMP sait les jouer

Va comprendre, Charles !

Qui saurait comment faire ?

Merci par avance.
--

Cordialement.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Wykaaa
Le #20265741
René ALBERT a écrit :
Salut à tous !

Il y avait longtemps que j'avais abandonné ma manie de sonoriser mes
sites, mais voila, un copain me demande de lui montrer comment on fait ...

Alors je lui insère cela, comme d'hab :

<embed src="001.MID" autoplay="true" autostart="true"
mime-type="audio/midi" loop="infinite" align="left" height="30"
width="50">




Et la, la cata, le fichier ne s'ouvre pas, car le navigateur affiche
l'icone bleue qui demande un plugin : mais hélas seuls Quick Time et un
autre truc peu connu sont proposés par Mozilla....



Pourquoi hélas ?
Quicktime permet de jouer sans problème les fichiers midi sous Windows
et Mac OS X. Sous Linux il faut peut-être Unix midi plugin.

Et je constate que le plugin WMP de Seamonkey ne comporte plus les
fichiers MIDI !
Et pourtant WMP sait les jouer...



Va comprendre, Charles !

Qui saurait comment faire ?

Merci par avance.


Sergio
Le #20266941
René ALBERT a écrit :

Il y avait longtemps que j'avais abandonné ma manie de sonoriser mes
sites, mais voila, un copain me demande de lui montrer comment on fait ...

Alors je lui insère cela, comme d'hab :

<embed src="001.MID" autoplay="true" autostart="true"
mime-type="audio/midi" loop="infinite" align="left" height="30"
width="50">




Et la, la cata, le fichier ne s'ouvre pas, car le navigateur affiche
l'icone bleue qui demande un plugin : mais hélas seuls Quick Time et un
autre truc peu connu sont proposés par Mozilla....



Pour ça, j'ai laissé tombé et j'utilise un plugin Flash...

Sinon la balise <audio> de HTML 5, mais le nombre de navigateurs installés qui le supporte...

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
René ALBERT
Le #20267111
Wykaaa a écrit:
René ALBERT a écrit :

....
Et la, la cata, le fichier ne s'ouvre pas, car le navigateur affiche
l'icone bleue qui demande un plugin : mais hélas seuls Quick Time et
un autre truc peu connu sont proposés par Mozilla....



Pourquoi hélas ?



Parce que quand on accepte d'installer ce plugin, à l'ouverture du MID ça
plante avec un message du genre "QT mal installé"...

Quicktime permet de jouer sans problème les fichiers midi sous Windows
et Mac OS X.



Oui, mais là il s'agit de plugin...

Entretemps j'ai résolu le pb en virant le QT récemment mis à jour, et en
installant une ancienne version, pour laquelle j'ai demande ensuite une
mise à jour.

Et là deux modules complémentaires manquants sont tombés du ciel, et le
plugin fonctionne à nouveau (donc ils manquent dans le download du QT récent).

Merci pour ton aide.

PS : par contre pourquoi diable WMP lit les MIDI, mais pas son plugin pour
Firefox ?


Cordialement.



http://perso.wanadoo.fr/rene.albert6
Tous mes sites à partir d'un seul écran :

Elements de Gestion Communale
Retraites , Droits de succession, IRPP, ISF
Fiabilité théorique
Bridge : conventions, code, probabilités Divertissements : casse-têtes
divers
Wykaaa
Le #20267541
René ALBERT a écrit :
Wykaaa a écrit:
René ALBERT a écrit :

....
Et la, la cata, le fichier ne s'ouvre pas, car le navigateur affiche
l'icone bleue qui demande un plugin : mais hélas seuls Quick Time et
un autre truc peu connu sont proposés par Mozilla....



Pourquoi hélas ?



Parce que quand on accepte d'installer ce plugin, à l'ouverture du MID
ça plante avec un message du genre "QT mal installé"...

Quicktime permet de jouer sans problème les fichiers midi sous Windows
et Mac OS X.



Oui, mais là il s'agit de plugin...

Entretemps j'ai résolu le pb en virant le QT récemment mis à jour, et en
installant une ancienne version, pour laquelle j'ai demande ensuite une
mise à jour.

Et là deux modules complémentaires manquants sont tombés du ciel, et le
plugin fonctionne à nouveau (donc ils manquent dans le download du QT
récent).



Hélas, il y a souvent des problèmes de ce genre avec QT sous Windows. Je
ne comprends pas pourquoi.
Je suis sur Mac et j'ai QT pro (par Logic Studio) et le plugin et je
n'ai aucun problème.
De toute façon, le MIDI (et le son d'une façon générale) a toujours été
mal traité (maltraité ?) par les différents organismes de normalisation
(en particulier le W3C).


Merci pour ton aide.



De rien.

PS : par contre pourquoi diable WMP lit les MIDI, mais pas son plugin
pour Firefox ?



Je trouve que WMP ne va pas en s'améliorant. Je veux dire le couple
WMP/plugin. Mais je trouve également que Firefox ne s'améliore pas non
plus, alors...
Plus ça va et plus je trouve que c'est Opera qui fait le mieux son
boulot et qui est le plus respectueux des standards.
Dommage que son interface ne soit pas à la hauteur (trop fouillis).

Cordialement.
Dominique Ottello
Le #20269351
René ALBERT
Alors je lui insère cela, comme d'hab :

> <embed src="001.MID" autoplay="true" autostart="true"
> mime-type="audio/midi" loop="infinite" align="left" height="30"
> width="50">



<object type="audio/x-midi" data="data/test.mid" width="200"
height="20">
<param name="autoplay" value="false">
<param name="autoStart" value="0">
alt : </object>
--
Ce n'est pas parce que l'erreur se propage qu'elle devient vérité. Gandhi
Technologie aéronautique : http://aviatechno.free.fr (http://ottello.net)
Concorde dans la presse de 1965 à 2003 : http://le.pointu.free.fr
René ALBERT
Le #20277561
Dominique Ottello a écrit:
René ALBERT
Alors je lui insère cela, comme d'hab :

<embed src="001.MID" autoplay="true" autostart="true"
mime-type="audio/midi" loop="infinite" align="left" height="30"
width="50">





<object type="audio/x-midi" data="data/test.mid" width="200"
height="20">
<param name="autoplay" value="false">
<param name="autoStart" value="0">
alt : </object>



C'est plus conforme aux normes, mais le pb n'était pas là...
merci quand même.

--

Cordialement.



http://perso.wanadoo.fr/rene.albert6
Tous mes sites à partir d'un seul écran :

Elements de Gestion Communale
Retraites , Droits de succession, IRPP, ISF
Fiabilité théorique
Bridge : conventions, code, probabilités Divertissements : casse-têtes
divers
Publicité
Poster une réponse
Anonyme