securite

Le
Michel Labato
bonjour, je suis obligé de garder Windows 95 et, par conséquent, IE5 sur
l'un de mes PC en me connectant sur 1 site, j'ai le message suivant :
SSL Alert
> The browser and the web-site cannot communicate securely because there are
> no common encryption algorithms.
>
> Please try the following:
>
> - Check the SSL protocol settings on the browser for SSLv3/TLSv1 protocol
> support.
>
> - The secure web-site may be using high-strength encryption algorithms(128
> bit).
> Check the SSL settings on your browser, if it supports high-strength
> encryption algorithms.
>
> - Upgrade your browser to latest version.

Y a t-il une solution ? merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Xavier
Le #16561041
"Michel Labato" message de news:
bonjour, je suis obligé de garder Windows 95 et, par conséquent, IE5
sur l'un de mes PC... en me connectant sur 1 site, j'ai le message
suivant :
SSL Alert
The browser and the web-site cannot communicate securely because
there are
no common encryption algorithms.

Please try the following:

- Check the SSL protocol settings on the browser for SSLv3/TLSv1
protocol
support.

- The secure web-site may be using high-strength encryption
algorithms(128
bit).
Check the SSL settings on your browser, if it supports high-strength
encryption algorithms.

- Upgrade your browser to latest version.



Y a t-il une solution ? merci d'avance




Quelle est votre version d'Internet Explorer ? 4.. 5.. ?
Et votre version de W95 ? OSR1.. OSR2.. a... b... c...
cartomi
Le #16561131
Il se trouve que Xavier a formulé :

Quelle est votre version d'Internet Explorer ? 4.. 5.. ?



la réponse est la :
bonjour, je suis obligé de garder Windows 95 et, par conséquent, IE5





;-)

--
amicalement !
Xavier
Le #16566031
"cartomi" <cartomi chez free @> a écrit dans le message de news:

Il se trouve que Xavier a formulé :

Quelle est votre version d'Internet Explorer ? 4.. 5.. ?



la réponse est la :
bonjour, je suis obligé de garder Windows 95 et, par conséquent, IE5





;-)

--
amicalement !




Ooops !
|-)

Merci de m'avoir ouvert les yeux cartomi !

amha le message correspond à la tentative d'authentification du client
par le serveur https qui réclame le protocole TLSv1 ainsi que le niveau
minimum de cryptage SSL3, et comme le serveur ne détecte pas ce niveau
d'équipement sur le client il refuse d'aller plus loin et ne va pas
consulter le magasin de certificats X.509 du client.

C'est avec IE5.5 (livré avec Windows Millenium) qu'est arrivé le
cryptage sur 128 bits (AES) en standart.
IE5 ne crypte que sur 40 bit (DES) ou qqchose comme ça... (petit rappel
historique : en France, ce n'est qu'en 1999 que la taille des clés de
chiffrement a été autorisé par Lionel Jospin au-delà des 40 bits et
jusqu'à 128 bits) d'où certainement le refus des sites web protégés en
https d'échanger des données avec le trop bas niveau de cryptage de
votre navigateur. De plus le magasin de certificats d'IE5.0/.1 ne
convient pas non plus avec les normes d'aujourd'hui.

Dans le menu d'IE5, cliquer sur le ? puis sur "Informations système" (je
ne souviens plus du tout de la dénomination exacte dans W95) et vérifier
le niveau du cryptage disponible, au cas où votre version d'IE5 ait
bénéficiée d'un update du ssl.
Puis, regarder dans les options avancées d'IE si vous disposez des cases
à cocher permettant de valider l'usage du ssl en 128bits (SSL2 SSL3).

Il a certainement du y avoir un update dédié permettant de porter le
niveau de cryptage d'IE5.1 à 128 bit, ou bien aussi vous auriez pu
envisager d'installer IE5.5 sur W95 (IE6 incompatible avec W95), mais je
crains qu'il y ait peu d'espoir de mettre la main dessus du fait que W95
n'est plus maintenu depuis longtemps.

Vous pouvez tester votre ssl sur une page spéciale de test de la Banque
populaire ici par exemple :

https://www.secure-ssl.net/digitalconcept.fr/Navitest.php

si vous cliquez ensuite sur le bouton "actualiser" de la page de
résultat, vous ouvrirez une autre page web avec des liens vers des
*patchs* de MAJ du SSL pour différents navigateurs (il s'agit de liens
vers des sites ftp en miroir de ceux de µ$). Malheureusement tous les
liens sont brisés... et il n'y a quasiment plus rien dans le dossier
"win95" du site ftp de µ$...
:-(

Une solution (peut être) si impossible de trouver une MAJ du ssl d'IE5
pour W95, ou un update en IE5.5, laisser tomber IE5 et tenter de trouver
un navigateur tiers avec ssl en 128 bits et fonctionnant sous votre
version de W95...

Eventuellement, si ça doit se faire manuellement, Il y a une procédure
pour déconnecter Internet Explorer de Windows.

Pour finir, si votre problème est d'être coincé par une machine peu
puissante, peut être pourriez vous quand même envisager au moins un
W98SE avec IE6 qui tourne sur un PC Pentium 133 avec seulement 32 MO de
Ram... voire même 16 Mo seulement en l'allégeant avec "98lite"...
Mais ce n'est qu'une suggestion.
Xavier
Le #16566311
bon et bien on peut dire que vous êtes verni... j'y croyais pas... mais
par curiosité j'ai quand même jeté un oeil chez µ$ et, à ma grande
surprise, j'y ai trouvé la MAJ pour W95 qu'il vous faut !

http://www.microsoft.com/downloads/details.aspx?familyid»CAAE86-F80D-4D0C-8FA2-78A8868652E0&displaylang=en

Dites nous si ça marche...
cartomi
Le #16566301
Xavier a exposé le 17/08/2008 :
"cartomi" <cartomi chez free @> a écrit dans le message de news:

Il se trouve que Xavier a formulé :

Quelle est votre version d'Internet Explorer ? 4.. 5.. ?



la réponse est la :
bonjour, je suis obligé de garder Windows 95 et, par conséquent, IE5





;-)

-- amicalement !




Ooops !
|-)

Merci de m'avoir ouvert les yeux cartomi !

amha le message correspond à la tentative d'authentification du client par le
serveur https qui réclame le protocole TLSv1 ainsi que le niveau minimum de
cryptage SSL3, et comme le serveur ne détecte pas ce niveau d'équipement sur
le client il refuse d'aller plus loin et ne va pas consulter le magasin de
certificats X.509 du client.

C'est avec IE5.5 (livré avec Windows Millenium) qu'est arrivé le cryptage sur
128 bits (AES) en standart.
IE5 ne crypte que sur 40 bit (DES) ou qqchose comme ça... (petit rappel
historique : en France, ce n'est qu'en 1999 que la taille des clés de
chiffrement a été autorisé par Lionel Jospin au-delà des 40 bits et jusqu'à
128 bits) d'où certainement le refus des sites web protégés en https
d'échanger des données avec le trop bas niveau de cryptage de votre
navigateur. De plus le magasin de certificats d'IE5.0/.1 ne convient pas non
plus avec les normes d'aujourd'hui.

Dans le menu d'IE5, cliquer sur le ? puis sur "Informations système" (je ne
souviens plus du tout de la dénomination exacte dans W95) et vérifier le
niveau du cryptage disponible, au cas où votre version d'IE5 ait bénéficiée
d'un update du ssl.
Puis, regarder dans les options avancées d'IE si vous disposez des cases à
cocher permettant de valider l'usage du ssl en 128bits (SSL2 SSL3).

Il a certainement du y avoir un update dédié permettant de porter le niveau
de cryptage d'IE5.1 à 128 bit, ou bien aussi vous auriez pu envisager
d'installer IE5.5 sur W95 (IE6 incompatible avec W95), mais je crains qu'il y
ait peu d'espoir de mettre la main dessus du fait que W95 n'est plus maintenu
depuis longtemps.




on trouve encore IE 5.5 ici :
http://mi.cnrs-orleans.fr/Updates/Update.htm

--
amicalement !
Michel Labato
Le #17250721
bonjour,
j'ai fait la maj et ça marche ...
Merci à tous... car suis obligé garder W95 car Pentium 75 ... je garde cette
machine en plus car toujours pas d'équivalent actuellement question gabarit
(libretto toshiba).
"Xavier" eH%
bon et bien on peut dire que vous êtes verni... j'y croyais pas... mais
par curiosité j'ai quand même jeté un oeil chez µ$ et, à ma grande
surprise, j'y ai trouvé la MAJ pour W95 qu'il vous faut !

http://www.microsoft.com/downloads/details.aspx?familyid»CAAE86-F80D-4D0C-8FA2-78A8868652E0&displaylang=en

Dites nous si ça marche...


Publicité
Poster une réponse
Anonyme