séparé des données d'une colonne

Le
Marc
Bonjour à vous tous
J'ai des nombres dans une colonne. Ces nombres sont en formats standard (ils
proviennent d'un autre logiciel).
Certains sont alignés à droite, d'autre à gauche.
Ce que j'aimerais, c'est d'avoir ceux à droite dans une colonne et ceux à
gauche, dans un autre.
J'ai essayé avec convertir, mais ça fonctionne pas.
Je suis avec Excel 2003.
Merci
Marc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FdeCourt
Le #21201771
Salut,

Avec une macro :

Si les données de la colonne A sont alignées à gauche, alors elles
iront dans la colonne B, sinon dans la colonne C

Sub decaler_en_fonction_alignement()
colonneDonnees = 1
ColonneGauche = 2
ColonneDroite = 3

For x = 1 To 10
If Cells(x, colonneDonnees).HorizontalAlignment = xlLeft Then
Cells(x, ColonneGauche).Value = Cells(x,
colonneDonnees).Value
Else
Cells(x, ColonneDroite).Value = Cells(x,
colonneDonnees).Value
End If
Next
End Sub

Cordialement,

F.
Marc
Le #21201971
Bonjour FdeCour
1. Dans la vrai vie, mes données sont dans la colonne G
2. J'ai plus de 6000 lignes de données
3. J'ai fait un copier-coller pour mettre les données dans la colonne A. La
macro présentement, ne fait que ré-écrire, dans la colonne C la données
inscrite dans la colonne A
Merci de continuer à m'aider.
Marc


"FdeCourt"
Salut,

Avec une macro :

Si les données de la colonne A sont alignées à gauche, alors elles
iront dans la colonne B, sinon dans la colonne C

Sub decaler_en_fonction_alignement()
colonneDonnees = 1
ColonneGauche = 2
ColonneDroite = 3

For x = 1 To 10
If Cells(x, colonneDonnees).HorizontalAlignment = xlLeft Then
Cells(x, ColonneGauche).Value = Cells(x,
colonneDonnees).Value
Else
Cells(x, ColonneDroite).Value = Cells(x,
colonneDonnees).Value
End If
Next
End Sub

Cordialement,

F.
Jacky
Le #21201961
Bonjour,

A tout hasard essaye ceci
Les chiffres en colonne A
En B1
=SI(A1<>CNUM(A1);CNUM(A1);"")
En C1
=SI(A1=CNUM(A1);A1;"")
Recopier vers le bas aussi loin que besoin.

Pour pouvoir supprimer la colonne A
Faire un copier / collage spécial==>valeurs sur les colonnes B et C
--
Salutations
JJ


"Marc"
Bonjour à vous tous
J'ai des nombres dans une colonne. Ces nombres sont en formats standard (ils proviennent d'un autre
logiciel).
Certains sont alignés à droite, d'autre à gauche.
Ce que j'aimerais, c'est d'avoir ceux à droite dans une colonne et ceux à gauche, dans un autre.
J'ai essayé avec convertir, mais ça fonctionne pas.
Je suis avec Excel 2003.
Merci
Marc



marc
Le #21202841
Bonjour Jacky
Ça ne fonctionne pas tous le temps
Je te joins un exemple
merci de ton aide
http://cjoint.com/?cptVSROClg
Marc


"Jacky" news:
Bonjour,

A tout hasard essaye ceci
Les chiffres en colonne A
En B1
=SI(A1<>CNUM(A1);CNUM(A1);"")
En C1
=SI(A1=CNUM(A1);A1;"")
Recopier vers le bas aussi loin que besoin.

Pour pouvoir supprimer la colonne A
Faire un copier / collage spécial==>valeurs sur les colonnes B et C
--
Salutations
JJ


"Marc" urL$
Bonjour à vous tous
J'ai des nombres dans une colonne. Ces nombres sont en formats standard
(ils proviennent d'un autre logiciel).
Certains sont alignés à droite, d'autre à gauche.
Ce que j'aimerais, c'est d'avoir ceux à droite dans une colonne et ceux à
gauche, dans un autre.
J'ai essayé avec convertir, mais ça fonctionne pas.
Je suis avec Excel 2003.
Merci
Marc







FdeCourt
Le #21203131
Salut,

En fonction de ton classeur :
En colonne B : =SI(A1<>CNUM(SUBSTITUE(A1;" ";""));A1;"")
En colonne C : =SI(A1<>CNUM(SUBSTITUE(A1;" ";""));"";A1)

Par contre, le caractère qui sépare le 4 du 5 dans 4 500 ne semble pas
être un espace.
Si besoin, directement dans ton classeur, copie ce caractère et colle
le entre les premiers guillemets de la formule.

Cordialement,

F.
Sam
Le #21203451
Bonjour,
dans ta colonne, tu as des nombres (à droite) et du texte (à gauche)
Pour le texte, ce qui semble être un espace est en réalité le caractère 160

je propose donc ceci
en B1 : =SI(ESTNUM(A1);A1;"")
en C1 : =SI(ESTNUM(A1);"";CNUM(SUBSTITUE(A1;CAR(160);"")))
Cordialement
Michel dit "Sam"

"Marc" urL$
Bonjour à vous tous
J'ai des nombres dans une colonne. Ces nombres sont en formats standard
(ils proviennent d'un autre logiciel).
Certains sont alignés à droite, d'autre à gauche.
Ce que j'aimerais, c'est d'avoir ceux à droite dans une colonne et ceux à
gauche, dans un autre.
J'ai essayé avec convertir, mais ça fonctionne pas.
Je suis avec Excel 2003.
Merci
Marc



Jacky
Le #21203911
Re...
Quel est le symbole décimale ?
Le point ou la virgule ?
12.25
ou
125,25
--
Salutations
JJ


"Jacky"
Bonjour,

A tout hasard essaye ceci
Les chiffres en colonne A
En B1
=SI(A1<>CNUM(A1);CNUM(A1);"")
En C1
=SI(A1=CNUM(A1);A1;"")
Recopier vers le bas aussi loin que besoin.

Pour pouvoir supprimer la colonne A
Faire un copier / collage spécial==>valeurs sur les colonnes B et C
--
Salutations
JJ


"Marc"
Bonjour à vous tous
J'ai des nombres dans une colonne. Ces nombres sont en formats standard (ils proviennent d'un autre
logiciel).
Certains sont alignés à droite, d'autre à gauche.
Ce que j'aimerais, c'est d'avoir ceux à droite dans une colonne et ceux à gauche, dans un autre.
J'ai essayé avec convertir, mais ça fonctionne pas.
Je suis avec Excel 2003.
Merci
Marc







marc
Le #21205051
Bonsoir Jacky
C'est la virgule et non le point
Merci
Marc

"Jacky" news:%23SwMh$
Re...
Quel est le symbole décimale ?
Le point ou la virgule ?
12.25
ou
125,25
--
Salutations
JJ


"Jacky"
Bonjour,

A tout hasard essaye ceci
Les chiffres en colonne A
En B1
=SI(A1<>CNUM(A1);CNUM(A1);"")
En C1
=SI(A1=CNUM(A1);A1;"")
Recopier vers le bas aussi loin que besoin.

Pour pouvoir supprimer la colonne A
Faire un copier / collage spécial==>valeurs sur les colonnes B et C
--
Salutations
JJ


"Marc" urL$
Bonjour à vous tous
J'ai des nombres dans une colonne. Ces nombres sont en formats standard
(ils proviennent d'un autre logiciel).
Certains sont alignés à droite, d'autre à gauche.
Ce que j'aimerais, c'est d'avoir ceux à droite dans une colonne et ceux
à gauche, dans un autre.
J'ai essayé avec convertir, mais ça fonctionne pas.
Je suis avec Excel 2003.
Merci
Marc











marc
Le #21205041
Bonsoir Michel dit "Sam"
Ta formule fonctionne parfaitement.
Un gros merci

"Sam" news:4b79a479$0$934$
Bonjour,
dans ta colonne, tu as des nombres (à droite) et du texte (à gauche)
Pour le texte, ce qui semble être un espace est en réalité le caractère
160

je propose donc ceci
en B1 : =SI(ESTNUM(A1);A1;"")
en C1 : =SI(ESTNUM(A1);"";CNUM(SUBSTITUE(A1;CAR(160);"")))
Cordialement
Michel dit "Sam"

"Marc" urL$
Bonjour à vous tous
J'ai des nombres dans une colonne. Ces nombres sont en formats standard
(ils proviennent d'un autre logiciel).
Certains sont alignés à droite, d'autre à gauche.
Ce que j'aimerais, c'est d'avoir ceux à droite dans une colonne et ceux à
gauche, dans un autre.
J'ai essayé avec convertir, mais ça fonctionne pas.
Je suis avec Excel 2003.
Merci
Marc







Jacky
Le #21205601
Re..
C'est la virgule et non le point


Alors la proposition de Sam doit convenir.

--
Salutations
JJ


"marc"
Bonsoir Jacky
C'est la virgule et non le point
Merci
Marc

"Jacky"
Re...
Quel est le symbole décimale ?
Le point ou la virgule ?
12.25
ou
125,25
--
Salutations
JJ


"Jacky"
Bonjour,

A tout hasard essaye ceci
Les chiffres en colonne A
En B1
=SI(A1<>CNUM(A1);CNUM(A1);"")
En C1
=SI(A1=CNUM(A1);A1;"")
Recopier vers le bas aussi loin que besoin.

Pour pouvoir supprimer la colonne A
Faire un copier / collage spécial==>valeurs sur les colonnes B et C
--
Salutations
JJ


"Marc"
Bonjour à vous tous
J'ai des nombres dans une colonne. Ces nombres sont en formats standard (ils proviennent d'un autre
logiciel).
Certains sont alignés à droite, d'autre à gauche.
Ce que j'aimerais, c'est d'avoir ceux à droite dans une colonne et ceux à gauche, dans un autre.
J'ai essayé avec convertir, mais ça fonctionne pas.
Je suis avec Excel 2003.
Merci
Marc














Publicité
Poster une réponse
Anonyme