série de dates décalées

Le
j-pascal
Bonsoir,

Sur une ligne, j'ai besoin d'avoir dans les colonnes successives :
Tous les mercredis et vendredis, dans l'ordre chronologique et pour un
mois donné.
Ex pour ce mois de novembre :
Mer05 - Ven07 - Mer12 - Ven14 - Mer19 - Ven21 - Mer26 - Ven28

Merci pour votre aide
JP
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #17805271
bonjour JP,

=SI(JOURSEM(A1)=4;A1+2;A1+5)

isabelle

j-pascal a écrit :
Bonsoir,

Sur une ligne, j'ai besoin d'avoir dans les colonnes successives :
Tous les mercredis et vendredis, dans l'ordre chronologique et pour un
mois donné.
Ex pour ce mois de novembre :
Mer05 - Ven07 - Mer12 - Ven14 - Mer19 - Ven21 - Mer26 - Ven28

Merci pour votre aide
JP




j-pascal
Le #17806461
Bonjour Isabelle,

Génial(e), merci !
JP
bonjour JP,

=SI(JOURSEM(A1)=4;A1+2;A1+5)

isabelle

j-pascal a écrit :
Bonsoir,

Sur une ligne, j'ai besoin d'avoir dans les colonnes successives :
Tous les mercredis et vendredis, dans l'ordre chronologique et pour un mois
donné.
Ex pour ce mois de novembre :
Mer05 - Ven07 - Mer12 - Ven14 - Mer19 - Ven21 - Mer26 - Ven28

Merci pour votre aide
JP




j-pascal
Le #17806611
Re,
J'aurais aimé que la série s'arrête à la fin du mois. Si je fais ce qui
suit, j'ai évidemment une réf. circulaire ... :

=SI(MOIS(B1)>MOIS(A1);"";SI(JOURSEM(A1)=4;A1+2;A1+5))

Je peux toujours faire un MEFC qui masque ce dont je n'ai pas besoin
mais ce n'est pas très "pro".

JP
bonjour JP,

=SI(JOURSEM(A1)=4;A1+2;A1+5)

isabelle

j-pascal a écrit :
Bonsoir,

Sur une ligne, j'ai besoin d'avoir dans les colonnes successives :
Tous les mercredis et vendredis, dans l'ordre chronologique et pour un mois
donné.
Ex pour ce mois de novembre :
Mer05 - Ven07 - Mer12 - Ven14 - Mer19 - Ven21 - Mer26 - Ven28

Merci pour votre aide
JP




Charabeuh
Le #17807061
Bonjour,

essayez :

=SI(A1="";""; SI(JOURSEM(A1)=4;SI(MOIS(A1+2)=MOIS(A1);A1+2;"");SI(MOIS(A1+5)=MOIS(A1);A1+5;"")))

Salut


"j-pascal"
Re,
J'aurais aimé que la série s'arrête à la fin du mois. Si je fais ce qui suit, j'ai évidemment une réf. circulaire ... :

=SI(MOIS(B1)>MOIS(A1);"";SI(JOURSEM(A1)=4;A1+2;A1+5))

Je peux toujours faire un MEFC qui masque ce dont je n'ai pas besoin mais ce n'est pas très "pro".

JP
bonjour JP,

=SI(JOURSEM(A1)=4;A1+2;A1+5)

isabelle

j-pascal a écrit :
Bonsoir,

Sur une ligne, j'ai besoin d'avoir dans les colonnes successives :
Tous les mercredis et vendredis, dans l'ordre chronologique et pour un mois donné.
Ex pour ce mois de novembre :
Mer05 - Ven07 - Mer12 - Ven14 - Mer19 - Ven21 - Mer26 - Ven28

Merci pour votre aide
JP








j-pascal
Le #17807211
Bonjour,
Merci, c'est parfait !
JP

Bonjour,

essayez :

=SI(A1="";"";
SI(JOURSEM(A1)=4;SI(MOIS(A1+2)=MOIS(A1);A1+2;"");SI(MOIS(A1+5)=MOIS(A1);A1+5;"")))

Salut


"j-pascal" news:
Re,
J'aurais aimé que la série s'arrête à la fin du mois. Si je fais ce qui
suit, j'ai évidemment une réf. circulaire ... :

=SI(MOIS(B1)>MOIS(A1);"";SI(JOURSEM(A1)=4;A1+2;A1+5))

Je peux toujours faire un MEFC qui masque ce dont je n'ai pas besoin mais
ce n'est pas très "pro".

JP
bonjour JP,

=SI(JOURSEM(A1)=4;A1+2;A1+5)

isabelle

j-pascal a écrit :
Bonsoir,

Sur une ligne, j'ai besoin d'avoir dans les colonnes successives :
Tous les mercredis et vendredis, dans l'ordre chronologique et pour un
mois donné.
Ex pour ce mois de novembre :
Mer05 - Ven07 - Mer12 - Ven14 - Mer19 - Ven21 - Mer26 - Ven28

Merci pour votre aide
JP










Publicité
Poster une réponse
Anonyme