service autoexnt

Le
Pascal
Bonjour,
j'utilise le service autoexnt pour mapper des ressources depuis un serveur samba.
j'utilise pour cela dans mon autoexnt.bat la commande net use sans login/passowrd

Ce service est lancé en tant que système local, mais je n'arrive pas bien à
comprendre quel login/password est utilisé lors d'opérations via ce service.

Or sans option d'authentification ma commande net use fonctionne correctement.

La seule piste que j'ai, est que le compte administrateur local est identique à
celui déclaré sur mon serveur samba (même nom d'utilisateur et même mot de
passe, cela veut t'il dire que le compte "système local"
utilise le compte administrateur pour s'authentifier ?

merci pour vos pistes ou réponses
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Claude BELLAMY
Le #18046691
"Pascal" news:4937e4c5$0$16764$
Bonjour,
j'utilise le service autoexnt pour mapper des ressources depuis un serveur
samba.
j'utilise pour cela dans mon autoexnt.bat la commande net use sans
login/passowrd


Ah bon ?????
Les bras m'en tombent, comme disait la petite Minus de vélo ! ;-)

Ce service est lancé en tant que système local, mais je n'arrive pas bien
à comprendre quel login/password est utilisé lors d'opérations via ce
service.



Sous quel OS es-tu ?
Car çà varie !
http://msdn.microsoft.com/en-us/library/ms686005(VS.85).aspx

Sous W2K, il n'y a qu'un seul compte "spécial", c'est le compte SYSTEM (NT
AUTHORITYSYSTEM)
Pas de profil

Sous XP, c'est le compte "LocalService" (NT AUTHORITYLOCALSERVICE).
Le profil est x:Documents and SettingsLocalService.AUTORITE NT

Sous VISTA, c'est aussi le compte "LocalService", mais géré différemment de
XP.
le profil est "%systemroot%system32configSystemprofile"

Dans TOUS les cas, le password est vide.

Or sans option d'authentification ma commande net use fonctionne
correctement.


Alors çà, c'est bizarre autant qu'étrange !

J'ai essayé sous W2K, XP et VISTA :
J'ai tapé la commande "NET USE * ..." dans une fenêtre de commandes lancée
par l'autoexnt.bat (afin de "voir" les messages éventuels)
Et bien à chaque fois j'ai été "sommé" de fournir un nom de compte et
password !
Et cela me semble normal, car si le compte SYSTEM (ou LocalService) a tous
les droits en local, il n'en a aucun à distance...

La seule piste que j'ai, est que le compte administrateur local est
identique à celui déclaré sur mon serveur samba (même nom d'utilisateur et
même mot de passe, cela veut t'il dire que le compte "système local"
utilise le compte administrateur pour s'authentifier ?



Vu que ce n'est pas le cas chez moi, sur 3 machines différents, avec 3 OS
différents, cela ne peut être le cas.
La seule explication que je vois, c'est que ton serveur SAMBA est très
conciliant au niveau partage et permissions!
Quelle version de Samba utilises-tu ?

As-tu essayé un tel montage réseau vers une autre machine sous Windows ?


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org
Pascal
Le #18046671
-------- Message original --------

"Pascal" news:4937e4c5$0$16764$
Bonjour,
j'utilise le service autoexnt pour mapper des ressources depuis un serveur
samba.
j'utilise pour cela dans mon autoexnt.bat la commande net use sans
login/passowrd


Ah bon ?????
Les bras m'en tombent, comme disait la petite Minus de vélo ! ;-)

Ce service est lancé en tant que système local, mais je n'arrive pas bien
à comprendre quel login/password est utilisé lors d'opérations via ce
service.



Sous quel OS es-tu ?
Car çà varie !
http://msdn.microsoft.com/en-us/library/ms686005(VS.85).aspx

Sous W2K, il n'y a qu'un seul compte "spécial", c'est le compte SYSTEM (NT
AUTHORITYSYSTEM)
Pas de profil

Sous XP, c'est le compte "LocalService" (NT AUTHORITYLOCALSERVICE).
Le profil est x:Documents and SettingsLocalService.AUTORITE NT

Sous VISTA, c'est aussi le compte "LocalService", mais géré différemment de
XP.
le profil est "%systemroot%system32configSystemprofile"

Dans TOUS les cas, le password est vide.

Or sans option d'authentification ma commande net use fonctionne
correctement.


Alors çà, c'est bizarre autant qu'étrange !

J'ai essayé sous W2K, XP et VISTA :
J'ai tapé la commande "NET USE * ..." dans une fenêtre de commandes lancée
par l'autoexnt.bat (afin de "voir" les messages éventuels)
Et bien à chaque fois j'ai été "sommé" de fournir un nom de compte et
password !
Et cela me semble normal, car si le compte SYSTEM (ou LocalService) a tous
les droits en local, il n'en a aucun à distance...

La seule piste que j'ai, est que le compte administrateur local est
identique à celui déclaré sur mon serveur samba (même nom d'utilisateur et
même mot de passe, cela veut t'il dire que le compte "système local"
utilise le compte administrateur pour s'authentifier ?



Vu que ce n'est pas le cas chez moi, sur 3 machines différents, avec 3 OS
différents, cela ne peut être le cas.
La seule explication que je vois, c'est que ton serveur SAMBA est très
conciliant au niveau partage et permissions!
Quelle version de Samba utilises-tu ?

As-tu essayé un tel montage réseau vers une autre machine sous Windows ?



J'ai une parcelle de réponse
tout d'abord il s'agit de windows xp sp2
samba 3.0.24

le partage
contient une option public=yes
du coup l'authentification se fait (de ce que j'ai compris) avec le compte de la
machine

le service autoexnt est lancé par "système local"

je suis preneur de plus d'explication
Alain Naigeon
Le #18047171
"Jean-Claude BELLAMY" message de news: 4937fca3$0$944$


Les bras m'en tombent, comme disait la petite Minus de vélo ! ;-)




:-) Première fois que je la lis, celle-là !

--

Français *==> "Musique renaissance" <==* English
midi - facsimiles - ligatures - mensuration
http://anaigeon.free.fr | http://www.medieval.org/emfaq/anaigeon/
Alain Naigeon - - Oberhoffen/Moder, France
http://fr.youtube.com/user/AlainNaigeon
mdnews
Le #18047161
On Thu, 04 Dec 2008 16:57:22 +0100, Pascal
le partage contient une option
public=yes
du coup l'authentification se fait (de ce que j'ai compris) avec le compte de la
machine



Pire que ça: « public = yes » (anciennement guest ok = yes)
= pas d'authentification du tout.
(Option à éviter)
Pascal
Le #18047431
>> le partage contient une option
public=yes


Pire que ça: « public = yes » (anciennement guest ok = yes)
= pas d'authentification du tout.


j'ai essayé de monter le partage avec un login / password bidon, je n'ai
pourtant pas réussi

ceci dit j'ai donc modifié l'option du partage
plus de public=yes
puis j'ai mis les options qui vont bien pour mon net use user/password

merci pour vos réponses

je suis malgré tout preneur de toute autre explication

merci encore
Thumain Th.
Le #18047961
Le Thu, 04 Dec 2008 17:59:54 +0100, Pascal
le partage contient une option public=yes


Pire que ça: « public = yes » (anciennement guest ok = yes) = pas
d'authentification du tout.


j'ai essayé de monter le partage avec un login / password bidon, je n'ai
pourtant pas réussi

ceci dit j'ai donc modifié l'option du partage
plus de public=yes
puis j'ai mis les options qui vont bien pour mon net use user/password

merci pour vos réponses

je suis malgré tout preneur de toute autre explication

merci encore




Bonjour

Une partie de l'authentification samba repose sur le paramètre security=
(user, share, ...)

--
TT
Pascal
Le #18048131
Thumain Th. a écrit :
Le Thu, 04 Dec 2008 17:59:54 +0100, Pascal
le partage contient une option public=yes


Pire que ça: « public = yes » (anciennement guest ok = yes) = pas
d'authentification du tout.


j'ai essayé de monter le partage avec un login / password bidon, je
n'ai pourtant pas réussi

ceci dit j'ai donc modifié l'option du partage
plus de public=yes
puis j'ai mis les options qui vont bien pour mon net use user/password

merci pour vos réponses

je suis malgré tout preneur de toute autre explication

merci encore




Bonjour

Une partie de l'authentification samba repose sur le paramètre security=
(user, share, ...)



en l'occurence user ici
CriCri
Le #18048371
Alain Naigeon a écrit :

:-) Première fois que je la lis, celle-là !



Musicien que tu es!!! ;-)
http://www.cdmc.asso.fr/biographies/h_l/jaffrennou.htm

Amicalement
CriCri

--
bitwyse [PGP KeyID 0xA79C8F2C]
Tout le monde est d'accord -
il ne reste plus qu'à trouver le point commun.
http://www.le-maquis.net
Alain Naigeon
Le #18048751
"CriCri" 49381ede$0$852$
Alain Naigeon a écrit :

:-) Première fois que je la lis, celle-là !



Musicien que tu es!!! ;-)
http://www.cdmc.asso.fr/biographies/h_l/jaffrennou.htm



A ben cha alorss, ça a même l'air sérieux tout ça !
(m'enfin personne n'égalera Eric Satie pour ce qui
est des titres d'oeuvres décalés)

--

Français *==> "Musique renaissance" <==* English
midi - facsimiles - ligatures - mensuration
http://anaigeon.free.fr | http://www.medieval.org/emfaq/anaigeon/
Alain Naigeon - - Oberhoffen/Moder, France
http://fr.youtube.com/user/AlainNaigeon
CriCri
Le #18049051
Alain Naigeon a écrit :

A ben cha alorss, ça a même l'air sérieux tout ça !



Dans le cadre actuel de la répression de la délinquance routière, je
voudrais savoir si conduire un vélo sans bras constitue une
contravention ou un délit.
(euhhh... le pilote sans bras, pas le vélo, quoi...)

--
bitwyse [PGP KeyID 0xA79C8F2C]
Error 4054 :
"insufficient memory may affect optimization"
http://www.le-maquis.net
Publicité
Poster une réponse
Anonyme