service qui ne marche pas (again)

Le
unbewusst.sein
bon j'ai un service qui marche très bien depuis automator.
il lit une URL sélectionnée dans Firefox et enregistre dans le bon
dossier le résultat du téléchargement + filtrage de la page.

donc ça marche impec si lancé depuis automator.

ce service est bien activé, amha, je le vois bien au niveau des prefs et
avec l'appli "Service Scrubber".

par contre là, en ce moment même il n'apparaît pas dans les Services de
FF qui sont désespérément à "Aucun service adequat" )))

j'ai regadé la plist dans le bundle de ce service, c'est tout simple :
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN"
"http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>NSServices</key>
<array>
<dict>
<key>NSMenuItem</key>
<dict>
<key>default</key>
<string>PetitChef</string>
</dict>
<key>NSMessage</key>
<string>runWorkflowAsService</string>
<key>NSRequiredContext</key>
<dict>
<key>NSApplicationIdentifier</key>
<string>org.mozilla.firefox</string>
</dict>
<key>NSSendTypes</key>
<array>
<string>public.utf8-plain-text</string>
</array>
</dict>
</array>
</dict>
</plist>

rien ne me paraît anormal, alors comme mon FF est en bêta (3.6.4) est-ce
que le pb pourrait venir de FF lui-même et pas de mon service ?
--
« Là où la vérité n'est pas libre,
la liberté n'est pas vraie. »
(Jacques Prévert)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrick Stadelmann
Le #22178581
In article (Une Bévue) wrote:

rien ne me paraît anormal, alors comme mon FF est en bêta (3.6.4) est-ce
que le pb pourrait venir de FF lui-même et pas de mon service ?



Probable puisque tu dis qu'aucun service n'est proposé, alors qu'avec du
texte sélectionné dans FireFox 3.6 j'ai plusieurs services standards qui
sont disponibles (Make New Sticky Note, New Email With Selection, ...).

Patrick
--
Patrick Stadelmann
J.P
Le #22179761
In article (Une Bévue) wrote:
tu as une solution pour les alias ?

JP
unbewusst.sein
Le #22179791
J.P
tu as une solution pour les alias ?



dans mon rép Sites ?
j'a mis des symlinks...
en fait, j'avais complétement oublié qu'il y a plusieurs fichiers de
conf pour httpd.
le principal httpd.conf et ceux sous users/
il m'a suffi d'ajouter followsymlink dans .../users/yt.conf et c'est
bon.

alias je n'ai pas ré-essayé, ça m'affichait le contenu binaire de
l'alias, quelque chose dans ce goût là, je peux ré-essayer derechef.

voila ce que ça donne quand on pointe sur un alias :
http://88.183.202.165/man.html

l'original item de cet alias étant :
http://88.183.202.165/man_html/index.html

p'tet que sur un dossier ces différents ?

oui, ça propose au dl :
http://88.183.202.165/AS_dictionnaries

pour :
http://88.183.202.165/macosx10.4-dictionaries-ruby/index.html

un symlink qui marche trè bien :
http://88.183.202.165/dictionaries/
ou
http://88.183.202.165/dictionaries/?page=iCal
--
« Le monde est une comédie dont les philosophes sont
les spectateurs. »
(Pythagore)
unbewusst.sein
Le #22181951
Patrick Stadelmann

Probable puisque tu dis qu'aucun service n'est proposé, alors qu'avec du
texte sélectionné dans FireFox 3.6 j'ai plusieurs services standards qui
sont disponibles (Make New Sticky Note, New Email With Selection, ...).



oui le texte sélectionné ça marche aussi chez moi.
du coup j'ai essayé Safari ça lance bien le service mais il plante avec
Safari

dans safari je fais Menu Contextuel > Copier le lien

et là je récupère non pas le lien mais le titre de la page visée suivi
du lien (c'est pourquoi mon service plantait il s'attandait à ce que ça
commence par http://...)

donc je fais une vérue pour réparer ça et paf, le service n'apparaît
plus non plus dans Safari...

là dans Automator j'ai choisi "adresses URL" je vais ré-essayer avec
texte...

à noter que pbpaste a toujours la bonne valeur au contraire (sans le
titre de la page) des args filés au service via automator...

cependant ça marche impec en direct depuis automator, bizarre tout ça...
--
« Le monde est une comédie dont les philosophes sont
les spectateurs. »
(Pythagore)
Publicité
Poster une réponse
Anonyme