[SID] VLC : noir et blanc et étiré

Le
Aurelien
Salut,

Ca va faire plusieurs mois que vlc me présente une image en niveau de
gris étiré dans la hauteur (ou plutôt compactée dans la largeur).

J'ai cherché sur le net, mais je n'ai jamais rien trouvé ressemblant à
mon souci en terme de symptômes. J'ai tenté de réinstaller vlc, les codecs,
etc. Mais rien n'y fait.

Voici ma configuration :
$> dpkg -l vlc
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
|
État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom Version Description
+++-==-==-==
ii vlc 1.1.3-1 multimedia player and streamer

Je suis en Debian SID à jour.

Les logs de vlc me donnent l'erreur suivante :

swScaler: pal8 is not supported as output pixel format
[0x226ae10] swscale scale error: could not init SwScaler and/or allocate
memory
[0x227df30] xcb_xv generic error: no available XVideo adaptor
No accelerated IMDCT transform found

qui, semble-t-il, seraient liés à mon driver X11, mais je ne vois pas
bien pourquoi cela aurait changé, j'utilise un noyau générique avec un
driver ATI, et ça fonctionne très bien pour xine, par exemple.

$> uname -a
Linux bete2guerre 2.6.32-3-amd64 #1 SMP Wed Feb 24 18:07:42 UTC 2010 x86_64 GNU/Linux


Des idées pour m'aider là-dessus ?

A plus tard.

NB : Je ne sais pas si ça a à voir, mais depuis environ le même temps,
la fonction 'zoom' de mplayer n'étire plus l'image à la taille de
l'écran, mais se contente de mettre des bandes noires autour.


--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20100902084353.GA2503@sebkhachott.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain L. Sauvage
Le #22533161
Le jeudi 2 septembre 2010 à 10:43:53, Aurelien a écrit :
Salut,



’lut,

Ca va faire plusieurs mois que vlc me présente une image en
niveau de gris étiré dans la hauteur (ou plutôt compactà ©e
dans la largeur).
[…]
Je suis en Debian SID à jour.
[…]
qui, semble-t-il, seraient liés à mon driver X11, mais je ne
vois pas bien pourquoi cela aurait changé, j'utilise un
noyau générique avec un driver ATI, et ça fonctionne trà ¨s
bien pour xine, par exemple.

$> uname -a
Linux bete2guerre 2.6.32-3-amd64 #1 SMP Wed Feb 24 18:07:42
UTC 2010 x86_64 GNU/Linux



Le dernier noyau Sid, c’est le « 2.6.32-5-amd64 #1 SMP Wed A ug
25 13:59:41 UTC 2010 x86_64 GNU/Linux », donc, non, tu n’es pa s
à jour (il y a eu plusieurs màj depuis février).

Des idées pour m'aider là-dessus ?



Il y a peut-être un soucis avec le pilote ATI (c’est bien le
pilote libre ?) : les derniers utilisent le noyau (KMS, DRM FB),
donc si le noyau n’est pas en phase…

A plus tard.

NB : Je ne sais pas si ça a à voir, mais depuis environ le
même temps, la fonction 'zoom' de mplayer n'étire plus
l'image à la taille de l'écran, mais se contente de mettre
des bandes noires autour.



Comme tu l’as vu plus haut : problème xv(ideo).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
jerome moliere
Le #22533271
Le 2 septembre 2010 11:24, Sylvain L. Sauvage
Le jeudi 2 septembre 2010 à 10:43:53, Aurelien a écrit :
Salut,



’lut,

Ca va faire plusieurs mois que vlc me présente une image en
niveau de gris étiré dans la hauteur (ou plutôt compactée
dans la largeur).
[…]
Je suis en Debian SID à jour.
[…]
qui, semble-t-il, seraient liés à mon driver X11, mais je ne
vois pas bien pourquoi cela aurait changé, j'utilise un
noyau générique avec un driver ATI, et ça fonctionne très
bien pour xine, par exemple.

$> uname -a
Linux bete2guerre 2.6.32-3-amd64 #1 SMP Wed Feb 24 18:07:42
UTC 2010 x86_64 GNU/Linux



 Le dernier noyau Sid, c’est le « 2.6.32-5-amd64 #1 SMP Wed Aug
25 13:59:41 UTC 2010 x86_64 GNU/Linux », donc, non, tu n’es pas
à jour (il y a eu plusieurs màj depuis février).

Des idées pour m'aider là-dessus ?



 Il y a peut-être un soucis avec le pilote ATI (c’est bien le
pilote libre ?) : les derniers utilisent le noyau (KMS, DRM FB),
donc si le noyau n’est pas en phase…




Bonjour,
je dirai +1 avec la réponse de Sylvain,
j'ai eu ce souci sur mon ancien portable qui était aussi en SID
jusqu'au jour où j'ai compilé un kernel récent..
Sur mon VAIO où j'ai d'emblée compilé un noyau 2.6.34 aucun souci ave c VLC

Jerome

--
Jerome Moliere - Mentor/J
http://romjethoughts.blogspot.com/
auteur Eyrolles

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/AANLkTi=
C. Mourad Jaber
Le #22533681
Le 02/09/2010 10:43, Aurelien a écrit :
Salut,

Ca va faire plusieurs mois que vlc me présente une image en niveau de
gris étiré dans la hauteur (ou plutôt compactée dans la largeur).

J'ai cherché sur le net, mais je n'ai jamais rien trouvé ressemblant à
mon souci en terme de symptômes. J'ai tenté de réinstaller vlc, les codecs,
etc. Mais rien n'y fait.

Voici ma configuration :
$> dpkg -l vlc
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
|
État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom Version Description
+++-=======================-=======================-============================================================= > ii vlc 1.1.3-1 multimedia player and streamer

Je suis en Debian SID à jour.

Les logs de vlc me donnent l'erreur suivante :

swScaler: pal8 is not supported as output pixel format
[0x226ae10] swscale scale error: could not init SwScaler and/or allocate
memory
[0x227df30] xcb_xv generic error: no available XVideo adaptor
No accelerated IMDCT transform found

qui, semble-t-il, seraient liés à mon driver X11, mais je ne vois pas
bien pourquoi cela aurait changé, j'utilise un noyau générique avec un
driver ATI, et ça fonctionne très bien pour xine, par exemple.

$> uname -a
Linux bete2guerre 2.6.32-3-amd64 #1 SMP Wed Feb 24 18:07:42 UTC 2010 x86_64 GNU/Linux


Des idées pour m'aider là-dessus ?

A plus tard.

NB : Je ne sais pas si ça a à voir, mais depuis environ le même temps,
la fonction 'zoom' de mplayer n'étire plus l'image à la taille de
l'écran, mais se contente de mettre des bandes noires autour.



Une question bête, as-tu essayer d'utiliser un autre type de sortie de vlc ?
Ton xcb_xv semble malade, mais vlc est capable d'utiliser d'autres type (glx, xvideo,
x11...)...

Par ailleurs, il y a eu d'énormes progrès dans le pilote libre pour les radeons, je pense
que ça peut valoir le coup de tenter un noyau 2.6.35 (en experimental) et de voir ce que
ça donne !

++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Aurelien
Le #22533671
On Thu, Sep 02, 2010 at 11:24:31AM +0200, Sylvain L. Sauvage wrote :
Le jeudi 2 septembre 2010 à 10:43:53, Aurelien a écrit :
> Salut,

’lut,

> Ca va faire plusieurs mois que vlc me présente une image en
> niveau de gris étiré dans la hauteur (ou plutôt compactée
> dans la largeur).
>[…]
> Je suis en Debian SID à jour.
>[…]
> qui, semble-t-il, seraient liés à mon driver X11, mais je ne
> vois pas bien pourquoi cela aurait changé, j'utilise un
> noyau générique avec un driver ATI, et ça fonctionne très
> bien pour xine, par exemple.
>
> $> uname -a
> Linux bete2guerre 2.6.32-3-amd64 #1 SMP Wed Feb 24 18:07:42
> UTC 2010 x86_64 GNU/Linux

Le dernier noyau Sid, c’est le « 2.6.32-5-amd64 #1 SMP Wed Aug
25 13:59:41 UTC 2010 x86_64 GNU/Linux », donc, non, tu n’es pas
à jour (il y a eu plusieurs màj depuis février).



Ah ?
Bizarre, j'ai fait un upgrade ce matin même (et reboot évidemment), et
vu le titre du noyau, je ne pense pas que ça soit un que j'ai compilé à
la main. Bon, je vais checker.


> Des idées pour m'aider là-dessus ?

Il y a peut-être un soucis avec le pilote ATI (c’est bien le
pilote libre ?) : les derniers utilisent le noyau (KMS, DRM FB),
donc si le noyau n’est pas en phase…



Pilote libre, oui. Du coup, c'est directement lié au noyau, quoi.
Bon, je vais essayer de voir pour upgrader tout ça.


> A plus tard.
>
> NB : Je ne sais pas si ça a à voir, mais depuis environ le
> même temps, la fonction 'zoom' de mplayer n'étire plus
> l'image à la taille de l'écran, mais se contente de mettre
> des bandes noires autour.

Comme tu l’as vu plus haut : problème xv(ideo).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Aurelien
Le #22533761
On Thu, Sep 02, 2010 at 02:00:12PM +0200, C. Mourad Jaber wrote :
Le 02/09/2010 10:43, Aurelien a écrit :
>Salut,
>
>Ca va faire plusieurs mois que vlc me présente une image en niveau de
>gris étiré dans la hauteur (ou plutôt compactée dans la largeur).
>
>J'ai cherché sur le net, mais je n'ai jamais rien trouvé ressemblant à
>mon souci en terme de symptômes. J'ai tenté de réinstaller vlc, les codecs,
>etc. Mais rien n'y fait.
>
>Voici ma configuration :
> $> dpkg -l vlc
> Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
> |
> État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
> |/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
> ||/ Nom Version Description
> +++-=======================-=======================-============================================================= > > ii vlc 1.1.3-1 multimedia player and streamer
>
>Je suis en Debian SID à jour.
>
>Les logs de vlc me donnent l'erreur suivante :
>
>swScaler: pal8 is not supported as output pixel format
>[0x226ae10] swscale scale error: could not init SwScaler and/or allocate
>memory
>[0x227df30] xcb_xv generic error: no available XVideo adaptor
>No accelerated IMDCT transform found
>
>qui, semble-t-il, seraient liés à mon driver X11, mais je ne vois pas
>bien pourquoi cela aurait changé, j'utilise un noyau générique avec un
>driver ATI, et ça fonctionne très bien pour xine, par exemple.
>
>$> uname -a
>Linux bete2guerre 2.6.32-3-amd64 #1 SMP Wed Feb 24 18:07:42 UTC 2010 x86_64 GNU/Linux
>
>
>Des idées pour m'aider là-dessus ?
>
>A plus tard.
>
>NB : Je ne sais pas si ça a à voir, mais depuis environ le même temps,
>la fonction 'zoom' de mplayer n'étire plus l'image à la taille de
>l'écran, mais se contente de mettre des bandes noires autour.
>
Une question bête, as-tu essayer d'utiliser un autre type de sortie de vlc ?
Ton xcb_xv semble malade, mais vlc est capable d'utiliser d'autres
type (glx, xvideo, x11...)...




Il me semble les avoir essayées sans succès avec mplayer. Je vais
re-regarder (j'attends la mise à jour de mon noyau[1]).

[1] D'ailleurs, comment se fait-il que le noyau ne soit pas touché par
les mises à jour du système ? C'est normal, ou c'est moi qui fais
quelque chose mal ?


Par ailleurs, il y a eu d'énormes progrès dans le pilote libre pour
les radeons, je pense que ça peut valoir le coup de tenter un noyau
2.6.35 (en experimental) et de voir ce que ça donne !



Hum, déjà SID c'est pas tous les jours simples, donc experimental, pour
l'instant, je vais tenter d'éviter. A la limite, je préfère compiler mon
propre noyau 2.6.35, ça, je sais faire !


++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #22533811
Le jeudi 2 septembre 2010 à 14:44:45, Sylvain L. Sauvage a écrit
:
[…]
Bon, remarque que rien n’est mis à jour automatiquement non
plus (il faut soit vérifier tout seul de temps en temps, soit
changer le pining pour les paquets d’experimental qu’on a
installé).



Grr, pi_nn_ing et installé_s_…

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #22533821
Le jeudi 2 septembre 2010 à 14:21:35, Aurelien a écrit :
[…]
[1] D'ailleurs, comment se fait-il que le noyau ne soit pas
touché par les mises à jour du système ? C'est normal, ou
c'est moi qui fais quelque chose mal ?



Parce que tu as installé linux-image-2.6.32-2-amd64
(d’ailleurs, il devrait être dans la section obsolète/loc al) et
pas linux-image-2.6-amd64.
linux-image-2.6-amd64 est un méta-paquet qui a juste une
dépendance sur le noyau courant.

> Par ailleurs, il y a eu d'énormes progrès dans le pilote
> libre pour les radeons, je pense que ça peut valoir le
> coup de tenter un noyau 2.6.35 (en experimental) et de
> voir ce que ça donne !

Hum, déjà SID c'est pas tous les jours simples, donc
experimental, pour l'instant, je vais tenter d'éviter. A la
limite, je préfère compiler mon propre noyau 2.6.35, ça, je
sais faire !



Ben, avec experimental, tu évites la compilation, les paquets
sont déjà prêts, rien de pire.
Par défaut, rien n’est installé d’experimental sans que tu le
demandes explicitement.
Bon, remarque que rien n’est mis à jour automatiquement non
plus (il faut soit vérifier tout seul de temps en temps, soit
changer le pining pour les paquets d’experimental qu’on a
installé).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Guy Roussin
Le #22533901
Hum, déjà SID c'est pas tous les jours simples, donc experimental, pour
l'instant, je vais tenter d'éviter. A la limite, je préfère compi ler mon
propre noyau 2.6.35, ça, je sais faire !


Rien ne t'obliges à désinstaller ton 2.6.32 ... Il te suffira au dé marrage
de grub de choisir la 2.6.32 pour retomber sur ta conf. qui marche (presq ue).
Dans ce cas, le risque ne me parait pas bien grand et le test ne va te pr endre
que quelques minutes.
--
Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Aurelien
Le #22534681
On Thu, Sep 02, 2010 at 03:22:25PM +0200, Guy Roussin wrote :
>Hum, déjà SID c'est pas tous les jours simples, donc experimental, pour
>l'instant, je vais tenter d'éviter. A la limite, je préfère compiler mon
>propre noyau 2.6.35, ça, je sais faire !
Rien ne t'obliges à désinstaller ton 2.6.32 ... Il te suffira au démarrage
de grub de choisir la 2.6.32 pour retomber sur ta conf. qui marche (presque).
Dans ce cas, le risque ne me parait pas bien grand et le test ne va te prendre
que quelques minutes.



Hum, oui, je sais. Je pensais au fait d'ajouter experimental à mes
sources, en fait. Mais en effet, je pourrais me contenter de prendre le
.deb et l'installer.

--
Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
Aurélien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
luc schimpf
Le #22535691
Le 02/09/2010 18:38, Aurelien a écrit :
On Thu, Sep 02, 2010 at 03:22:25PM +0200, Guy Roussin wrote :
Hum, déjà SID c'est pas tous les jours simples, donc experimental, pour
l'instant, je vais tenter d'éviter. A la limite, je préfère compiler mon
propre noyau 2.6.35, ça, je sais faire !


Rien ne t'obliges à désinstaller ton 2.6.32 ... Il te suffira au démarrage
de grub de choisir la 2.6.32 pour retomber sur ta conf. qui marche (presque).
Dans ce cas, le risque ne me parait pas bien grand et le test ne va te prendre
que quelques minutes.



Hum, oui, je sais. Je pensais au fait d'ajouter experimental à mes
sources, en fait. Mais en effet, je pourrais me contenter de prendre le
.deb et l'installer.



Tu peux t'économiser cette peine, j'ai le même problème que toi sur le
même type de matériel et je viens d'installer le 2.6.35 d'experimental
sans résultat...


--

Luc Schimpf
www.au-ptit-bon-air.eu

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme