Signe euro et PDF

Le
Mourad Jaber
Bonjour,

Je rencontre un petit soucis avec certains PDF, c'est l'affichage du signe euro (€) dans
des documents pdf, il est remplacé par un carré à l'écran et n'apparaît pas du tout à
l'impression !

J'ai le même problème avec okular et evinct donc je pense à une cause commune

Le dernier document en date, la police est de l'Hevetica et de l'Helvetica Bold.

J'ai tester dans libreoffice en mettant la police en helvetica et le signe euro apparaît
bien !

Comment faire pour que le signe euro revienne dans mes documents ?

++

Mourad


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/5235EC81.4060208@nativobject.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Haricophile
Le #25662812
Le dimanche 15 septembre 2013 à 19:21 +0200, Mourad Jaber a écrit :
Bonjour,

Je rencontre un petit soucis avec certains PDF, c'est l'affichage du signe euro (€) dans
des documents pdf, il est remplacé par un carré à l'écran et n'apparaît pas du tout à
l'impression !

J'ai le même problème avec okular et evinct donc je pense à une cause commune...



Un problème de police à priori. Le "carré" à l'écran est un caractère
manquant. A noter que les PDF embarquent ou pas la police.

C'est sur tous les documents PDF ?

Au fait, tu es bien en UTF8 ?



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
C. Mourad Jaber
Le #25662902
Le 16/09/2013 07:57, Haricophile a écrit :
Le dimanche 15 septembre 2013 à 19:21 +0200, Mourad Jaber a écrit :
Bonjour,

Je rencontre un petit soucis avec certains PDF, c'est l'affichage du signe euro (€) dans
des documents pdf, il est remplacé par un carré à l'écran et n'apparaît pas du tout à
l'impression !

J'ai le même problème avec okular et evinct donc je pense à une cause commune...


Un problème de police à priori. Le "carré" à l'écran est un caractère
manquant. A noter que les PDF embarquent ou pas la police.

C'est sur tous les documents PDF ?

Au fait, tu es bien en UTF8 ?


Bonjour,

Oui, tout est en UTF-8 et ceci ne concerne pas tous les pdf.

Ce que j'ai remarqué c'est que les pdf générés par des applications php ont souvent ce
problème.

++

Mourad


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Haricophile
Le #25663212
Le lundi 16 septembre 2013 à 09:45 +0200, C. Mourad Jaber a écrit :
Ce que j'ai remarqué c'est que les pdf générés par des applications
php ont souvent ce
problème.



Ça serait donc un problème de PHP, ou plutôt du fait que pour les
américains, seul le reste du monde a besoin de choses triviales comme
des accents ou des signes ridicules de monnaies autres que $

A mon humble avis, ça sent le babelweb en iso machintruc-1 au lieu de
machintruc-15 , l'UTF8 étant trop récent : ça ne date que de 1993 en
première mouture et encore seul Plan9 l'a utilisé à cette date.

10 ans c'est super jeune en informatique, la preuve : la disposition
foireuse des clavier date de 1870, à cause de la technologie de l'époque
pour que les touches ne se coincent pas, et n'a toujours pas été
amélioré sinon par l'ajout anarchique de touches, sauf par quelques très
rares sociétés comme Typematrix.

Dans un siècle ou deux, tous tes PDF fonctionneront tous ;)



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Vincent Lefevre
Le #25663482
On 2013-09-16 07:57:29 +0200, Haricophile wrote:
Un problème de police à priori. Le "carré" à l'écran est un caractère
manquant. A noter que les PDF embarquent ou pas la police.



Et c'est vérifiable avec la commande "pdffonts". Cf colonne "emb".

--
Vincent Lefèvre 100% accessible validated (X)HTML - Blog: Work: CR INRIA - computer arithmetic / AriC project (LIP, ENS-Lyon)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
C. Mourad Jaber
Le #25665422
Le 16/09/2013 13:29, Vincent Lefevre a écrit :
On 2013-09-16 07:57:29 +0200, Haricophile wrote:
Un problème de police à priori. Le "carré" à l'écran est un caractère
manquant. A noter que les PDF embarquent ou pas la police.


Et c'est vérifiable avec la commande "pdffonts". Cf colonne "emb".



En effet cela semble venir d'une de mes machines qui doit avoir une "vieille" font
importée d'un windaube XP je crois...

Parce que la police n'est pas incluse dans le document qui me pose problème...

name type encoding emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
Helvetica Type 1 WinAnsi no no no 7 0
Helvetica-Bold Type 1 WinAnsi no no no 8 0

Sur mon laptop, pas de problème le signe euro se porte bien.

Merci pour votre aide pour identifier le problème !

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme