Simplification de formule

Le
Patrick BASTARD
Bonjour.

Comment puis-je simplifier la formule suivante en E1:

=INDEX(Table2;EQUIV(F2&E2;Table1;0))+INDEX(Table2;EQUIV(F3&E3;Table1;0))+.+INDEX(Table2;EQUIV(F367&E367;Table1;0))

D'avance, Merci.

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.M
Le #4447801
Bonsoir Patrick,

=SOMMEPROD((F2:F367&E2:E367=Table1)*Table2)

ou encore la matricielle (saisir avec Ctrl-Maj-Entrée) suivante s'il y a des
valeurs d'erreurs en Table2 lorsque la première condition n'est pas remplie)
:

=SOMME(SI(F2:F367&E2:E367=Table1;Table2))

Salutations,

Daniel M.

"Patrick BASTARD" news:%

Bonjour.

Comment puis-je simplifier la formule suivante en E1:

=INDEX(Table2;EQUIV(F2&E2;Table1;0))+INDEX(Table2;EQUIV(F3&E3;Table1;0))+.......+INDEX(Table2;EQUIV(F367&E367;Table1;0))

D'avance, Merci.

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.



Patrick BASTARD
Le #4447631
Bonjour, *Daniel*

Merci. Nous y sommes presque.

Presque, car la taille des tables etant moins importante que la taille de la
zone à calculer cela génère des N/A.
Je te joins un exemple restreint :

http://cjoint.com/?eokWAA2kEW

Objectif : calculer en haut de colonne (1 colonne par salarié) le nb
d'heures annuelles planifiées (positions sur 3 lettres ici en colonne F) en
fonction des horaires correspondants (tables 1 et 2) et du jour de la
colonne D.

La question reste donc ouverte.

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.


Bonsoir Patrick,

=SOMMEPROD((F2:F367&E2:E367=Table1)*Table2)

ou encore la matricielle (saisir avec Ctrl-Maj-Entrée) suivante s'il
y a des valeurs d'erreurs en Table2 lorsque la première condition
n'est pas remplie)



=SOMME(SI(F2:F367&E2:E367=Table1;Table2))

Salutations,

Daniel M.

"Patrick BASTARD" message news:%

Bonjour.

Comment puis-je simplifier la formule suivante en E1:

=INDEX(Table2;EQUIV(F2&E2;Table1;0))+INDEX(Table2;EQUIV(F3&E3;Table1;0))+.......+INDEX(Table2;EQUIV(F367&E367;Table1;0))

D'avance, Merci.

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.




Daniel.M
Le #4446721
Bonjour Patrick,

Presque, car la taille des tables etant moins importante que la taille de
la zone à calculer cela génère des N/A.


La matricielle suivante :
=SOMME(N(DECALER(Table2;EQUIV(F4:F13&E4:E13;Table1;0)-1;;;)))

Salutations,

Daniel M.

"Patrick BASTARD" news:
Bonjour, *Daniel*

Merci. Nous y sommes presque.

Presque, car la taille des tables etant moins importante que la taille de
la zone à calculer cela génère des N/A.
Je te joins un exemple restreint :

http://cjoint.com/?eokWAA2kEW

Objectif : calculer en haut de colonne (1 colonne par salarié) le nb
d'heures annuelles planifiées (positions sur 3 lettres ici en colonne F)
en fonction des horaires correspondants (tables 1 et 2) et du jour de la
colonne D.

La question reste donc ouverte.

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.


Bonsoir Patrick,

=SOMMEPROD((F2:F367&E2:E367=Table1)*Table2)

ou encore la matricielle (saisir avec Ctrl-Maj-Entrée) suivante s'il
y a des valeurs d'erreurs en Table2 lorsque la première condition
n'est pas remplie)



=SOMME(SI(F2:F367&E2:E367=Table1;Table2))

Salutations,

Daniel M.

"Patrick BASTARD" message news:%

Bonjour.

Comment puis-je simplifier la formule suivante en E1:

=INDEX(Table2;EQUIV(F2&E2;Table1;0))+INDEX(Table2;EQUIV(F3&E3;Table1;0))+.......+INDEX(Table2;EQUIV(F367&E367;Table1;0))

D'avance, Merci.

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.








Patrick BASTARD
Le #4446521
Bonjour, cousin *Daniel*


La matricielle suivante :
=SOMME(N(DECALER(Table2;EQUIV(F4:F13&E4:E13;Table1;0)-1;;;)))


correspond parfaitement à ce que je cherche à obtenir, et je vais pouvoir
avancer sur mon projet de simplification.
Mais pour ne pas me laisser mourir idiot, aurais-tu la gentilesse de la
"décortiquer".
J'ai regardé dans l'aide la signification de N, que je ne connaissais pas,
ok.
Pour le reste, je n'ai pas tout compris...
Sauf que ça maaarche.

En tous cas, un grand merci.

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.

"Patrick BASTARD" message news:
Bonjour, *Daniel*

Merci. Nous y sommes presque.

Presque, car la taille des tables etant moins importante que la
taille de la zone à calculer cela génère des N/A.
Je te joins un exemple restreint :

http://cjoint.com/?eokWAA2kEW

Objectif : calculer en haut de colonne (1 colonne par salarié) le nb
d'heures annuelles planifiées (positions sur 3 lettres ici en
colonne F) en fonction des horaires correspondants (tables 1 et 2)
et du jour de la colonne D.

La question reste donc ouverte.


Bonsoir Patrick,

=SOMMEPROD((F2:F367&E2:E367=Table1)*Table2)

ou encore la matricielle (saisir avec Ctrl-Maj-Entrée) suivante s'il
y a des valeurs d'erreurs en Table2 lorsque la première condition
n'est pas remplie)



=SOMME(SI(F2:F367&E2:E367=Table1;Table2))

Salutations,

Daniel M.

"Patrick BASTARD" message news:%

Bonjour.

Comment puis-je simplifier la formule suivante en E1:

=INDEX(Table2;EQUIV(F2&E2;Table1;0))+INDEX(Table2;EQUIV(F3&E3;Table1;0))+.......+INDEX(Table2;EQUIV(F367&E367;Table1;0))

D'avance, Merci.

--
Bien amicordialement,
P. Bastard








Publicité
Poster une réponse
Anonyme