Snow Leopard et version de Java

Le
xavier
Bonjour,

Depuis que j'ai installé SL, je me fais injurier par l'interface Web de
mes Cisco, sous prétexte que la version max supportée est la 1.4

Bon, je veux bien, il y a justement /Utilities/Java Preferences pour ça.

Et là, Gasp ! Je n'ai plus le choix qu'entre les versions 64 et 32 bits
de Java 1.6, les versions précédentes ont disparu, alors qu'avec
Leopard, on avait le choix, dans des cas de compatibilité comme
celui-ci, de préférer la 1.5 ou la 1.4

Voir ici : <http://www.groumpf.org/vrac/JavaPrefs.gif>

Je rêve peut-etre un peu, mais y aurait-il moyen d'installer une 1.4, et
la faire (ou non) choisis par Java Prefs ?

Merci,

--
XAv
Disponible au 01/06/2010
<http://www.xavierhumbert.net/perso/CV2.html>
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrick Stadelmann
Le #20580661
In article (Xavier) wrote:

Je rêve peut-etre un peu, mais y aurait-il moyen d'installer une 1.4, et
la faire (ou non) choisis par Java Prefs ?



Il semble que ce soit faisable :
http://wiki.oneswarm.org/index.php/OS_X_10.6_Snow_Leopard#Java_1.4

Patrick
--
Patrick Stadelmann
xavier
Le #20580901
Xavier
Et là, Gasp ! Je n'ai plus le choix qu'entre les versions 64 et 32 bits
de Java 1.6, les versions précédentes ont disparu



Et comme je viens de fouiller dans
/System/Library/Frameworks/JavaVM.framework/Versions, on a bien
présent :

[ Versions]$ ll
total 48
lrwxr-xr-x 1 root wheel 5 Sep 6 15:25 1.3@ -> 1.3.1
drwxr-xr-x 3 root wheel 102 Jul 21 01:35 1.3.1/
lrwxr-xr-x 1 root wheel 10 Sep 6 15:25 1.5@ -> CurrentJDK
lrwxr-xr-x 1 root wheel 10 Sep 6 15:25 1.5.0@ -> CurrentJDK
lrwxr-xr-x 1 root wheel 5 Sep 6 15:25 1.6@ -> 1.6.0
drwxr-xr-x 8 root wheel 272 Sep 6 15:58 1.6.0/
drwxr-xr-x 9 root wheel 306 Sep 6 15:58 A/
lrwxr-xr-x 1 root wheel 1 Sep 6 15:26 Current@ -> A
lrwxr-xr-x 1 root wheel 3 Sep 6 15:25 CurrentJDK@ -> 1.6

Donc :

* La 1.3.1 est présente, mais n'apparaît pas dans Java Prefs
* La 1.5 prétend être là, mais n'est qu'un lien vers la 1.6

Et une des réponses se trouve là :


--
XAv
Disponible au 01/06/2010
xavier
Le #20581071
Patrick Stadelmann
Il semble que ce soit faisable :
http://wiki.oneswarm.org/index.php/OS_X_10.6_Snow_Leopard#Java_1.4



Oui, et je complète mon message précédent, plutôt que d'utiliser les
packages de washington.edu (qui sont corrects, néamoins) d'extraire les
fichiers ad-hoc de la toute dernière MàJ pour Leopard disponible sur
ADC :
<http://adcdownload.apple.com/Java/java_for_mac_os_x_developer_preview_1
0m30139m3113/javaformacosx10.5_update6_9m3113.dmg>
(inscription gratuite nécessaire) qui contient les toute dernières
versions 1.3.1, 1.4.2 et 1.5.O. Il ne reste plus qu'à ajuster les
symlinks comme expliqué dans ton lien. Reste à voir sur Java Prefs les
voit, je n'ai pas encore eu le temps d'essayer.

Merci,

--
XAv
Disponible au 01/06/2010
Publicité
Poster une réponse
Anonyme