SOAPpy installation

Le
hervest
Bonjour,
pour installer SOAPpy, j'ai installé:
fpconst et pyXML

puis pour complier j'ai fait dans le dossier de SOAPpy (/home/soap)
python setup.py build

mais j'ai cette erreure ci

Traceback (most recent call last):
File "setup.py", line 8, in <module>
from SOAPpy.version import __version__
File "/home/soap/SOAPpy/__init__.py", line 5, in <module>
from Client import *
File "/home/soap/SOAPpy/Client.py", line 46
from __future__ import nested_scopes
SyntaxError: from __future__ imports must occur at the beginning of the file

quelqu'un pourrait il m'expliquer pourquoi ça ne marche pas?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Méta-MCI \(MVP\)
Le #18738111
Bonjour !

Quelle version de Python ?
Pour info, j'avais échoué à installer soapy (de ZSI). Car il y avait
trop de dépendances. Et, dans le paquet de trucs à télécharger /
installer, il y avait toujours un module ou un autre qui n'existait pas
à jour.
C'est, entre autres, et notamment, à cause de ce genre de choses que je
suis maintenant prudent sur la pérennité des modules. Ce n'est pas tout,
de dire qu'il existe beaucoup de choses pour Python. Encore faut-il que
ces choses soient disponibles pour les nouvelles et prochaines versions
de Python...

--
@-salutations
--
Michel Claveau
hervest
Le #18741411
Méta-MCI (MVP) a écrit le 23/02/2009 à 07h36 :
Bonjour !

Quelle version de Python ?
Pour info, j'avais échoué à installer soapy (de ZSI). Car
il y avait
trop de dépendances. Et, dans le paquet de trucs à
télécharger /
installer, il y avait toujours un module ou un autre qui n'existait pas
à jour.
C'est, entre autres, et notamment, à cause de ce genre de choses que je
suis maintenant prudent sur la pérennité des modules. Ce n'est
pas tout,
de dire qu'il existe beaucoup de choses pour Python. Encore faut-il que
ces choses soient disponibles pour les nouvelles et prochaines versions
de Python...

--
@-salutations
--
Michel Claveau


ok, j'utilise la version 2.5
Publicité
Poster une réponse
Anonyme