Somme avec Equiv et index

Le
ttcpp
Bonjour

J'ai un problème avec une formule index +equiv.
Je voudrais avoir le résultat d'une somme suivant 2 critéres:
son type,son nom de colonne

exemple :
Nom de la colonne
Type a b c
x 150 250 300
z 125 210 301
a 175 190 302
r 175 180 303
x 187,5 150 304
x 200 127 305
x 212,5 104 306
z 225 81 307
a 237,5 58 308
r 250 35 309
x 262,5 12 310

J'ai mis dans une cellule K2 le type que je veux additionner et en K3 le nom
de la colonne dans laquelle je veux récupérer la somme des valeurs
correpondant au critères K2

J'ai mis en K4 la formule suivante
:{=SOMME(INDEX(Base;EQUIV(K2;Type;0);EQUIV(K3;A2:D2;0)))}
Mais cela me donne le resultat de la premère valeur rencontrée ?
Exemple : type z et colonne B valeur récupérée : 210 au lieu de 291

Comment remédier au problème ?
merci pour votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Caetera
Le #20713131
"ttcpp"
Nom de la colonne
Type a b c
x 150 250 300
z 125 210 301
a 175 190 302
r 175 180 303
x 187,5 150 304
x 200 127 305
x 212,5 104 306
z 225 81 307
a 237,5 58 308
r 250 35 309
x 262,5 12 310

J'ai mis dans une cellule K2 le type que je veux additionner et en K3 le nom
de la colonne dans laquelle je veux récupérer la somme des valeurs
correpondant au critères K2



********************

=SOMMEPROD((type=K2)*INDIRECT(K3))

Etc
Daniel.C
Le #20713111
Bonjour.
Essaie :
=SOMMEPROD((A2:A12=K2)*(DECALER(A2:A12;;EQUIV(K3;B1:D1;0))))
Daniel

Bonjour

J'ai un problème avec une formule index +equiv.
Je voudrais avoir le résultat d'une somme suivant 2 critéres:
son type,son nom de colonne

exemple :
Nom de la colonne
Type a b c
x 150 250 300
z 125 210 301
a 175 190 302
r 175 180 303
x 187,5 150 304
x 200 127 305
x 212,5 104 306
z 225 81 307
a 237,5 58 308
r 250 35 309
x 262,5 12 310

J'ai mis dans une cellule K2 le type que je veux additionner et en K3 le nom
de la colonne dans laquelle je veux récupérer la somme des valeurs
correpondant au critères K2

J'ai mis en K4 la formule suivante
{=SOMME(INDEX(Base;EQUIV(K2;Type;0);EQUIV(K3;A2:D2;0)))}


Mais cela me donne le resultat de la premère valeur rencontrée ?
Exemple : type z et colonne B valeur récupérée : 210 au lieu de 291

Comment remédier au problème ?
merci pour votre aide.


ttcpp
Le #20714021
Merci pour vos réponses
Toutefois celle de Caetera ne fonctionne pas #nombre ( je ne comprends pas
comment on peut faire une sommeProd sans indiquer la colonne que l'on veut
sommer)
Par contre celle de Daniel. C fonctionne

Encore merci.

"Daniel.C" wrote:

Bonjour.
Essaie :
=SOMMEPROD((A2:A12=K2)*(DECALER(A2:A12;;EQUIV(K3;B1:D1;0))))
Daniel

> Bonjour
>
> J'ai un problème avec une formule index +equiv.
> Je voudrais avoir le résultat d'une somme suivant 2 critéres:
> son type,son nom de colonne
>
> exemple :
> Nom de la colonne
> Type a b c
> x 150 250 300
> z 125 210 301
> a 175 190 302
> r 175 180 303
> x 187,5 150 304
> x 200 127 305
> x 212,5 104 306
> z 225 81 307
> a 237,5 58 308
> r 250 35 309
> x 262,5 12 310
>
> J'ai mis dans une cellule K2 le type que je veux additionner et en K3 le nom
> de la colonne dans laquelle je veux récupérer la somme des valeurs
> correpondant au critères K2
>
> J'ai mis en K4 la formule suivante
>> {=SOMME(INDEX(Base;EQUIV(K2;Type;0);EQUIV(K3;A2:D2;0)))}
> Mais cela me donne le resultat de la premère valeur rencontrée ?
> Exemple : type z et colonne B valeur récupérée : 210 au lieu de 291
>
> Comment remédier au problème ?
> merci pour votre aide.


.



ttcpp
Le #20714261
En fait la réponse de Daniel.C ne répond pas entièrement à mon problème (j'ai
mis dans l'exemple des critères trop simples)
En fait j'ai besoin de faire une {somme.si()} ou {somme(si(...) } car je
veux faire un regroupement de critères (ex tous les noms qui comment par A,
B , C....)
Merci encore pour votre aide.


"ttcpp" wrote:

Merci pour vos réponses
Toutefois celle de Caetera ne fonctionne pas #nombre ( je ne comprends pas
comment on peut faire une sommeProd sans indiquer la colonne que l'on veut
sommer)
Par contre celle de Daniel. C fonctionne

Encore merci.

"Daniel.C" wrote:

> Bonjour.
> Essaie :
> =SOMMEPROD((A2:A12=K2)*(DECALER(A2:A12;;EQUIV(K3;B1:D1;0))))
> Daniel
>
> > Bonjour
> >
> > J'ai un problème avec une formule index +equiv.
> > Je voudrais avoir le résultat d'une somme suivant 2 critéres:
> > son type,son nom de colonne
> >
> > exemple :
> > Nom de la colonne
> > Type a b c
> > x 150 250 300
> > z 125 210 301
> > a 175 190 302
> > r 175 180 303
> > x 187,5 150 304
> > x 200 127 305
> > x 212,5 104 306
> > z 225 81 307
> > a 237,5 58 308
> > r 250 35 309
> > x 262,5 12 310
> >
> > J'ai mis dans une cellule K2 le type que je veux additionner et en K3 le nom
> > de la colonne dans laquelle je veux récupérer la somme des valeurs
> > correpondant au critères K2
> >
> > J'ai mis en K4 la formule suivante
> >> {=SOMME(INDEX(Base;EQUIV(K2;Type;0);EQUIV(K3;A2:D2;0)))}
> > Mais cela me donne le resultat de la premère valeur rencontrée ?
> > Exemple : type z et colonne B valeur récupérée : 210 au lieu de 291
> >
> > Comment remédier au problème ?
> > merci pour votre aide.
>
>
> .
>


Daniel.C
Le #20714421
Poste un classeur avec ta problématique complématique sur
www.cjoint.com
en supprimant le cas échéant les données confidentielles.
Daniel

En fait la réponse de Daniel.C ne répond pas entièrement à mon problème (j'ai
mis dans l'exemple des critères trop simples)
En fait j'ai besoin de faire une {somme.si()} ou {somme(si(...) } car je
veux faire un regroupement de critères (ex tous les noms qui comment par A,
B , C....)
Merci encore pour votre aide.


"ttcpp" wrote:

Merci pour vos réponses
Toutefois celle de Caetera ne fonctionne pas #nombre ( je ne comprends pas
comment on peut faire une sommeProd sans indiquer la colonne que l'on veut
sommer)
Par contre celle de Daniel. C fonctionne

Encore merci.

"Daniel.C" wrote:

Bonjour.
Essaie :
=SOMMEPROD((A2:A12=K2)*(DECALER(A2:A12;;EQUIV(K3;B1:D1;0))))
Daniel

Bonjour

J'ai un problème avec une formule index +equiv.
Je voudrais avoir le résultat d'une somme suivant 2 critéres:
son type,son nom de colonne

exemple :
Nom de la colonne
Type a b c
x 150 250 300
z 125 210 301
a 175 190 302
r 175 180 303
x 187,5 150 304
x 200 127 305
x 212,5 104 306
z 225 81 307
a 237,5 58 308
r 250 35 309
x 262,5 12 310

J'ai mis dans une cellule K2 le type que je veux additionner et en K3 le
nom de la colonne dans laquelle je veux récupérer la somme des valeurs
correpondant au critères K2

J'ai mis en K4 la formule suivante
{=SOMME(INDEX(Base;EQUIV(K2;Type;0);EQUIV(K3;A2:D2;0)))}


Mais cela me donne le resultat de la premère valeur rencontrée ?
Exemple : type z et colonne B valeur récupérée : 210 au lieu de 291

Comment remédier au problème ?
merci pour votre aide.




.







Caetera
Le #20714541
"ttcpp"
Merci pour vos réponses
Toutefois celle de Caetera ne fonctionne pas #nombre



***************

Exemple là :
http://www.cijoint.fr/cjlink.php?file=cj200912/cijP8v4fNy.xls

Etc
ttcpp
Le #20714841
Je viens de trouver la solution
pour info voici la formule :
{=SOMME.SI($A$3:$A$13;$K$2;(DECALER($A$3:$A$13;;EQUIV($K$3;$A$2:$D$2;0)-1)))}

"ttcpp" wrote:

En fait la réponse de Daniel.C ne répond pas entièrement à mon problème (j'ai
mis dans l'exemple des critères trop simples)
En fait j'ai besoin de faire une {somme.si()} ou {somme(si(...) } car je
veux faire un regroupement de critères (ex tous les noms qui comment par A,
B , C....)
Merci encore pour votre aide.


"ttcpp" wrote:

> Merci pour vos réponses
> Toutefois celle de Caetera ne fonctionne pas #nombre ( je ne comprends pas
> comment on peut faire une sommeProd sans indiquer la colonne que l'on veut
> sommer)
> Par contre celle de Daniel. C fonctionne
>
> Encore merci.
>
> "Daniel.C" wrote:
>
> > Bonjour.
> > Essaie :
> > =SOMMEPROD((A2:A12=K2)*(DECALER(A2:A12;;EQUIV(K3;B1:D1;0))))
> > Daniel
> >
> > > Bonjour
> > >
> > > J'ai un problème avec une formule index +equiv.
> > > Je voudrais avoir le résultat d'une somme suivant 2 critéres:
> > > son type,son nom de colonne
> > >
> > > exemple :
> > > Nom de la colonne
> > > Type a b c
> > > x 150 250 300
> > > z 125 210 301
> > > a 175 190 302
> > > r 175 180 303
> > > x 187,5 150 304
> > > x 200 127 305
> > > x 212,5 104 306
> > > z 225 81 307
> > > a 237,5 58 308
> > > r 250 35 309
> > > x 262,5 12 310
> > >
> > > J'ai mis dans une cellule K2 le type que je veux additionner et en K3 le nom
> > > de la colonne dans laquelle je veux récupérer la somme des valeurs
> > > correpondant au critères K2
> > >
> > > J'ai mis en K4 la formule suivante
> > >> {=SOMME(INDEX(Base;EQUIV(K2;Type;0);EQUIV(K3;A2:D2;0)))}
> > > Mais cela me donne le resultat de la premère valeur rencontrée ?
> > > Exemple : type z et colonne B valeur récupérée : 210 au lieu de 291
> > >
> > > Comment remédier au problème ?
> > > merci pour votre aide.
> >
> >
> > .
> >


Publicité
Poster une réponse
Anonyme