somme de colonnes décalées d'un même intervalle

Le
j-pascal
Bonjour,

J'ai un tableau de 12 mois, dont chacun d'entre eux est divisé en 6
colonnes.
Dans mon tableau de synthèse, je souhaite récupérer la somme des valeurs de
chacun de ces mois en fonction de sa colonne (colonne "a" de janvier +
colonne "a" de février, etc.).

Est-il possible de passer par une formule du genre "DECALER" plutôt que "+"
"+" "+" "+" "+" "+" ?

Merci d'avance pour vos éventuelles réponses.
--
Cordialement @+
JP
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4866601
Bonjour,

Nombres en B2,H2,..

=SOMMEPROD(B2:BP2*(MOD(COLONNE(B2:BP2)+4;6)=0))

JB

On 20 juil, 12:55, "j-pascal"
Bonjour,

J'ai un tableau de 12 mois, dont chacun d'entre eux est divisé en 6
colonnes.
Dans mon tableau de synthèse, je souhaite récupérer la somme des va leurs de
chacun de ces mois en fonction de sa colonne (colonne "a" de janvier +
colonne "a" de février, etc.).

Est-il possible de passer par une formule du genre "DECALER" plutôt que "+"
"+" "+" "+" "+" "+" ... ?

Merci d'avance pour vos éventuelles réponses.
--
Cordialement @+
JP


j-pascal
Le #4865261
Bonjour,

Merci !

J'ai eu du mal à comprendre le [+4]. J'ai fait un tableau en changeant
l'intervalle [6] et j'ai conclu que 6 - 4 = 2 qui correspond à la colonne où
se trouve la première valeur additionnée ...

JP


"JB"
Bonjour,

Nombres en B2,H2,..

=SOMMEPROD(B2:BP2*(MOD(COLONNE(B2:BP2)+4;6)=0))

JB

On 20 juil, 12:55, "j-pascal"
Bonjour,

J'ai un tableau de 12 mois, dont chacun d'entre eux est divisé en 6
colonnes.
Dans mon tableau de synthèse, je souhaite récupérer la somme des valeurs
de
chacun de ces mois en fonction de sa colonne (colonne "a" de janvier +
colonne "a" de février, etc.).

Est-il possible de passer par une formule du genre "DECALER" plutôt que
"+"
"+" "+" "+" "+" "+" ... ?

Merci d'avance pour vos éventuelles réponses.
--
Cordialement @+
JP


j-pascal
Le #4864891
Re,

Finalement, je ne suis pas sûr d'avoir compris le [+4].
Ok pour l'intervalle avec le [6], mais comment détermine-t-on la première
cellule comptabilisée ?

Y compris dans le cas où le résultat doit s'afficher dans une colonne autre
que "A".
Exemple, j'ai le résultat des sommes dans F, G, H, I (contenant ta formule)
des valeurs contenues dans J, K, L, M et N, O, P, Q et R, S, T, U.

Soit F = J + N + R
Soit G = K + O + S
Soit H = L + P + T
etc

@+ ?

JP

"JB"
Bonjour,

Nombres en B2,H2,..

=SOMMEPROD(B2:BP2*(MOD(COLONNE(B2:BP2)+4;6)=0))

JB

On 20 juil, 12:55, "j-pascal"
Bonjour,

J'ai un tableau de 12 mois, dont chacun d'entre eux est divisé en 6
colonnes.
Dans mon tableau de synthèse, je souhaite récupérer la somme des valeurs
de
chacun de ces mois en fonction de sa colonne (colonne "a" de janvier +
colonne "a" de février, etc.).

Est-il possible de passer par une formule du genre "DECALER" plutôt que
"+"
"+" "+" "+" "+" "+" ... ?

Merci d'avance pour vos éventuelles réponses.
--
Cordialement @+
JP


JB
Le #4864861
http://cjoint.com/?hvqjOG7cnX

=SOMMEPROD(B2:BP2*(MOD(COLONNE(B2:BP2)+6-COLONNE(B2);6)=0)

Si on insère des colonnes à gauche de B, laformule est adaptée.

JB



On 21 juil, 15:29, "j-pascal"
Re,

Finalement, je ne suis pas sûr d'avoir compris le [+4].
Ok pour l'intervalle avec le [6], mais comment détermine-t-on la premi ère
cellule comptabilisée ?

Y compris dans le cas où le résultat doit s'afficher dans une colonne autre
que "A".
Exemple, j'ai le résultat des sommes dans F, G, H, I (contenant ta form ule)
des valeurs contenues dans J, K, L, M et N, O, P, Q et R, S, T, U.

Soit F = J + N + R
Soit G = K + O + S
Soit H = L + P + T
etc

@+ ?

JP

"JB"
Bonjour,

Nombres en B2,H2,..

=SOMMEPROD(B2:BP2*(MOD(COLONNE(B2:BP2)+4;6)=0))

JB

On 20 juil, 12:55, "j-pascal"


Bonjour,

J'ai un tableau de 12 mois, dont chacun d'entre eux est divisé en 6
colonnes.
Dans mon tableau de synthèse, je souhaite récupérer la somme des valeurs
de
chacun de ces mois en fonction de sa colonne (colonne "a" de janvier +
colonne "a" de février, etc.).

Est-il possible de passer par une formule du genre "DECALER" plutôt q ue
"+"
"+" "+" "+" "+" "+" ... ?

Merci d'avance pour vos éventuelles réponses.
--
Cordialement @+
JP- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



j-pascal
Le #4864771
Bonsoir,

Désolé, il y a un truc que je ne comprends pas :

Mon classeur "simplifié" est ici :

http://cjoint.com/?hvtdZnXm76

@+ ?

JP


"JB"
http://cjoint.com/?hvqjOG7cnX

=SOMMEPROD(B2:BP2*(MOD(COLONNE(B2:BP2)+6-COLONNE(B2);6)=0)

Si on insère des colonnes à gauche de B, laformule est adaptée.

JB



On 21 juil, 15:29, "j-pascal"
Re,

Finalement, je ne suis pas sûr d'avoir compris le [+4].
Ok pour l'intervalle avec le [6], mais comment détermine-t-on la première
cellule comptabilisée ?

Y compris dans le cas où le résultat doit s'afficher dans une colonne
autre
que "A".
Exemple, j'ai le résultat des sommes dans F, G, H, I (contenant ta
formule)
des valeurs contenues dans J, K, L, M et N, O, P, Q et R, S, T, U.

Soit F = J + N + R
Soit G = K + O + S
Soit H = L + P + T
etc

@+ ?

JP

"JB"
Bonjour,

Nombres en B2,H2,..

=SOMMEPROD(B2:BP2*(MOD(COLONNE(B2:BP2)+4;6)=0))

JB

On 20 juil, 12:55, "j-pascal"


Bonjour,

J'ai un tableau de 12 mois, dont chacun d'entre eux est divisé en 6
colonnes.
Dans mon tableau de synthèse, je souhaite récupérer la somme des valeurs
de
chacun de ces mois en fonction de sa colonne (colonne "a" de janvier +
colonne "a" de février, etc.).

Est-il possible de passer par une formule du genre "DECALER" plutôt que
"+"
"+" "+" "+" "+" "+" ... ?

Merci d'avance pour vos éventuelles réponses.
--
Cordialement @+
JP- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Publicité
Poster une réponse
Anonyme