Somme : compris dans une fourchette de nombres

Le
Michel O
Bonjour,

J'aurais besoin de vos lumières SVP
Je souhaite faire une somme de nombre compris dans une fourchette de
nombres.
Par exemple dans une balance comptable qui comprend des comptes entre
100000 et 799999
Je voudrais additionner les montants de tous les comptes compris en
140000 et 149999
Merci pour votre aide

Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #21270171
Bonjour.
Avec les comptes en A1:A20 et les montants correspondants en colonne B
:
=SOMMEPROD((A1:A20>0000)*(A1:A20<150000)*B1:B20)
Cordialement.
Daniel

Bonjour,

J'aurais besoin de vos lumières SVP
Je souhaite faire une somme de nombre compris dans une fourchette de
nombres.
Par exemple dans une balance comptable qui comprend des comptes entre
100000 et 799999
Je voudrais additionner les montants de tous les comptes compris en
140000 et 149999
Merci pour votre aide

Michel


Michel O
Le #21270581
Super Daniel et un grand merci,

C'est exactement ce que je voulais et ça marche
Seul hic, et je ne suis vraiment pas doué,
je souhaite soustraite des montants débits trouvés en b1:b20 les
credits en c1:c20
Désolé !!
Daniel.C
Le #21270721
=SOMMEPROD((A1:A20>0000)*(A1:A20<150000)*(B1:B20-C1:C20))
Daniel

Super Daniel et un grand merci,

C'est exactement ce que je voulais et ça marche
Seul hic, et je ne suis vraiment pas doué,
je souhaite soustraite des montants débits trouvés en b1:b20 les
credits en c1:c20
Désolé !!


Michel O
Le #21270971
Ah bougre, j'ai du mal, il me répond #N/A

=SOMMEPROD(('bal def'!$A$1:$A$999>Ä0)*('bal def'!$A$1:$A
$999<Ô0)*('bal def'!$C$2:$C$999-'bal def'!$D$2:$D$999))
Daniel.C
Le #21271041
Je n'arrive pas à reproduire. Est-ce que tu peux mettre un classeur
exemple sur www.cjoint.com, en supprimant les données confidentielles ?
Poste ensuite ici le lien généré. En cas de difficulté, reviens
demander de plus amples explications.
Daniel

Ah bougre, j'ai du mal, il me répond #N/A

=SOMMEPROD(('bal def'!$A$1:$A$999>Ä0)*('bal def'!$A$1:$A
$999<Ô0)*('bal def'!$C$2:$C$999-'bal def'!$D$2:$D$999))


Michel O
Le #21271121
Voilà le fichier un peu nettoyé
Merci
http://cjoint.com/?cAmeUtdVYJ
Daniel.C
Le #21271261
Voici le fichier modifié:
http://www.cijoint.fr/cjlink.php?file=cj201002/cijlVXZlTe.xlsx
Le problème vient de ce qu'il y a des entêtes au dessus des montants.
Les plages de cellules doivent donc commencer en ligne 2.
Daniel

Voilà le fichier un peu nettoyé
Merci
http://cjoint.com/?cAmeUtdVYJ


Daniel.C
Le #21271251
Oups, erreur de formule, mettre en E2 :
=SOMMEPROD(('bal def'!$A$2:$A$999>=$C2)*('bal
def'!$A$2:$A$999<=$D2)*('bal def'!$C$2:$C$999-'bal def'!$D$2:$D$999))
et recopier vers le bas.
Daniel

Voici le fichier modifié:
http://www.cijoint.fr/cjlink.php?file=cj201002/cijlVXZlTe.xlsx
Le problème vient de ce qu'il y a des entêtes au dessus des montants. Les
plages de cellules doivent donc commencer en ligne 2.
Daniel

Voilà le fichier un peu nettoyé
Merci
http://cjoint.com/?cAmeUtdVYJ




Michel O
Le #21271441
Super, merci merci merci beaucoup
Bonne journée
Michel
Publicité
Poster une réponse
Anonyme