Somme conditionnelle

Le
cynoq.cover
Bonjour à tous,
Je cherche une solution à mon problème qui est le suivant :
J'ai une grille dans laquelle je retrouve par colonne :
A : une date (jour / mois / année)
B : une croix ou rien (une conception)
C : une croix ou rien (une impression)
D : "fr" ou "em" (initiales de prénom nom)
E : une durée en hh:mm

Je voudrai donc calculer le temps par personne (fr ou em) pour chaque
mois de l'année, une premier résultat qui serait en rapport avec les
coches de la colonne B et un autre résultat en rapport avec les coches
de la colonne C.

Je pense que je dois mettre en place la formule SOMME.SI() mais je
ne vois pas très bien comment.

Merci par avance pour vos lumières.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4228701
Bonjour.
Formule à mettre en ligne 1 et à recopier jusqu'en ligne 12 :
=SOMMEPROD((MOIS($A$1:$A$30)=LIGNE())*($B$1:$B$30="x")*($D$1:$D$30="fr")*$E$1:$E$30)
(correspond à fr et x en colonne B, la ligne 1 correspond à janvier, la
ligne 12 à décembre).
Cordialement.
Daniel

Bonjour à tous,
Je cherche une solution à mon problème qui est le suivant :
J'ai une grille dans laquelle je retrouve par colonne :
A : une date (jour / mois / année)
B : une croix ou rien (une conception)
C : une croix ou rien (une impression)
D : "fr" ou "em" (initiales de prénom nom)
E : une durée en hh:mm

Je voudrai donc calculer le temps par personne (fr ou em) pour chaque
mois de l'année, une premier résultat qui serait en rapport avec les
coches de la colonne B et un autre résultat en rapport avec les coches
de la colonne C.

Je pense que je dois mettre en place la formule SOMME.SI(...) mais je
ne vois pas très bien comment.

Merci par avance pour vos lumières.
cynoq.cover
Le #4228681
J'ai beau eassayer ça ne fonctionne pas, j'ai toujours #VALEUR qui
s'affiche.

On 5 mar, 14:11, "Daniel"
Bonjour.
Formule à mettre en ligne 1 et à recopier jusqu'en ligne 12 :
=SOMMEPROD((MOIS($A$1:$A$30)=LIGNE())*($B$1:$B$30="x")*($D$1:$D$30 ="fr")*$E$1:$E$30)
(correspond à fr et x en colonne B, la ligne 1 correspond à janvier, la
ligne 12 à décembre).
Cordialement.
Daniel

Bonjour à tous,
Je cherche une solution à mon problème qui est le suivant :
J'ai une grille dans laquelle je retrouve par colonne :
A : une date (jour / mois / année)
B : une croix ou rien (une conception)
C : une croix ou rien (une impression)
D : "fr" ou "em" (initiales de prénom nom)
E : une durée en hh:mm

Je voudrai donc calculer le temps par personne (fr ou em) pour chaque
mois de l'année, une premier résultat qui serait en rapport avec les
coches de la colonne B et un autre résultat en rapport avec les coches
de la colonne C.

Je pense que je dois mettre en place la formule SOMME.SI(...) mais je
ne vois pas très bien comment.

Merci par avance pour vos lumières.


Daniel
Le #4228671
regarde le classeur à l'adresse :
http://cjoint.com/?dfoVNviJdm
Daniel

J'ai beau eassayer ça ne fonctionne pas, j'ai toujours #VALEUR qui
s'affiche.

On 5 mar, 14:11, "Daniel"
Bonjour.
Formule à mettre en ligne 1 et à recopier jusqu'en ligne 12 :
=SOMMEPROD((MOIS($A$1:$A$30)=LIGNE())*($B$1:$B$30="x")*($D$1:$D$30="fr")*$E$1:$E$30)
(correspond à fr et x en colonne B, la ligne 1 correspond à janvier, la
ligne 12 à décembre).
Cordialement.
Daniel

Bonjour à tous,
Je cherche une solution à mon problème qui est le suivant :
J'ai une grille dans laquelle je retrouve par colonne :
A : une date (jour / mois / année)
B : une croix ou rien (une conception)
C : une croix ou rien (une impression)
D : "fr" ou "em" (initiales de prénom nom)
E : une durée en hh:mm

Je voudrai donc calculer le temps par personne (fr ou em) pour chaque
mois de l'année, une premier résultat qui serait en rapport avec les
coches de la colonne B et un autre résultat en rapport avec les coches
de la colonne C.

Je pense que je dois mettre en place la formule SOMME.SI(...) mais je
ne vois pas très bien comment.

Merci par avance pour vos lumières.


cynoq.cover
Le #4228621
Ok, je comprend mieux. la fonction LIGNE() reprend le numéro de la
ligne sur laquelle se trouve la formule. Mais dans ce cas, comment
puis-je faire si ma formule est décalée (je ne peux pas mettre la
ligne correspondant à janvier sur la ligne 1) ?
Merci encore.

On 5 mar, 14:48, "Daniel"
regarde le classeur à l'adresse :http://cjoint.com/?dfoVNviJdm
Daniel

J'ai beau eassayer ça ne fonctionne pas, j'ai toujours #VALEUR qui
s'affiche.

On 5 mar, 14:11, "Daniel"
Bonjour.
Formule à mettre en ligne 1 et à recopier jusqu'en ligne 12 :
=SOMMEPROD((MOIS($A$1:$A$30)=LIGNE())*($B$1:$B$30="x")*($D$1:$D$3 0="fr")*$E$1:$E$30)
(correspond à fr et x en colonne B, la ligne 1 correspond à janvier , la
ligne 12 à décembre).
Cordialement.
Daniel

Bonjour à tous,
Je cherche une solution à mon problème qui est le suivant :
J'ai une grille dans laquelle je retrouve par colonne :
A : une date (jour / mois / année)
B : une croix ou rien (une conception)
C : une croix ou rien (une impression)
D : "fr" ou "em" (initiales de prénom nom)
E : une durée en hh:mm

Je voudrai donc calculer le temps par personne (fr ou em) pour chaque
mois de l'année, une premier résultat qui serait en rapport avec les
coches de la colonne B et un autre résultat en rapport avec les coches
de la colonne C.

Je pense que je dois mettre en place la formule SOMME.SI(...) mais je
ne vois pas très bien comment.

Merci par avance pour vos lumières.




Daniel
Le #4228611
Tu peux remplacer "LIGNE()" par le numéro du mois dans chaque formule; tu
peux aussi, si tu mets la formule en ligne 10, mettre "LIGNE()-9", ce qui
tévite de modifier chaque formule.
Daniel

Ok, je comprend mieux. la fonction LIGNE() reprend le numéro de la
ligne sur laquelle se trouve la formule. Mais dans ce cas, comment
puis-je faire si ma formule est décalée (je ne peux pas mettre la
ligne correspondant à janvier sur la ligne 1) ?
Merci encore.

On 5 mar, 14:48, "Daniel"
regarde le classeur à l'adresse :http://cjoint.com/?dfoVNviJdm
Daniel

J'ai beau eassayer ça ne fonctionne pas, j'ai toujours #VALEUR qui
s'affiche.

On 5 mar, 14:11, "Daniel"
Bonjour.
Formule à mettre en ligne 1 et à recopier jusqu'en ligne 12 :
=SOMMEPROD((MOIS($A$1:$A$30)=LIGNE())*($B$1:$B$30="x")*($D$1:$D$30="fr")*$E$1:$E$30)
(correspond à fr et x en colonne B, la ligne 1 correspond à janvier, la
ligne 12 à décembre).
Cordialement.
Daniel

Bonjour à tous,
Je cherche une solution à mon problème qui est le suivant :
J'ai une grille dans laquelle je retrouve par colonne :
A : une date (jour / mois / année)
B : une croix ou rien (une conception)
C : une croix ou rien (une impression)
D : "fr" ou "em" (initiales de prénom nom)
E : une durée en hh:mm

Je voudrai donc calculer le temps par personne (fr ou em) pour chaque
mois de l'année, une premier résultat qui serait en rapport avec les
coches de la colonne B et un autre résultat en rapport avec les coches
de la colonne C.

Je pense que je dois mettre en place la formule SOMME.SI(...) mais je
ne vois pas très bien comment.

Merci par avance pour vos lumières.




Jacky
Le #4228571
Bonjour

Une autre façon de faire....très analogue, sans utiliser ligne, et les zones
nommées
http://cjoint.com/?dfqMsQqFku

Salutations
JJ



Ok, je comprend mieux. la fonction LIGNE() reprend le numéro de la
ligne sur laquelle se trouve la formule. Mais dans ce cas, comment
puis-je faire si ma formule est décalée (je ne peux pas mettre la
ligne correspondant à janvier sur la ligne 1) ?
Merci encore.

On 5 mar, 14:48, "Daniel"
regarde le classeur à l'adresse :http://cjoint.com/?dfoVNviJdm
Daniel

J'ai beau eassayer ça ne fonctionne pas, j'ai toujours #VALEUR qui
s'affiche.

On 5 mar, 14:11, "Daniel"
Bonjour.
Formule à mettre en ligne 1 et à recopier jusqu'en ligne 12 :
=SOMMEPROD((MOIS($A$1:$A$30)=LIGNE())*($B$1:$B$30="x")*($D$1:$D$30="fr")*$E$1:$E$30)
(correspond à fr et x en colonne B, la ligne 1 correspond à janvier, la
ligne 12 à décembre).
Cordialement.
Daniel

Bonjour à tous,
Je cherche une solution à mon problème qui est le suivant :
J'ai une grille dans laquelle je retrouve par colonne :
A : une date (jour / mois / année)
B : une croix ou rien (une conception)
C : une croix ou rien (une impression)
D : "fr" ou "em" (initiales de prénom nom)
E : une durée en hh:mm

Je voudrai donc calculer le temps par personne (fr ou em) pour chaque
mois de l'année, une premier résultat qui serait en rapport avec les
coches de la colonne B et un autre résultat en rapport avec les coches
de la colonne C.

Je pense que je dois mettre en place la formule SOMME.SI(...) mais je
ne vois pas très bien comment.

Merci par avance pour vos lumières.




Publicité
Poster une réponse
Anonyme