Somme sur critère de dates fériées

Le
FREDSCOPE
Bonjour à tous et à toutes ,

Toujour admiratif de vos connaissances, je me permet de venir vers
vous pour essayer d'améliorer le point suivant :

Je suis en train de créer un planning pour des salariés. A l'aide de
MFC j'arrive à mettre automatiquement en couleur les jours fériés qui
sont répertoriés dans une liste (champ nommé jfériés). Cette part=
ie me
convient parfaitement. fonction NB.SI(jfériés;A5)=1

Les salariés peuvent travailler les jours fériés et je dois sommer le=
s
heures travaillées fériées dans une colonne afin qu'ils soient payé=
s
en conséquence.

J'ai réussi à faire cette somme en ajoutant par une fonction si un
code F dans la cellule se trouvant au dessus de la date. J'ai ensuite
mis une fonction somme.si qui me permet de faire la somme des heures
fériées.

Je n'arrive pas à supprimer cette étape de code F. Je n'arrive pas à
exprimer la condition dans somme.si.

Y aurait-il une possibilité de faire un test sur le fait que la
journée soit fériée ou non directement.

Je ne suis pas certain que ça soit clair. Le fichier est ici :
http://www.cijoint.fr/cjlink.php?file=cj200909/cijLHJFbx9.xls


La formule est en colonne BC

Merci d'avance pour le temps que vous pourrez consacrer au problème


Fred.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal
Le #20118031
Bonjour,
Il existe une fonction Fériés qui te permettrait de supprimer l'étape "F".
Regarde du côté d'excelabo tu devrais trouver ton bonheur.

Pascal


"FREDSCOPE"
Bonjour à tous et à toutes ,

Toujour admiratif de vos connaissances, je me permet de venir vers
vous pour essayer d'améliorer le point suivant :

Je suis en train de créer un planning pour des salariés. A l'aide de
MFC j'arrive à mettre automatiquement en couleur les jours fériés qui
sont répertoriés dans une liste (champ nommé jfériés). Cette partie me
convient parfaitement. fonction NB.SI(jfériés;A5)=1

Les salariés peuvent travailler les jours fériés et je dois sommer les
heures travaillées fériées dans une colonne afin qu'ils soient payés
en conséquence.

J'ai réussi à faire cette somme en ajoutant par une fonction si un
code F dans la cellule se trouvant au dessus de la date. J'ai ensuite
mis une fonction somme.si qui me permet de faire la somme des heures
fériées.

Je n'arrive pas à supprimer cette étape de code F. Je n'arrive pas à
exprimer la condition dans somme.si.

Y aurait-il une possibilité de faire un test sur le fait que la
journée soit fériée ou non directement.

Je ne suis pas certain que ça soit clair. Le fichier est ici :
http://www.cijoint.fr/cjlink.php?file=cj200909/cijLHJFbx9.xls


La formule est en colonne BC

Merci d'avance pour le temps que vous pourrez consacrer au problème


Fred.
Pascal
Le #20118021
j'ai retrouvé cela si ca peut t'aider:

Function TYPEJOUR(D As Date)
'L. Longre
Dim A As Integer, T As Integer
Dim LP As Date, LD As Long
Dim Toto As Long

A = Year(D)
If A > 2099 Then
TYPEJOUR = CVErr(xlErrValue)
Exit Function
End If
LD = Int(D)
If LD <= 2 Then
If LD = 1 Then TYPEJOUR = 2
Exit Function
End If
T = (((255 - 11 * (A Mod 19)) - 21) Mod 30) + 21
LP = DateSerial(A, 3, 2) + T + (T > 48) _
+ 6 - ((A + A 4 + T + (T > 48) + 1) Mod 7)
Select Case D
' Jours fériés mobiles
Case Is = LP, Is = LP + 38, Is = LP + 49
TYPEJOUR = 2
' Jours fériés fixes
Case Is = DateSerial(A, 1, 1), Is = DateSerial(A, 5, 1), _
Is = DateSerial(A, 5, 8), Is = DateSerial(A, 7, 14), _
Is = DateSerial(A, 8, 15), Is = DateSerial(A, 11, 1), _
Is = DateSerial(A, 11, 11), Is = DateSerial(A, 12, 25)
TYPEJOUR = 2
Case Else
' Samedi ou dimanche
If Weekday(D, vbMonday) >= 6 Then TYPEJOUR = 1
End Select

End Function
"FREDSCOPE"
Bonjour à tous et à toutes ,

Toujour admiratif de vos connaissances, je me permet de venir vers
vous pour essayer d'améliorer le point suivant :

Je suis en train de créer un planning pour des salariés. A l'aide de
MFC j'arrive à mettre automatiquement en couleur les jours fériés qui
sont répertoriés dans une liste (champ nommé jfériés). Cette partie me
convient parfaitement. fonction NB.SI(jfériés;A5)=1

Les salariés peuvent travailler les jours fériés et je dois sommer les
heures travaillées fériées dans une colonne afin qu'ils soient payés
en conséquence.

J'ai réussi à faire cette somme en ajoutant par une fonction si un
code F dans la cellule se trouvant au dessus de la date. J'ai ensuite
mis une fonction somme.si qui me permet de faire la somme des heures
fériées.

Je n'arrive pas à supprimer cette étape de code F. Je n'arrive pas à
exprimer la condition dans somme.si.

Y aurait-il une possibilité de faire un test sur le fait que la
journée soit fériée ou non directement.

Je ne suis pas certain que ça soit clair. Le fichier est ici :
http://www.cijoint.fr/cjlink.php?file=cj200909/cijLHJFbx9.xls


La formule est en colonne BC

Merci d'avance pour le temps que vous pourrez consacrer au problème


Fred.
isabelle
Le #20118241
bonjour Fred,

la formule suivante fonctionne : =SOMMEPROD((G6:M6)*(NB.SI(jfériés;G5:M5)))
mais celle-ci : =SOMMEPROD((G6:AW6)*(NB.SI(jfériés;G5:AW5)))
ne fonctionne pas, il faudrait mettre sur deux lignes différentes les
date et les titre de colonne (Al: AP par exemple)

isabelle

FREDSCOPE a écrit :
Bonjour à tous et à toutes ,

Toujour admiratif de vos connaissances, je me permet de venir vers
vous pour essayer d'améliorer le point suivant :

Je suis en train de créer un planning pour des salariés. A l'aide de
MFC j'arrive à mettre automatiquement en couleur les jours fériés qui
sont répertoriés dans une liste (champ nommé jfériés). Cette partie me
convient parfaitement. fonction NB.SI(jfériés;A5)=1

Les salariés peuvent travailler les jours fériés et je dois sommer les
heures travaillées fériées dans une colonne afin qu'ils soient payés
en conséquence.

J'ai réussi à faire cette somme en ajoutant par une fonction si un
code F dans la cellule se trouvant au dessus de la date. J'ai ensuite
mis une fonction somme.si qui me permet de faire la somme des heures
fériées.

Je n'arrive pas à supprimer cette étape de code F. Je n'arrive pas à
exprimer la condition dans somme.si.

Y aurait-il une possibilité de faire un test sur le fait que la
journée soit fériée ou non directement.

Je ne suis pas certain que ça soit clair. Le fichier est ici :
http://www.cijoint.fr/cjlink.php?file=cj200909/cijLHJFbx9.xls


La formule est en colonne BC

Merci d'avance pour le temps que vous pourrez consacrer au problème


Fred.



isabelle
Le #20118461
bonjour fred,

oublie ce que j'ai dit précédemment, voici la solution :

=SOMMEPROD((NB.SI(jfériés;G5:AW5))*SI((ESTTEXTE(G6:AW6));0;G6:AW6))
matricielle à valider avec ctrl+maj+enter

isabelle

FREDSCOPE a écrit :
Bonjour à tous et à toutes ,

Toujour admiratif de vos connaissances, je me permet de venir vers
vous pour essayer d'améliorer le point suivant :

Je suis en train de créer un planning pour des salariés. A l'aide de
MFC j'arrive à mettre automatiquement en couleur les jours fériés qui
sont répertoriés dans une liste (champ nommé jfériés). Cette partie me
convient parfaitement. fonction NB.SI(jfériés;A5)=1

Les salariés peuvent travailler les jours fériés et je dois sommer les
heures travaillées fériées dans une colonne afin qu'ils soient payés
en conséquence.

J'ai réussi à faire cette somme en ajoutant par une fonction si un
code F dans la cellule se trouvant au dessus de la date. J'ai ensuite
mis une fonction somme.si qui me permet de faire la somme des heures
fériées.

Je n'arrive pas à supprimer cette étape de code F. Je n'arrive pas à
exprimer la condition dans somme.si.

Y aurait-il une possibilité de faire un test sur le fait que la
journée soit fériée ou non directement.

Je ne suis pas certain que ça soit clair. Le fichier est ici :
http://www.cijoint.fr/cjlink.php?file=cj200909/cijLHJFbx9.xls


La formule est en colonne BC

Merci d'avance pour le temps que vous pourrez consacrer au problème


Fred.



FREDSCOPE
Le #20119471
Bonjour,

Merci pour votre réponse. J'ai oublié de vous dire que je ne pouvais
pas mettre de code car certains utilisateurs sont sur Open Office...

Je retiens toutefois la procédure pour une autre application.

Fred
FREDSCOPE
Le #20119461
Bonjour et merci de votre réponse,

Je ne pense pas que ça me simplifie la procédure car les deux lignes
sont conservées.

Je pense que je vais garder ma solution.

Merci de vous être penché sur le problème.

Fred

On 11 sep, 14:54, isabelle wrote:
bonjour fred,

oublie ce que j'ai dit précédemment, voici la solution :

=SOMMEPROD((NB.SI(jfériés;G5:AW5))*SI((ESTTEXTE(G6:AW6));0;G6:AW6))
matricielle à valider avec ctrl+maj+enter

isabelle



isabelle
Le #20119741
bonjour Fred,

mais non, regarde à la ligne 3 il n'y a plus de "F" et en cellule
BC6:BC15 il y a la formule.
{=SOMMEPROD((NB.SI(jfériés;$G$5:$AW$5))*SI(ESTTEXTE(G6:AW6);0;G6:AW6))}
ps/ j'ai changé le nom du fichier pour "SommeProd calendrier avec texte
et numérique"

http://cjoint.com/?jlrreGZHJ3

isabelle

FREDSCOPE a écrit :
Bonjour et merci de votre réponse,

Je ne pense pas que ça me simplifie la procédure car les deux lignes
sont conservées.

Je pense que je vais garder ma solution.

Merci de vous être penché sur le problème.

Fred

On 11 sep, 14:54, isabelle wrote:

bonjour fred,

oublie ce que j'ai dit précédemment, voici la solution :

=SOMMEPROD((NB.SI(jfériés;G5:AW5))*SI((ESTTEXTE(G6:AW6));0;G6:AW6))
matricielle à valider avec ctrl+maj+enter

isabelle






FREDSCOPE
Le #20139211
Bonjour Isabelle,

Désolé, j'ai regardé trop vite. Ca marche impécable.

Merci beaucoup, car je suis loin de maitriser les fonctions SOMMEPROD.

Fred

On 11 sep, 17:18, isabelle wrote:
bonjour Fred,

mais non, regarde à la ligne 3 il n'y a plus de "F" et en cellule
BC6:BC15 il y a la formule.
{=SOMMEPROD((NB.SI(jfériés;$G$5:$AW$5))*SI(ESTTEXTE(G6:AW6);0;G6:AW 6))}
ps/ j'ai changé le nom du fichier pour  "SommeProd calendrier avec te xte
et numérique"

http://cjoint.com/?jlrreGZHJ3

isabelle

FREDSCOPE a écrit :



> Bonjour et merci de votre réponse,

> Je ne pense pas que ça me simplifie la procédure car les deux ligne s
> sont conservées.

> Je pense que je vais garder ma solution.

> Merci de vous être penché sur le problème.

> Fred

> On 11 sep, 14:54, isabelle wrote:

>> bonjour fred,

>> oublie ce que j'ai dit précédemment, voici la solution :

>> =SOMMEPROD((NB.SI(jfériés;G5:AW5))*SI((ESTTEXTE(G6:AW6));0;G6:AW 6))
>> matricielle à valider avec ctrl+maj+enter

>> isabelle- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Publicité
Poster une réponse
Anonyme