somme en deux dates

Le
magic-dd
Bonsoir

j'aimerai dans un classeur compter le nombre d'arrivées et de depart entr=
e 2 dates

j'ai bien essayé le somme prod mais il ne me calcul que le nombre de lign=
e entre ces dates

je vous joins un fichier exemple

merci

http://cjoint.com/?CLmsAdVjIJX
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #25865552
Bonjour,

Tu as utilisé ceci comme formule de "Sommeprod"?
=SOMMEPROD((A3:A184>G2)*(A3:A184<H2))
= 72

La réponse est inexacte?
GL
Le #25865692
Le 12/12/2013 18:43, MichD a écrit :
Bonjour,

Tu as utilisé ceci comme formule de "Sommeprod"?
=SOMMEPROD((A3:A184>G2)*(A3:A184<H2))
= 72

La réponse est inexacte?



Sinon on peut aussi utiliser

=NB.SI.ENS(<plage>;">=" & <date_debut> ; <plage> ; "<=" & <date_fin>)

Cdt.
magic-dd
Le #25865802
Bonsoir MichD

oui la reponse de 72 est inexacte car elle ne donne que le nombre de valeur s entre les dates du 01/09 et 30/09

or en arrivées dans cet ecart la il y a 83 et en depart 83 au ssi soit 16 6


Le jeudi 12 décembre 2013 18:43:03 UTC+1, MichD a écrit :
Bonjour,



Tu as utilis� ceci comme formule de "Sommeprod"?

=SOMMEPROD((A3:A184>G2)*(A3:A184<H2))

= 72



La r�ponse est inexacte?
magic-dd
Le #25865792
merci mais cela ne fonctionne pas sur mon exemple


Le jeudi 12 décembre 2013 18:56:24 UTC+1, GL a écrit :
Le 12/12/2013 18:43, MichD a �crit :

> Bonjour,

>

> Tu as utilis� ceci comme formule de "Sommeprod"?

> =SOMMEPROD((A3:A184>G2)*(A3:A184<H2))

> = 72

>

> La r�ponse est inexacte?

>

Sinon on peut aussi utiliser



=NB.SI.ENS(<plage>;">=" & <date_debut> ; <plage> ; "<=" & <date_fin >)



Cdt.
MichD
Le #25866092
Désolé, je n'ai pas bien lu la question :

Essaie plutôt ceci pour le nombre de départ :
=SOMMEPROD((A3:A184>G2)*(A3:A184<H2);(B3:B184))
Jacquouille
Le #25866232
Bonjour
Sommeprod n'aime pas les colonnes complètes du style (a:a) comme plage. Il
faut lui laisser au moins 1 ligne pour respirer.
Ensuite, éviter A TOUT PRIX les cellules fusionnées.
Ensuite, sélectionner la plage B3:C184, puis Menu/edition/remplacer -->
laisser vide et mettre 0 dans la fenêtre "par".
Autrement dit, remplacer les cel vides par 0
Ensuite, vérifier que les plages calculées sont toutes de même longueur (a,
b et c 3:a184)
Et cela donne bien 83



Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"magic-dd" a écrit dans le message de groupe de discussion :


Bonsoir

j'aimerai dans un classeur compter le nombre d'arrivées et de depart entre 2
dates

j'ai bien essayé le somme prod mais il ne me calcul que le nombre de ligne
entre ces dates

je vous joins un fichier exemple

merci

http://cjoint.com/?CLmsAdVjIJX
magic-dd
Le #25866482
Bonsoir,

en effet j'ai remplacé mes cellules vides par des 0 et cel fonctionne

en revanche, si je prends des zonnes nommées, cela ne fonctionne pas

bizarre



Le jeudi 12 décembre 2013 20:08:34 UTC+1, Jacquouille a écrit :
Bonjour

Sommeprod n'aime pas les colonnes compl�tes du style (a:a) comme plage. Il

faut lui laisser au moins 1 ligne pour respirer.

Ensuite, �viter A TOUT PRIX les cellules fusionn�es.

Ensuite, s�lectionner la plage B3:C184, puis Menu/edition/remplac er -->

laisser vide et mettre 0 dans la fen�tre "par".

Autrement dit, remplacer les cel vides par 0

Ensuite, v�rifier que les plages calcul�es sont toutes de m�me longueur (a,

b et c 3:a184)

Et cela donne bien 83







Jacquouille



" Le vin est au repas ce que le parfum est � la femme."

"magic-dd" a �crit dans le message de groupe de discussion :





Bonsoir



j'aimerai dans un classeur compter le nombre d'arriv�es et de dep art entre 2

dates



j'ai bien essay� le somme prod mais il ne me calcul que le nombre de ligne

entre ces dates



je vous joins un fichier exemple



merci



http://cjoint.com/?CLmsAdVjIJX
MichD
Le #25866472
Ma formule fonctionne sans modifier ta plage de cellules!
Jacquouille
Le #25866532
Effectivement, Denis.
Elle fonctionne.
mais, je crois avoir remarqué que les plages nommées par le demandeur n'ont
pas toutes la même longueur.
Je profite du présent pour te demander pourquoi tu utilises le * entre les
dates et le ; pour el troisième argument. l'un et l'autre fonctionnent bien.
Qu'y a-t-il comme motivation à utiliser le ; ?
Merci et bonne soirée.

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"MichD" a écrit dans le message de groupe de discussion :
l8d3vl$bf1$


Ma formule fonctionne sans modifier ta plage de cellules!
magic-dd
Le #25866572
j'ai fais correctement avec les plage de meme taille

cela fonctionne

mais quand je veux utiliser mes zones nommées alors ca ne marche plus

peut etre qu'il faudrait utiliser une plage dynamique mais je balbutie dess us

un peu d'aide serait la bienvenue

:)


Le jeudi 12 décembre 2013 21:11:19 UTC+1, Jacquouille a écrit :
Effectivement, Denis.

Elle fonctionne.

mais, je crois avoir remarqu� que les plages nomm�es par le demandeur n'ont

pas toutes la m�me longueur.

Je profite du pr�sent pour te demander pourquoi tu utilises le * entre les

dates et le ; pour el troisi�me argument. l'un et l'autre fonctio nnent bien.

Qu'y a-t-il comme motivation � utiliser le ; ?

Merci et bonne soir�e.



Jacquouille



" Le vin est au repas ce que le parfum est � la femme."

"MichD" a �crit dans le message de groupe de discussion :

l8d3vl$bf1$





Ma formule fonctionne sans modifier ta plage de cellules!
Publicité
Poster une réponse
Anonyme