Somme de mots différents

Le
Guy72
Bonsoir
Dans le tableau J4:K34 j'ai des textes "Brouillard"_"Neige"_"Pluie".
Dans la cellule P389, je voudrais le total des textes divisé par 2
J'ai essayé de trouver une formule mais..
=NB.SI(OU(J4:K34;"Brouillard";J4:K34;"Neige";J4:K34;"Pluie");"")/2)
Une idée ?
Cordialement
Guy
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #5028111
Bonsoir,

=(SOMMEPROD((J4:K34<>"")*(J4:K34="Neige"))+SOMMEPROD((J4:K34<>"")*(J4:K34="Pluie"))+SOMMEPROD((J4:K34<>"")*(J4:K34="Brouillard")))/2

devrait pouvoir convenir pour dénombrer ces 3 items parmi d'autres

Si toutefois il n'y avait sur la plage que ces items ou rien, une formule
comme :

=NBVAL(J4:K34)/2

suffirait
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"Guy72" news:
Bonsoir
Dans le tableau J4:K34 j'ai des textes "Brouillard"_"Neige"_"Pluie".
Dans la cellule P389, je voudrais le total des textes divisé par 2
J'ai essayé de trouver une formule mais.....
=NB.SI(OU(J4:K34;"Brouillard";J4:K34;"Neige";J4:K34;"Pluie");"")/2)
Une idée ?
Cordialement
Guy



JB
Le #5028081
Bonsoir,


=(NB.SI(J4:K34;"Brouillard")+NB.SI(J4:K34;"Neige")
+NB.SI(J4:K34;"Pluie"))/2

JB


On 7 nov, 21:22, "Guy72"
Bonsoir
Dans le tableau J4:K34 j'ai des textes "Brouillard"_"Neige"_"Pluie".
Dans la cellule P389, je voudrais le total des textes divisé par 2
J'ai essayé de trouver une formule mais.....
=NB.SI(OU(J4:K34;"Brouillard";J4:K34;"Neige";J4:K34;"Pluie");"")/2)
Une idée ?
Cordialement
Guy


Modeste
Le #5028071
Bonsour® Guy72 avec ferveur ;o))) vous nous disiez :

Dans le tableau J4:K34 j'ai des textes "Brouillard"_"Neige"_"Pluie".
Dans la cellule P389, je voudrais le total des textes divisé par 2
J'ai essayé de trouver une formule mais.....
=NB.SI(OU(J4:K34;"Brouillard";J4:K34;"Neige";J4:K34;"Pluie");"")/2)
Une idée ?


Compter le nombre de cellule non-vide (contenant des données)NBVAL(plage),
soustraire le nombre de cellules contenant des chiffres NB(plage) et diviser par
2
=(NBVAL(J4:K34)-NB(J4:K34))/2

pour aller plus précisément vers une solution il faudrait quelques précisions
complémentaires
Chaque cellule contenant un texte, contient-t-elle un mot et un seul ?
contient-elle plusieurs mots , quel est alors le séparateur ?
la liste des mots possibles est-elle prédéfinie ??







--
--
@+
;o)))

JB
Le #5028061
=SOMMEPROD(NB.SI(J4:K34;{"Brouillard";"neige";"pluie"}))/2
valider avec Maj+Ctrl+Entrée

JB
On 7 nov, 21:48, JB
Bonsoir,

=(NB.SI(J4:K34;"Brouillard")+NB.SI(J4:K34;"Neige")
+NB.SI(J4:K34;"Pluie"))/2

JB

On 7 nov, 21:22, "Guy72"


Bonsoir
Dans le tableau J4:K34 j'ai des textes "Brouillard"_"Neige"_"Pluie".
Dans la cellule P389, je voudrais le total des textes divisé par 2
J'ai essayé de trouver une formule mais.....
=NB.SI(OU(J4:K34;"Brouillard";J4:K34;"Neige";J4:K34;"Pluie");"")/2)
Une idée ?
Cordialement
Guy- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Philippe.R
Le #5028041
Bonsoir JB,

"valider avec Maj+Ctrl+Entrée"

Que nenni, SOMMEPROD() n'a pas besoin de validation matricielles et c'est un
de ses grands mérites quand vient l'arthrose !
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"JB" news:

=SOMMEPROD(NB.SI(J4:K34;{"Brouillard";"neige";"pluie"}))/2
valider avec Maj+Ctrl+Entrée

JB
On 7 nov, 21:48, JB
Bonsoir,

=(NB.SI(J4:K34;"Brouillard")+NB.SI(J4:K34;"Neige")
+NB.SI(J4:K34;"Pluie"))/2

JB

On 7 nov, 21:22, "Guy72"


Bonsoir
Dans le tableau J4:K34 j'ai des textes "Brouillard"_"Neige"_"Pluie".
Dans la cellule P389, je voudrais le total des textes divisé par 2
J'ai essayé de trouver une formule mais.....
=NB.SI(OU(J4:K34;"Brouillard";J4:K34;"Neige";J4:K34;"Pluie");"")/2)
Une idée ?
Cordialement
Guy- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Guy72
Le #5028021
Salut Modeste
Dans le tableau, il y a tous les mots ci-dessous, un seul mot par cellule.
Mais dans la cellule P389 j'ai besoin du total de...
"Brouillard"ou"Neige"ou"Pluie.
Puis dans la cellule U389 ce seras les mots....
"Gris"ou"Nuageux"
Puis dans la cellule Y389 ce seras les mots....
"Averses"ou "Eclaircies"
Guy

"Modeste"
Bonsour® Guy72 avec ferveur ;o))) vous nous disiez :

Dans le tableau J4:K34 j'ai des textes "Brouillard"_"Neige"_"Pluie".
Dans la cellule P389, je voudrais le total des textes divisé par 2
J'ai essayé de trouver une formule mais.....
=NB.SI(OU(J4:K34;"Brouillard";J4:K34;"Neige";J4:K34;"Pluie");"")/2)
Une idée ?


Compter le nombre de cellule non-vide (contenant des données)NBVAL(plage),
soustraire le nombre de cellules contenant des chiffres NB(plage) et
diviser par 2
=(NBVAL(J4:K34)-NB(J4:K34))/2

pour aller plus précisément vers une solution il faudrait quelques
précisions complémentaires
Chaque cellule contenant un texte, contient-t-elle un mot et un seul ?
contient-elle plusieurs mots , quel est alors le séparateur ?
la liste des mots possibles est-elle prédéfinie ??







--
--
@+
;o)))





Modeste
Le #5027981
Bonsour® Chirogourdiste avec ferveur ;o))) vous nous disiez :

Que nenni, SOMMEPROD() n'a pas besoin de validation matricielles et
c'est un de ses grands mérites quand vient l'arthrose !
;o)))


http://cjoint.com/?lhxumh3daH

@+
;o)))

Tatanka
Le #5027921
Salut Guy,

Comme Modeste doit faire dodo, je me permets de répondre.

Total ou Total / 2 ?

Je reprends la formule de JB pour le Total :
=SOMMEPROD(NB.SI($J$4:$K$34;{"Brouillard";"Neige";"Pluie"}))
=SOMMEPROD(NB.SI($J$4:$K$34;{"Gris";"Nuageux"}))
=SOMMEPROD(NB.SI($J$4:$K$34;{"Averses";"Eclaircies"}))
(valider par Entrée)

Serge


"Guy72"
Salut Modeste
Dans le tableau, il y a tous les mots ci-dessous, un seul mot par cellule.
Mais dans la cellule P389 j'ai besoin du total de...
"Brouillard"ou"Neige"ou"Pluie.
Puis dans la cellule U389 ce seras les mots....
"Gris"ou"Nuageux"
Puis dans la cellule Y389 ce seras les mots....
"Averses"ou "Eclaircies"
Guy

"Modeste"
Bonsour® Guy72 avec ferveur ;o))) vous nous disiez :

Dans le tableau J4:K34 j'ai des textes "Brouillard"_"Neige"_"Pluie".
Dans la cellule P389, je voudrais le total des textes divisé par 2
J'ai essayé de trouver une formule mais.....
=NB.SI(OU(J4:K34;"Brouillard";J4:K34;"Neige";J4:K34;"Pluie");"")/2)
Une idée ?


Compter le nombre de cellule non-vide (contenant des données)NBVAL(plage), soustraire le nombre de cellules contenant des
chiffres NB(plage) et diviser par 2
=(NBVAL(J4:K34)-NB(J4:K34))/2

pour aller plus précisément vers une solution il faudrait quelques précisions complémentaires
Chaque cellule contenant un texte, contient-t-elle un mot et un seul ?
contient-elle plusieurs mots , quel est alors le séparateur ?
la liste des mots possibles est-elle prédéfinie ??







--
--
@+
;o)))









Szut
Le #5027911
Allo,

Ici tu peux remplacer SOMMEPROD par SOMME, et tjrs sans validation matricielle.

Szut

Salut Guy,

Comme Modeste doit faire dodo, je me permets de répondre.

Total ou Total / 2 ?

Je reprends la formule de JB pour le Total :
=SOMMEPROD(NB.SI($J$4:$K$34;{"Brouillard";"Neige";"Pluie"}))
=SOMMEPROD(NB.SI($J$4:$K$34;{"Gris";"Nuageux"}))
=SOMMEPROD(NB.SI($J$4:$K$34;{"Averses";"Eclaircies"}))
(valider par Entrée)

Serge


"Guy72"
Salut Modeste
Dans le tableau, il y a tous les mots ci-dessous, un seul mot par cellule.
Mais dans la cellule P389 j'ai besoin du total de...
"Brouillard"ou"Neige"ou"Pluie.
Puis dans la cellule U389 ce seras les mots....
"Gris"ou"Nuageux"
Puis dans la cellule Y389 ce seras les mots....
"Averses"ou "Eclaircies"
Guy

"Modeste"
Bonsour® Guy72 avec ferveur ;o))) vous nous disiez :

Dans le tableau J4:K34 j'ai des textes "Brouillard"_"Neige"_"Pluie".
Dans la cellule P389, je voudrais le total des textes divisé par 2
J'ai essayé de trouver une formule mais.....
=NB.SI(OU(J4:K34;"Brouillard";J4:K34;"Neige";J4:K34;"Pluie");"")/2)
Une idée ?
Compter le nombre de cellule non-vide (contenant des données)NBVAL(plage), soustraire le nombre de cellules contenant des

chiffres NB(plage) et diviser par 2
=(NBVAL(J4:K34)-NB(J4:K34))/2

pour aller plus précisément vers une solution il faudrait quelques précisions complémentaires
Chaque cellule contenant un texte, contient-t-elle un mot et un seul ?
contient-elle plusieurs mots , quel est alors le séparateur ?
la liste des mots possibles est-elle prédéfinie ??







--
--
@+
;o)))












Guy72
Le #5027831
Bonjour à tous
Je vous remercie de toute cette collaboration, je n'ai que l'embarras du
choix car tout fonctionne.
Merci encore
Cordialement
Guy

"Guy72"
Bonsoir
Dans le tableau J4:K34 j'ai des textes "Brouillard"_"Neige"_"Pluie".
Dans la cellule P389, je voudrais le total des textes divisé par 2
J'ai essayé de trouver une formule mais.....
=NB.SI(OU(J4:K34;"Brouillard";J4:K34;"Neige";J4:K34;"Pluie");"")/2)
Une idée ?
Cordialement
Guy



Publicité
Poster une réponse
Anonyme