Somme par mois

Le
jthillard
Bonjour,

En colonne B j'ai des dates au format xx/xx/xxxx
En colonne A j'ai A1=B1; A2=B2, etc au format personnalisé mmmm
En colonne C j'ai des nombres 2 chiffres après la virgule.

Je souhaite faire un bilan par mois. J'ai donc créé un tableau où j'a=
i
les mois de janvier à décembre en ordonnée et j'ai utilisé la fonct=
ion
somme.si pour faire la somme par mois.
Somme.si n'a pas l'air de reconnaître la première plage (celle de la
colonne A au format mmmm).
Pourquoi???
Quelqu'un pourrait me dire!

Merci d'avance pour les conseils

JPierre
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Caetera
Le #18954341
Je souhaite faire un bilan par mois.

Il faut faire un tableau croisé avec groupement, par mois, du champ date

Etc
Jacky
Le #18954481
Bonjour,

Par exemple :
=SOMMEPROD((MOIS($A$2:$A$13)=MOIS($E2))*1;$C$2:$C$13)
Voir ici
http://www.cijoint.fr/cjlink.php?file=cj200903/cijUfoZBvb.xls
--
Salutations
JJ



Bonjour,

En colonne B j'ai des dates au format xx/xx/xxxx
En colonne A j'ai A1±; A2², ... etc au format personnalisé mmmm
En colonne C j'ai des nombres 2 chiffres après la virgule.

Je souhaite faire un bilan par mois. J'ai donc créé un tableau où j'ai
les mois de janvier à décembre en ordonnée et j'ai utilisé la fonction
somme.si pour faire la somme par mois.
Somme.si n'a pas l'air de reconnaître la première plage (celle de la
colonne A au format mmmm).
Pourquoi???
Quelqu'un pourrait me dire!

Merci d'avance pour les conseils

JPierre
Daniel.C
Le #18954591
Bonjour.
Le format mmmm ne sert que pour l'affichage, quel que soit le format,
la valeur de la cellule est un nombre, genre : 32856. Tu peux utiliser
les formules suivantes (pour janvier, à modifier pour les autres mois)
:

=SOMMEPROD((TEXTE(A1:A1000;"mmmm")="janvier")*C1:C1000)
=SOMMEPROD((MOIS(B1:B1000)=1)*C1:C1000)
=SOMMEPROD((MOIS(A1:A1000)=1)*C1:C1000)

Cordialement.
Daniel
Bonjour,

En colonne B j'ai des dates au format xx/xx/xxxx
En colonne A j'ai A1±; A2², ... etc au format personnalisé mmmm
En colonne C j'ai des nombres 2 chiffres après la virgule.

Je souhaite faire un bilan par mois. J'ai donc créé un tableau où j'ai
les mois de janvier à décembre en ordonnée et j'ai utilisé la fonction
somme.si pour faire la somme par mois.
Somme.si n'a pas l'air de reconnaître la première plage (celle de la
colonne A au format mmmm).
Pourquoi???
Quelqu'un pourrait me dire!

Merci d'avance pour les conseils

JPierre


jthillard
Le #18954751
Merci à Jacky et Daniel.
Je me doutais que la solution serait avec sommeprod.
Bonne fin de week-end.

JPierre

On 22 mar, 12:04, Daniel.C
Bonjour.
Le format mmmm ne sert que pour l'affichage, quel que soit le format,
la valeur de la cellule est un nombre, genre : 32856. Tu peux utiliser
les formules suivantes (pour janvier, à modifier pour les autres mois)
:

=SOMMEPROD((TEXTE(A1:A1000;"mmmm")="janvier")*C1:C1000)
=SOMMEPROD((MOIS(B1:B1000)=1)*C1:C1000)
=SOMMEPROD((MOIS(A1:A1000)=1)*C1:C1000)

Cordialement.
Daniel



> Bonjour,

> En colonne B j'ai des dates au format xx/xx/xxxx
> En colonne A j'ai A1±; A2², ... etc au format personnalisé mm mm
> En colonne C j'ai des nombres 2 chiffres après la virgule.

> Je souhaite faire un bilan par mois. J'ai donc créé un tableau où j'ai
> les mois de janvier à décembre en ordonnée et j'ai utilisé la f onction
> somme.si pour faire la somme par mois.
> Somme.si n'a pas l'air de reconnaître la première plage (celle de l a
> colonne A au format mmmm).
> Pourquoi???
> Quelqu'un pourrait me dire!

> Merci d'avance pour les conseils

> JPierre- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Caetera
Le #18955571
>Je me doutais que la solution serait avec sommeprod.



Tu connais les Tableaux Croisés Dyn. ?
Non ?
Tout s'explique ...

Etc
Publicité
Poster une réponse
Anonyme