somme.(pas)si facile...

Le
JMM21
Bonjour,

Je souhaite sommer les valeurs des cellules d'une colonne, à condition que
le mois des cellules correspondant soit égal à ce que je souhaite.
Un petit extrait du classeur pour une meilleur compréhension :
la somme des valeurs de la colonne "montant" si le mois de la colonne "date"
= 2, par exemple
http://cjoint.com/?bhqlmBv1Se

J'ai trituré sans réussite la fonction [=somme.si],mais ce n'est peut-être
pas la bonne piste ???
C'est vrai qu'un petit formulaire avec le choix du mois dans une ListBox et
puis le résultat dans une zone serait l'idéal, mais je n'en suis pas là

Merci d'un coup de pouce
--
[Jmm21]
☺♂
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
abigael
Le #18324861
bonjour,

pourquoi ne pas rajouter une colonne mois déduite de la date de la colonne 1
et faire un tableau croisé dynamique
tu aurais ainsi les totaux pour chacun des mois.

Mais c'est peut-être une solution un peu compliquée.
Quelqu'un te donneras sans soute une piste plus simple

Abigael

"JMM21" a écrit :

Bonjour,

Je souhaite sommer les valeurs des cellules d'une colonne, à condition que
le mois des cellules correspondant soit égal à ce que je souhaite.
Un petit extrait du classeur pour une meilleur compréhension :
la somme des valeurs de la colonne "montant" si le mois de la colonne "date"
= 2, par exemple...
http://cjoint.com/?bhqlmBv1Se

J'ai trituré sans réussite la fonction [=somme.si],mais ce n'est peut-être
pas la bonne piste ???
C'est vrai qu'un petit formulaire avec le choix du mois dans une ListBox et
puis le résultat dans une zone serait l'idéal, mais je n'en suis pas là...

Merci d'un coup de pouce
--
[Jmm21]
☺♂


michdenis
Le #18324981
Cette formule
=SOMMEPROD((MOIS(A2:A20)=2)*B2:B20)

OU celle-ci

Validation matricielle : Ctrl + Maj + Enter
=SOMME(SI(MOIS(A2:A20)=2;B2:B20))


"JMM21"
Bonjour,

Je souhaite sommer les valeurs des cellules d'une colonne, à condition que
le mois des cellules correspondant soit égal à ce que je souhaite.
Un petit extrait du classeur pour une meilleur compréhension :
la somme des valeurs de la colonne "montant" si le mois de la colonne "date"
= 2, par exemple...
http://cjoint.com/?bhqlmBv1Se

J'ai trituré sans réussite la fonction [=somme.si],mais ce n'est peut-être
pas la bonne piste ???
C'est vrai qu'un petit formulaire avec le choix du mois dans une ListBox et
puis le résultat dans une zone serait l'idéal, mais je n'en suis pas là...

Merci d'un coup de pouce
--
[Jmm21]
☺♂
JMM21
Le #18325081
Merci à abigael et surtout à michdenis.

Cela parait si simple, quant on maîtrise !!!
(les deux solutions donnent le même résultat, c'est rassurant...)

Cordialement


--
[Jmm21]
☺♂


"michdenis" a écrit :

Cette formule
=SOMMEPROD((MOIS(A2:A20)=2)*B2:B20)

OU celle-ci

Validation matricielle : Ctrl + Maj + Enter
=SOMME(SI(MOIS(A2:A20)=2;B2:B20))


"JMM21"
Bonjour,

Je souhaite sommer les valeurs des cellules d'une colonne, à condition que
le mois des cellules correspondant soit égal à ce que je souhaite.
Un petit extrait du classeur pour une meilleur compréhension :
la somme des valeurs de la colonne "montant" si le mois de la colonne "date"
= 2, par exemple...
http://cjoint.com/?bhqlmBv1Se

J'ai trituré sans réussite la fonction [=somme.si],mais ce n'est peut-être
pas la bonne piste ???
C'est vrai qu'un petit formulaire avec le choix du mois dans une ListBox et
puis le résultat dans une zone serait l'idéal, mais je n'en suis pas là...

Merci d'un coup de pouce
--
[Jmm21]
☺♂




JMM21
Le #18325491
Un petit souci cependant, cela ne fonctionne pas avec Janvier ???
La fonction [=mois] renvoie systématiquement 1 quelle que soit la valeur de
la cellulle !!!

il y a sûrement une explication ....

--
[Jmm21]
☺♂


"JMM21" a écrit :

Merci à abigael et surtout à michdenis.

Cela parait si simple, quant on maîtrise !!!
(les deux solutions donnent le même résultat, c'est rassurant...)

Cordialement


--
[Jmm21]
☺♂


"michdenis" a écrit :

> Cette formule
> =SOMMEPROD((MOIS(A2:A20)=2)*B2:B20)
>
> OU celle-ci
>
> Validation matricielle : Ctrl + Maj + Enter
> =SOMME(SI(MOIS(A2:A20)=2;B2:B20))
>
>
> "JMM21" >
> Bonjour,
>
> Je souhaite sommer les valeurs des cellules d'une colonne, à condition que
> le mois des cellules correspondant soit égal à ce que je souhaite.
> Un petit extrait du classeur pour une meilleur compréhension :
> la somme des valeurs de la colonne "montant" si le mois de la colonne "date"
> = 2, par exemple...
> http://cjoint.com/?bhqlmBv1Se
>
> J'ai trituré sans réussite la fonction [=somme.si],mais ce n'est peut-être
> pas la bonne piste ???
> C'est vrai qu'un petit formulaire avec le choix du mois dans une ListBox et
> puis le résultat dans une zone serait l'idéal, mais je n'en suis pas là...
>
> Merci d'un coup de pouce
> --
> [Jmm21]
> ☺♂
>
>


michdenis
Le #18325681
Une cellule vide soit A1
si tu écris en B1 = Mois(A1) tu obtiendras 1

Pourquoi ? parce que les dates débutent le
1 janvier 1900. et la date A1 dont le contenu
est 0 correspond à la date 1 janvier 1900 d'où
le résultat 1

et tu modifies la formule de cette façon :

=SOMMEPROD((MOIS(A2:A20)=1)*(A2:A20>0)*B2:B20)

OU
Validation matricielle
=SOMME(SI((MOIS(A2:A20)=1)*(A2:A20>0)=1;B2:B20))




"JMM21"
Un petit souci cependant, cela ne fonctionne pas avec Janvier ???
La fonction [=mois] renvoie systématiquement 1 quelle que soit la valeur de
la cellulle !!!

il y a sûrement une explication ....

--
[Jmm21]
☺♂


"JMM21" a écrit :

Merci à abigael et surtout à michdenis.

Cela parait si simple, quant on maîtrise !!!
(les deux solutions donnent le même résultat, c'est rassurant...)

Cordialement


--
[Jmm21]
☺♂


"michdenis" a écrit :

> Cette formule
> =SOMMEPROD((MOIS(A2:A20)=2)*B2:B20)
>
> OU celle-ci
>
> Validation matricielle : Ctrl + Maj + Enter
> =SOMME(SI(MOIS(A2:A20)=2;B2:B20))
>
>
> "JMM21" > news:
>
> Bonjour,
>
> Je souhaite sommer les valeurs des cellules d'une colonne, à condition
> que
> le mois des cellules correspondant soit égal à ce que je souhaite.
> Un petit extrait du classeur pour une meilleur compréhension :
> la somme des valeurs de la colonne "montant" si le mois de la colonne
> "date"
> = 2, par exemple...
> http://cjoint.com/?bhqlmBv1Se
>
> J'ai trituré sans réussite la fonction [=somme.si],mais ce n'est
> peut-être
> pas la bonne piste ???
> C'est vrai qu'un petit formulaire avec le choix du mois dans une ListBox
> et
> puis le résultat dans une zone serait l'idéal, mais je n'en suis pas
> là...
>
> Merci d'un coup de pouce
> --
> [Jmm21]
> ☺♂
>
>


Albert
Le #18326331
Bonjour
"michdenis" news:
Une cellule vide soit A1
si tu écris en B1 = Mois(A1) tu obtiendras 1

Pourquoi ? parce que les dates débutent le
1 janvier 1900. et la date A1 dont le contenu
est 0 correspond à la date 1 janvier 1900 d'où
le résultat 1



Chez moi le contenu
zero donne 1900-01-00
100-01-01
200-01-02
300-01-03
400-01-04
500-01-05

en date format 1904 zero 04-01-01

suis-je correct ?


--
albertri-at-videotron.ca.invalid
JMM21
Le #18326291
Encore merci à toi pour ces précisions
Bonne soirée



"michdenis" a écrit :

Une cellule vide soit A1
si tu écris en B1 = Mois(A1) tu obtiendras 1

Pourquoi ? parce que les dates débutent le
1 janvier 1900. et la date A1 dont le contenu
est 0 correspond à la date 1 janvier 1900 d'où
le résultat 1

et tu modifies la formule de cette façon :

=SOMMEPROD((MOIS(A2:A20)=1)*(A2:A20>0)*B2:B20)

OU
Validation matricielle
=SOMME(SI((MOIS(A2:A20)=1)*(A2:A20>0)=1;B2:B20))




michdenis
Le #18326281
OUI


"Albert" %
Bonjour
"michdenis" news:
Une cellule vide soit A1
si tu écris en B1 = Mois(A1) tu obtiendras 1

Pourquoi ? parce que les dates débutent le
1 janvier 1900. et la date A1 dont le contenu
est 0 correspond à la date 1 janvier 1900 d'où
le résultat 1



Chez moi le contenu
zero donne 1900-01-00
100-01-01
200-01-02
300-01-03
400-01-04
500-01-05

en date format 1904 zero 04-01-01

suis-je correct ?


--
albertri-at-videotron.ca.invalid
Publicité
Poster une réponse
Anonyme