somme prod critère variable et incomplet

Le
sophhia
Bonjour à tous,

Voilà, je voudrais faire la somme des valeurs de la colonne B, si la colonne
A contient un critère variable.

J'ai bien la fonction
=sommeprod((zone de rechercheA;indirect(critère))*(zone de rechercheB))

La formule marche super si je veux =critère ou >critère mais mon problème,
et je ne trouve la solution sur aucun forum, c'est d'avoir un critère qui
soit partiel, c'est-à-dire "contenu" dans la cellule mais pas forcément égal
à la valeur de la cellule. Concrètement je veux prendre en compte toutes les
lignes qui contiennent, mon critère que j'indique ailleurs, par exemple ZB,
je veux les lignes "ZB polo", "ZB henry", etc.

Meme en rentrant la valeur dans le dur, j'ai un message d'erreur
=sommeprod((zone de rechercheA;"*ZB*")*(zone de rechercheB))

Quelqu'un a-t-il la solution???

D'avance, merci de votre aide.

Cdlt
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #4964161
bonjour Sophia,

=SOMME.SI(A2:A10;"ZB*";B2:B10)

isabelle


Bonjour à tous,

Voilà, je voudrais faire la somme des valeurs de la colonne B, si la colonne
A contient un critère variable.

J'ai bien la fonction
=sommeprod((zone de rechercheA;indirect(critère))*(zone de rechercheB))

La formule marche super si je veux =critère ou >critère mais mon problème,
et je ne trouve la solution sur aucun forum, c'est d'avoir un critère qui
soit partiel, c'est-à-dire "contenu" dans la cellule mais pas forcément égal
à la valeur de la cellule. Concrètement je veux prendre en compte toutes les
lignes qui contiennent, mon critère que j'indique ailleurs, par exemple ZB,
je veux les lignes "ZB polo", "ZB henry", etc.

Meme en rentrant la valeur dans le dur, j'ai un message d'erreur
=sommeprod((zone de rechercheA;"*ZB*")*(zone de rechercheB))

Quelqu'un a-t-il la solution???

D'avance, merci de votre aide.

Cdlt




MichDenis
Le #4964141
Tu adaptes la plage de cellules et on en parle plus ;-)

Peu importe où est située la chaîne "zb" dans la plage de cellules ...

E2 -> cellule où la chaine recherchée est placée
B3:B4 plage sur laquelle est appliquée le critère
C3:C4 Plage à addtionner
=SOMMEPROD((ESTNUM(CHERCHE(E2;B3:B4))*(C3:C4)))




"sophhia"
Bonjour à tous,

Voilà, je voudrais faire la somme des valeurs de la colonne B, si la colonne
A contient un critère variable.

J'ai bien la fonction
=sommeprod((zone de rechercheA;indirect(critère))*(zone de rechercheB))

La formule marche super si je veux =critère ou >critère mais mon problème,
et je ne trouve la solution sur aucun forum, c'est d'avoir un critère qui
soit partiel, c'est-à-dire "contenu" dans la cellule mais pas forcément égal
à la valeur de la cellule. Concrètement je veux prendre en compte toutes les
lignes qui contiennent, mon critère que j'indique ailleurs, par exemple ZB,
je veux les lignes "ZB polo", "ZB henry", etc.

Meme en rentrant la valeur dans le dur, j'ai un message d'erreur
=sommeprod((zone de rechercheA;"*ZB*")*(zone de rechercheB))

Quelqu'un a-t-il la solution???

D'avance, merci de votre aide.

Cdlt
garnote
Le #4964131
Bonjour Sophia,

Peut-être que :
Je suppose tes données en A1:B10
Entre ZB* en C1 et la formule suivante
=SOMME.SI(A1:A10;C1;B1:B10)
dans une autre cellule.
La formule ne fait pas de différence entre majuscule et minuscule
(Zb, ZB, ...)

Serge



"sophhia"
Bonjour à tous,

Voilà, je voudrais faire la somme des valeurs de la colonne B, si la colonne A contient un critère variable.

J'ai bien la fonction
=sommeprod((zone de rechercheA;indirect(critère))*(zone de rechercheB))

La formule marche super si je veux =critère ou >critère mais mon problème, et je ne trouve la solution sur aucun forum, c'est
d'avoir un critère qui soit partiel, c'est-à-dire "contenu" dans la cellule mais pas forcément égal à la valeur de la cellule.
Concrètement je veux prendre en compte toutes les lignes qui contiennent, mon critère que j'indique ailleurs, par exemple ZB, je
veux les lignes "ZB polo", "ZB henry", etc.

Meme en rentrant la valeur dans le dur, j'ai un message d'erreur
=sommeprod((zone de rechercheA;"*ZB*")*(zone de rechercheB))

Quelqu'un a-t-il la solution???

D'avance, merci de votre aide.

Cdlt



garnote
Le #4964121
Et si tu veux tenir compte des cellules contenant la chaîne ZB,
tu entres *ZB* en C1 et la formule
=SOMME.SI(A1:A10;C1;B1:B10)
dans une autre cellule.

Serge

"sophhia"
Bonjour à tous,

Voilà, je voudrais faire la somme des valeurs de la colonne B, si la colonne A contient un critère variable.

J'ai bien la fonction
=sommeprod((zone de rechercheA;indirect(critère))*(zone de rechercheB))

La formule marche super si je veux =critère ou >critère mais mon problème, et je ne trouve la solution sur aucun forum, c'est
d'avoir un critère qui soit partiel, c'est-à-dire "contenu" dans la cellule mais pas forcément égal à la valeur de la cellule.
Concrètement je veux prendre en compte toutes les lignes qui contiennent, mon critère que j'indique ailleurs, par exemple ZB, je
veux les lignes "ZB polo", "ZB henry", etc.

Meme en rentrant la valeur dans le dur, j'ai un message d'erreur
=sommeprod((zone de rechercheA;"*ZB*")*(zone de rechercheB))

Quelqu'un a-t-il la solution???

D'avance, merci de votre aide.

Cdlt



sophhia
Le #4964101
Merci pour la rapidité de vos réponses !
C'est parfait, la fonction somme.si me remonte exactement les bonnes
données.
En revanche, juste pour info, la fonction sommeprod avec estnum me met une
erreur de valeur...

Cdlt


"garnote"
Et si tu veux tenir compte des cellules contenant la chaîne ZB,
tu entres *ZB* en C1 et la formule
=SOMME.SI(A1:A10;C1;B1:B10)
dans une autre cellule.

Serge

"sophhia"
Bonjour à tous,

Voilà, je voudrais faire la somme des valeurs de la colonne B, si la
colonne A contient un critère variable.

J'ai bien la fonction
=sommeprod((zone de rechercheA;indirect(critère))*(zone de rechercheB))

La formule marche super si je veux =critère ou >critère mais mon
problème, et je ne trouve la solution sur aucun forum, c'est d'avoir un
critère qui soit partiel, c'est-à-dire "contenu" dans la cellule mais pas
forcément égal à la valeur de la cellule. Concrètement je veux prendre en
compte toutes les lignes qui contiennent, mon critère que j'indique
ailleurs, par exemple ZB, je veux les lignes "ZB polo", "ZB henry", etc.

Meme en rentrant la valeur dans le dur, j'ai un message d'erreur
=sommeprod((zone de rechercheA;"*ZB*")*(zone de rechercheB))

Quelqu'un a-t-il la solution???

D'avance, merci de votre aide.

Cdlt







MichDenis
Le #4964081
| E2 -> cellule où la chaine recherchée est placée
| B3:B4 plage sur laquelle est appliquée le critère
| C3:C4 Plage à addtionner
| =SOMMEPROD((ESTNUM(CHERCHE(E2;B3:B4))*(C3:C4)))


Est-ce qu'il y a des cellules dans ta colonne qui ne seraient
pas des nombres ?

Dans un tel cas, tu peux utiliser ceci :
=SOMMEPROD((ESTNUM(CHERCHE(E2;B3:B4)))*1;(C3:C4))
garnote
Le #4964021
Si dans la dernière formule de Denis, tu remplaces CHERCHE
par TROUVE, la formule fera la différence entre les lettres minuscules
et majuscules. Si Zb, recherche exclusivement Zb; si ZB, recherche
exclusivement ZB ...

Serge


"sophhia"
Merci pour la rapidité de vos réponses !
C'est parfait, la fonction somme.si me remonte exactement les bonnes données.
En revanche, juste pour info, la fonction sommeprod avec estnum me met une erreur de valeur...

Cdlt


"garnote"
Et si tu veux tenir compte des cellules contenant la chaîne ZB,
tu entres *ZB* en C1 et la formule
=SOMME.SI(A1:A10;C1;B1:B10)
dans une autre cellule.

Serge

"sophhia"
Bonjour à tous,

Voilà, je voudrais faire la somme des valeurs de la colonne B, si la colonne A contient un critère variable.

J'ai bien la fonction
=sommeprod((zone de rechercheA;indirect(critère))*(zone de rechercheB))

La formule marche super si je veux =critère ou >critère mais mon problème, et je ne trouve la solution sur aucun forum, c'est
d'avoir un critère qui soit partiel, c'est-à-dire "contenu" dans la cellule mais pas forcément égal à la valeur de la cellule.
Concrètement je veux prendre en compte toutes les lignes qui contiennent, mon critère que j'indique ailleurs, par exemple ZB, je
veux les lignes "ZB polo", "ZB henry", etc.

Meme en rentrant la valeur dans le dur, j'ai un message d'erreur
=sommeprod((zone de rechercheA;"*ZB*")*(zone de rechercheB))

Quelqu'un a-t-il la solution???

D'avance, merci de votre aide.

Cdlt











Publicité
Poster une réponse
Anonyme