somme prod

Le
celine
bonjour a tous

j'ai un problème concernant la formule somme prod


j'ai la formule suivante:

=sommeprod( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (Zone à
additionner )

Mes zones vient toutes de 2 à 300

Seulement certaines lignes (les dernières ne sont pas remplit)

J'ai le résultat suivant #VALEUR

Pourriez vous m'aider

merci d'avance

bonne journée

céline
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #16638091
Bonjour
Essaie la formule matricielle valider avec (CTRL+MAJ+Entrée) :
=somme( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (SI(ESTNUM(Zone à
additionner);Zone à additionner;0) )
Cordialement.
Daniel
"celine"
bonjour a tous

j'ai un problème concernant la formule somme prod


j'ai la formule suivante:

=sommeprod( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (Zone à
additionner )

Mes zones vient toutes de 2 à 300

Seulement certaines lignes (les dernières ne sont pas remplit)

J'ai le résultat suivant #VALEUR

Pourriez vous m'aider

merci d'avance

bonne journée

céline


Jacky
Le #16638831
Bonjour,

=SOMMEPROD((zone1=critère1 )*(zone2=critère2)*zone3)





Sauf à enlever un "(" de trop, Il n'y a pas de raison apparente que cette
formule ne fonctionne pas
Voir ici:
http://cjoint.com/?iBmSidIkkZ

--
Salutations
JJ


"celine"
bonjour a tous

j'ai un problème concernant la formule somme prod


j'ai la formule suivante:

=sommeprod( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (Zone à
additionner )

Mes zones vient toutes de 2 à 300

Seulement certaines lignes (les dernières ne sont pas remplit)

J'ai le résultat suivant #VALEUR

Pourriez vous m'aider

merci d'avance

bonne journée

céline


Daniel.C
Le #16638821
Salut Jacky,
Tu obtiens ce résultat si tu as une valeur non numérique dans zone3.
Daniel
"Jacky"
Bonjour,

=SOMMEPROD((zone1=critère1 )*(zone2=critère2)*zone3)





Sauf à enlever un "(" de trop, Il n'y a pas de raison apparente que cette
formule ne fonctionne pas
Voir ici:
http://cjoint.com/?iBmSidIkkZ

--
Salutations
JJ


"celine" news:

bonjour a tous

j'ai un problème concernant la formule somme prod


j'ai la formule suivante:

=sommeprod( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (Zone à
additionner )

Mes zones vient toutes de 2 à 300

Seulement certaines lignes (les dernières ne sont pas remplit)

J'ai le résultat suivant #VALEUR

Pourriez vous m'aider

merci d'avance

bonne journée

céline








Jacky
Le #16640641
Salut Daniel

Exact, je n'ai pas pensé que cette erreur pouvait arrivé jusque là.
Un contrôle de la saisie s'impose.....Une saisie Alpha dans une colonne de
chiffres ne devrait pas être possible.
Ou lâchement:
=SI(ESTERREUR(SOMMEPROD((zone1=$E$2 )*(zone2=$F$2)*zone3));"Erreur dans les
saisies";SOMMEPROD((zone1=$E$2 )*(zone2=$F$2)*zone3))

--
Salutations
JJ


"Daniel.C"
Salut Jacky,
Tu obtiens ce résultat si tu as une valeur non numérique dans zone3.
Daniel
"Jacky"
Bonjour,

=SOMMEPROD((zone1=critère1 )*(zone2=critère2)*zone3)





Sauf à enlever un "(" de trop, Il n'y a pas de raison apparente que cette
formule ne fonctionne pas
Voir ici:
http://cjoint.com/?iBmSidIkkZ

--
Salutations
JJ


"celine" news:

bonjour a tous

j'ai un problème concernant la formule somme prod


j'ai la formule suivante:

=sommeprod( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (Zone à
additionner )

Mes zones vient toutes de 2 à 300

Seulement certaines lignes (les dernières ne sont pas remplit)

J'ai le résultat suivant #VALEUR

Pourriez vous m'aider

merci d'avance

bonne journée

céline












Jacky
Le #16640621
Re...
Je n'ai pas vu que tu avais donné la solution
Désolé.
=SOMME((zone1=$E$2)*(zone2=$F$2)*(SI(ESTNUM(zone3);zone3;0)))
Matricielle, fonctionne parfaitement.
Mes excuses, je creuse.... je vais m'enfouir la tête comme les autruches.


--
Salutations
JJ


"Daniel.C"
Salut Jacky,
Tu obtiens ce résultat si tu as une valeur non numérique dans zone3.
Daniel
"Jacky"
Bonjour,

=SOMMEPROD((zone1=critère1 )*(zone2=critère2)*zone3)





Sauf à enlever un "(" de trop, Il n'y a pas de raison apparente que cette
formule ne fonctionne pas
Voir ici:
http://cjoint.com/?iBmSidIkkZ

--
Salutations
JJ


"celine" news:

bonjour a tous

j'ai un problème concernant la formule somme prod


j'ai la formule suivante:

=sommeprod( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (Zone à
additionner )

Mes zones vient toutes de 2 à 300

Seulement certaines lignes (les dernières ne sont pas remplit)

J'ai le résultat suivant #VALEUR

Pourriez vous m'aider

merci d'avance

bonne journée

céline












celine
Le #16640401
Merci a tous les deux

cela fonctionne

merci beaucoup

céline

"Jacky" a écrit :

Re...
Je n'ai pas vu que tu avais donné la solution
Désolé.
=SOMME((zone1=$E$2)*(zone2=$F$2)*(SI(ESTNUM(zone3);zone3;0)))
Matricielle, fonctionne parfaitement.
Mes excuses, je creuse.... je vais m'enfouir la tête comme les autruches.


--
Salutations
JJ


"Daniel.C"
> Salut Jacky,
> Tu obtiens ce résultat si tu as une valeur non numérique dans zone3.
> Daniel
> "Jacky" >
>> Bonjour,
>>
>>>> =SOMMEPROD((zone1=critère1 )*(zone2=critère2)*zone3)
>>
>> Sauf à enlever un "(" de trop, Il n'y a pas de raison apparente que cette
>> formule ne fonctionne pas
>> Voir ici:
>> http://cjoint.com/?iBmSidIkkZ
>>
>> --
>> Salutations
>> JJ
>>
>>
>> "celine" >> news:
>>
>>> bonjour a tous
>>>
>>> j'ai un problème concernant la formule somme prod
>>>
>>>
>>> j'ai la formule suivante:
>>>
>>> =sommeprod( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (Zone à
>>> additionner )
>>>
>>> Mes zones vient toutes de 2 à 300
>>>
>>> Seulement certaines lignes (les dernières ne sont pas remplit)
>>>
>>> J'ai le résultat suivant #VALEUR
>>>
>>> Pourriez vous m'aider
>>>
>>> merci d'avance
>>>
>>> bonne journée
>>>
>>> céline
>>
>>
>>
>>
>
>






michdenis
Le #16640361
Il me semble que tu abandonnes un peu vite !

Un truc du genre est possible :

=SOMMEPROD((A1:A5=2)*(B1:B5="M");(C1:C5))

Permet d'addtionner la plage C1:C5 qui répond aux critères
même s'il y a des cellules en C1:C5 qui contient du texte ...

(je n'ai pas vraiment lu ce que le demandeur voulait)

;-))


"Jacky"
Salut Daniel

Exact, je n'ai pas pensé que cette erreur pouvait arrivé jusque là.
Un contrôle de la saisie s'impose.....Une saisie Alpha dans une colonne de
chiffres ne devrait pas être possible.
Ou lâchement:
=SI(ESTERREUR(SOMMEPROD((zone1=$E$2 )*(zone2=$F$2)*zone3));"Erreur dans les
saisies";SOMMEPROD((zone1=$E$2 )*(zone2=$F$2)*zone3))

--
Salutations
JJ


"Daniel.C"
Salut Jacky,
Tu obtiens ce résultat si tu as une valeur non numérique dans zone3.
Daniel
"Jacky"
Bonjour,

=SOMMEPROD((zone1=critère1 )*(zone2=critère2)*zone3)





Sauf à enlever un "(" de trop, Il n'y a pas de raison apparente que cette
formule ne fonctionne pas
Voir ici:
http://cjoint.com/?iBmSidIkkZ

--
Salutations
JJ


"celine" news:

bonjour a tous

j'ai un problème concernant la formule somme prod


j'ai la formule suivante:

=sommeprod( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (Zone à
additionner )

Mes zones vient toutes de 2 à 300

Seulement certaines lignes (les dernières ne sont pas remplit)

J'ai le résultat suivant #VALEUR

Pourriez vous m'aider

merci d'avance

bonne journée

céline












Jacky
Le #16640351
> Il me semble que tu abandonnes un peu vite !


Oui, sur ce coup là, c'est vrai.

Un truc du genre est possible :
=SOMMEPROD((A1:A5=2)*(B1:B5="M");(C1:C5))


J'y pense jamais, à cette deuxième matrice

(je n'ai pas vraiment lu ce que le demandeur voulait)


C'était exactement cela.
Merci d'être intervenu
--
Salutations
JJ


"michdenis" %
Il me semble que tu abandonnes un peu vite !

Un truc du genre est possible :

=SOMMEPROD((A1:A5=2)*(B1:B5="M");(C1:C5))

Permet d'addtionner la plage C1:C5 qui répond aux critères
même s'il y a des cellules en C1:C5 qui contient du texte ...

(je n'ai pas vraiment lu ce que le demandeur voulait)

;-))


"Jacky"
Salut Daniel

Exact, je n'ai pas pensé que cette erreur pouvait arrivé jusque là.
Un contrôle de la saisie s'impose.....Une saisie Alpha dans une colonne de
chiffres ne devrait pas être possible.
Ou lâchement:
=SI(ESTERREUR(SOMMEPROD((zone1=$E$2 )*(zone2=$F$2)*zone3));"Erreur dans
les
saisies";SOMMEPROD((zone1=$E$2 )*(zone2=$F$2)*zone3))

--
Salutations
JJ


"Daniel.C"
Salut Jacky,
Tu obtiens ce résultat si tu as une valeur non numérique dans zone3.
Daniel
"Jacky"
Bonjour,

=SOMMEPROD((zone1=critère1 )*(zone2=critère2)*zone3)





Sauf à enlever un "(" de trop, Il n'y a pas de raison apparente que
cette
formule ne fonctionne pas
Voir ici:
http://cjoint.com/?iBmSidIkkZ

--
Salutations
JJ


"celine" news:

bonjour a tous

j'ai un problème concernant la formule somme prod


j'ai la formule suivante:

=sommeprod( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (Zone à
additionner )

Mes zones vient toutes de 2 à 300

Seulement certaines lignes (les dernières ne sont pas remplit)

J'ai le résultat suivant #VALEUR

Pourriez vous m'aider

merci d'avance

bonne journée

céline
















Jacky
Le #16640341
Re...
D'ailleurs, je retourne dans le jardin terminer de creuser le trou.
;o))
--
Salutations
JJ


"Jacky"
Il me semble que tu abandonnes un peu vite !


Oui, sur ce coup là, c'est vrai.

Un truc du genre est possible :
=SOMMEPROD((A1:A5=2)*(B1:B5="M");(C1:C5))


J'y pense jamais, à cette deuxième matrice

(je n'ai pas vraiment lu ce que le demandeur voulait)


C'était exactement cela.
Merci d'être intervenu
--
Salutations
JJ


"michdenis" %
Il me semble que tu abandonnes un peu vite !

Un truc du genre est possible :

=SOMMEPROD((A1:A5=2)*(B1:B5="M");(C1:C5))

Permet d'addtionner la plage C1:C5 qui répond aux critères
même s'il y a des cellules en C1:C5 qui contient du texte ...

(je n'ai pas vraiment lu ce que le demandeur voulait)

;-))


"Jacky"
Salut Daniel

Exact, je n'ai pas pensé que cette erreur pouvait arrivé jusque là.
Un contrôle de la saisie s'impose.....Une saisie Alpha dans une colonne
de
chiffres ne devrait pas être possible.
Ou lâchement:
=SI(ESTERREUR(SOMMEPROD((zone1=$E$2 )*(zone2=$F$2)*zone3));"Erreur dans
les
saisies";SOMMEPROD((zone1=$E$2 )*(zone2=$F$2)*zone3))

--
Salutations
JJ


"Daniel.C"
Salut Jacky,
Tu obtiens ce résultat si tu as une valeur non numérique dans zone3.
Daniel
"Jacky"
Bonjour,

=SOMMEPROD((zone1=critère1 )*(zone2=critère2)*zone3)





Sauf à enlever un "(" de trop, Il n'y a pas de raison apparente que
cette
formule ne fonctionne pas
Voir ici:
http://cjoint.com/?iBmSidIkkZ

--
Salutations
JJ


"celine" news:

bonjour a tous

j'ai un problème concernant la formule somme prod


j'ai la formule suivante:

=sommeprod( ( Zone 1 = critère 1 ) * ( Zone 2 = critère 2 ) * (Zone à
additionner )

Mes zones vient toutes de 2 à 300

Seulement certaines lignes (les dernières ne sont pas remplit)

J'ai le résultat suivant #VALEUR

Pourriez vous m'aider

merci d'avance

bonne journée

céline




















Publicité
Poster une réponse
Anonyme