Somme.si avec plusieurs conditions

Le
nadd
Bonjour,

Je souhaite élaborer par une "SOMME.SI" une formule qui me communique la somme des cellules d'une colonne A en fonction des éléments d'une colonne B. Jusque là il s'agit d'une fonction Somme.si banale
Il s'avère que je souhaite par cette formule procéder au découpage par tranches de la colonne B :

En clair, je souhaite une formule telle que ci-dessous qui pour je ne sais quelle raison refuse de fonctionner ! ! !

=SOMME.SI($B$2:$B$98;et(">10";"< ");$A$2:$A$98)

=SOMME.SI($B$2:$B$98;et(">20";"<0");$A$2:$A$98)



Merci d'avance pour votre précieuse aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sam
Le #22134961
Bonjour,
utilise sommeprod
=SOMMEPROD(($B$2:$B$98>10)*($B$2:$B$98<30)*$A$2:$A$98)
Cordialement
Michel dit "Sam"

"nadd"
Bonjour,

Je souhaite élaborer par une "SOMME.SI" une formule qui me communique la
somme
des cellules d'une colonne A en fonction des éléments d'une colonne B.
Jusque là
il s'agit d'une fonction Somme.si banale...
Il s'avère que je souhaite par cette formule procéder au découpage par
tranches
de la colonne B :

En clair, je souhaite une formule telle que ci-dessous qui pour je ne sais
quelle raison refuse de fonctionner ! ! !

=SOMME.SI($B$2:$B$98;et(">10";"< ");$A$2:$A$98)

=SOMME.SI($B$2:$B$98;et(">20";"<0");$A$2:$A$98)

..

Merci d'avance pour votre précieuse aide.
Sam
Le #22135151
re Bonjour,
tu peux aussi faire
=SOMME.SI($B$2:$B$98;">10";$A$2:$A$98)-SOMME.SI($B$2:$B$98;">20";$A$2:$A$98)
Cordialement
Michel dit "Sam"

"Sam" 4bf2c126$0$2971$
Bonjour,
utilise sommeprod
=SOMMEPROD(($B$2:$B$98>10)*($B$2:$B$98<30)*$A$2:$A$98)
Cordialement
Michel dit "Sam"

"nadd"
Bonjour,

Je souhaite élaborer par une "SOMME.SI" une formule qui me communique la
somme
des cellules d'une colonne A en fonction des éléments d'une colonne B.
Jusque là
il s'agit d'une fonction Somme.si banale...
Il s'avère que je souhaite par cette formule procéder au découpage par
tranches
de la colonne B :

En clair, je souhaite une formule telle que ci-dessous qui pour je ne
sais
quelle raison refuse de fonctionner ! ! !

=SOMME.SI($B$2:$B$98;et(">10";"< ");$A$2:$A$98)

=SOMME.SI($B$2:$B$98;et(">20";"<0");$A$2:$A$98)

..

Merci d'avance pour votre précieuse aide.




Publicité
Poster une réponse
Anonyme