Somme si

Le
Steph
Bonsoir,

Je cherche une formule (je dis bien si possible une FORMULE et pas une
macro) qui permettrait de calculer ce qui suis:

Dans une colonne j'ai des valeurs de type

A
1 22M
2 12S
3
4 10M
5 5E
6 2M
7 3E


Je souhaiterais pouvoir calculer la somme des valeurs qui ont la même lettre
en fin.
Donc si dernière lettre = M somme = 34, S = 12, E = 8 etc..

Est-ce possible ?

D'avance merci pour votre aide

Steph
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #17266161
Bonjour.
Pour M :
=SOMMEPROD(N(DROITE(B1:B7;1)="M"))
Cordialement.
Daniel
"Steph"
Bonsoir,

Je cherche une formule (je dis bien si possible une FORMULE et pas une
macro) qui permettrait de calculer ce qui suis:

Dans une colonne j'ai des valeurs de type

A
1 22M
2 12S
3
4 10M
5 5E
6 2M
7 3E


Je souhaiterais pouvoir calculer la somme des valeurs qui ont la même
lettre en fin.
Donc si dernière lettre = M somme = 34, S = 12, E = 8 etc..

Est-ce possible ?

D'avance merci pour votre aide

Steph




Jacquouille
Le #17266341
Bonjour
Le pseudo Steph est déjà pris. Pour éviter confusion, tu pourrais prendre
Steph de Bruxelles, par ex.
Dans tes cellules, il n'y a qu' une seule lettre à droite?
Si oui:
En col A, tu as tes données 12M ....
En B1, à tirer vers le bas =GAUCHE(A1;NBCAR(A1)-1)
En C1, à tirer vers le bas =DROITE(A1;1)
En ...où tu veux =SOMMEPROD((D1:D7="M")*C1:C7) te donnera la somme des
nombres ayant M en finale.
Si tu désires seulement compter le nombre de cellules se terminant par
"M" --> =NB.SI(A1:A10;droite(a1;1="M")
PS Adapter la longueur des plages dans les formules.
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Steph"
Bonsoir,

Je cherche une formule (je dis bien si possible une FORMULE et pas une
macro) qui permettrait de calculer ce qui suis:

Dans une colonne j'ai des valeurs de type

A
1 22M
2 12S
3
4 10M
5 5E
6 2M
7 3E


Je souhaiterais pouvoir calculer la somme des valeurs qui ont la même
lettre en fin.
Donc si dernière lettre = M somme = 34, S = 12, E = 8 etc..

Est-ce possible ?

D'avance merci pour votre aide

Steph




Steph
Le #17266531
Merci pour vos réponses


"Steph"
Bonsoir,

Je cherche une formule (je dis bien si possible une FORMULE et pas une
macro) qui permettrait de calculer ce qui suis:

Dans une colonne j'ai des valeurs de type

A
1 22M
2 12S
3
4 10M
5 5E
6 2M
7 3E


Je souhaiterais pouvoir calculer la somme des valeurs qui ont la même
lettre en fin.
Donc si dernière lettre = M somme = 34, S = 12, E = 8 etc..

Est-ce possible ?

D'avance merci pour votre aide

Steph




michdenis
Le #17266521
Pour la somme, il y a ceci parmi d'autres...

En supposant que tes données sont en A1:A7

Validation Matricielle : Ctrl + Maj + Enter
=SOMME(SI(ESTNUM(CHERCHE("m";$A$1:$A$7));GAUCHE($A$1:$A$7;NBCAR($A$1:$A$7)-1)*1))



"Steph"
Bonsoir,

Je cherche une formule (je dis bien si possible une FORMULE et pas une
macro) qui permettrait de calculer ce qui suis:

Dans une colonne j'ai des valeurs de type

A
1 22M
2 12S
3
4 10M
5 5E
6 2M
7 3E


Je souhaiterais pouvoir calculer la somme des valeurs qui ont la même lettre
en fin.
Donc si dernière lettre = M somme = 34, S = 12, E = 8 etc..

Est-ce possible ?

D'avance merci pour votre aide

Steph
Tendasque
Le #17275061
Un début:
en B1:
=SI(DROITE(A1;1)="M";CNUM(GAUCHE(A1;NBCAR(A1)-1));"")
te mets la "valeur" de A1 (22)
tu recopies en bas
en bas de Colonne B, tu fais la somme
en C, même chose avec les "E", etc...
on doit pouvoir faire plus court, mais je sais pas faire...

"Steph"
Bonsoir,

Je cherche une formule (je dis bien si possible une FORMULE et pas une
macro) qui permettrait de calculer ce qui suis:

Dans une colonne j'ai des valeurs de type

A
1 22M
2 12S
3
4 10M
5 5E
6 2M
7 3E


Je souhaiterais pouvoir calculer la somme des valeurs qui ont la même
lettre en fin.
Donc si dernière lettre = M somme = 34, S = 12, E = 8 etc..

Est-ce possible ?

D'avance merci pour votre aide

Steph




Publicité
Poster une réponse
Anonyme