somme.si

Le
rico34
Bonjour,

Je possède une feuille avec 3 colonnes dont les intitulés sont les suivants :
- colonne A : date (10/04/07, 11/04/07, etc)
- colonne B : référence ( x1, y2, z3, etc)
- colonne C : temps ( 3:01, 2:01, etc)

J'arrive à cumuler le temps en fonction de la référence avec la formule
suivante :
=SOMME.SI($B:$B;"x1";$C:$C).
Je n'arrive plus à cumuler en fonction de la référence et deux dates, à savoir
connaître le temps cumulé pour une référence donnée entre le 8/04/07 et le
11/04/07.

Merci pour vos lumières.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #4392411
bonjour rico34,

=SOMMEPROD(($A:$A>=8/04/07)*($A:$A</04/07)*($B:$B="x1")*($C:$C))

isabelle


Bonjour,

Je possède une feuille avec 3 colonnes dont les intitulés sont les suivants :
- colonne A : date (10/04/07, 11/04/07, etc...)
- colonne B : référence ( x1, y2, z3, etc...)
- colonne C : temps ( 3:01, 2:01, etc...)

J'arrive à cumuler le temps en fonction de la référence avec la formule
suivante :
=SOMME.SI($B:$B;"x1";$C:$C).
Je n'arrive plus à cumuler en fonction de la référence et deux dates, à savoir
connaître le temps cumulé pour une référence donnée entre le 8/04/07 et le
11/04/07.

Merci pour vos lumières.







rico34
Le #4392211
Merci pour la réponse rapide, mais elle ne fonctionne pas dans sa globalité.
J'ai essayé une variante avec succès
=SOMMEPROD(($B:$B="x1")*($C:$C))

Cette variante retourne 0.
=SOMMEPROD(($A:$A>=8/04/07)*($A:$A</04/07)*($B:$B="x1")*($C:$C))

J'ai essayé de mettre des guillemets pour la date, mais la conclusion est
identique.
Sans guillemets, la date est transformée en 8/4/7 dans la formule.





bonjour rico34,

=SOMMEPROD(($A:$A>=8/04/07)*($A:$A</04/07)*($B:$B="x1")*($C:$C))

isabelle


Bonjour,

Je possède une feuille avec 3 colonnes dont les intitulés sont les suivants :
- colonne A : date (10/04/07, 11/04/07, etc...)
- colonne B : référence ( x1, y2, z3, etc...)
- colonne C : temps ( 3:01, 2:01, etc...)

J'arrive à cumuler le temps en fonction de la référence avec la formule
suivante :
=SOMME.SI($B:$B;"x1";$C:$C).
Je n'arrive plus à cumuler en fonction de la référence et deux dates, à savoir
connaître le temps cumulé pour une référence donnée entre le 8/04/07 et le
11/04/07.

Merci pour vos lumières.










isabelle
Le #4392141
bonjour,

correction: il ne faut jamais mettre une colonne entière en référecnce,
et les formats de date sont assez pointilleux sur excel, essaie comme ça,

=SOMMEPROD((A2:A2000>DATE(2007;4;8))*(A2:A2000<DATE(2007;4;11))*($B2:$B2000="x1")*($C2:$C2000))

isabelle


Merci pour la réponse rapide, mais elle ne fonctionne pas dans sa globalité.
J'ai essayé une variante avec succès
=SOMMEPROD(($B:$B="x1")*($C:$C))

Cette variante retourne 0.
=SOMMEPROD(($A:$A>=8/04/07)*($A:$A</04/07)*($B:$B="x1")*($C:$C))

J'ai essayé de mettre des guillemets pour la date, mais la conclusion est
identique.
Sans guillemets, la date est transformée en 8/4/7 dans la formule.






bonjour rico34,

=SOMMEPROD(($A:$A>=8/04/07)*($A:$A</04/07)*($B:$B="x1")*($C:$C))

isabelle



Bonjour,

Je possède une feuille avec 3 colonnes dont les intitulés sont les suivants :
- colonne A : date (10/04/07, 11/04/07, etc...)
- colonne B : référence ( x1, y2, z3, etc...)
- colonne C : temps ( 3:01, 2:01, etc...)

J'arrive à cumuler le temps en fonction de la référence avec la formule
suivante :
=SOMME.SI($B:$B;"x1";$C:$C).
Je n'arrive plus à cumuler en fonction de la référence et deux dates, à savoir
connaître le temps cumulé pour une référence donnée entre le 8/04/07 et le
11/04/07.

Merci pour vos lumières.












rico34
Le #4392051
Un très grand merci.


bonjour,

correction: il ne faut jamais mettre une colonne entière en référecnce,
et les formats de date sont assez pointilleux sur excel, essaie comme ça,

=SOMMEPROD((A2:A2000>DATE(2007;4;8))*(A2:A2000<DATE(2007;4;11))*($B2:$B2000="x1")*($C2:$C2000))

isabelle


Merci pour la réponse rapide, mais elle ne fonctionne pas dans sa globalité.
J'ai essayé une variante avec succès
=SOMMEPROD(($B:$B="x1")*($C:$C))

Cette variante retourne 0.
=SOMMEPROD(($A:$A>=8/04/07)*($A:$A</04/07)*($B:$B="x1")*($C:$C))

J'ai essayé de mettre des guillemets pour la date, mais la conclusion est
identique.
Sans guillemets, la date est transformée en 8/4/7 dans la formule.






bonjour rico34,

=SOMMEPROD(($A:$A>=8/04/07)*($A:$A</04/07)*($B:$B="x1")*($C:$C))

isabelle



Bonjour,

Je possède une feuille avec 3 colonnes dont les intitulés sont les suivants :
- colonne A : date (10/04/07, 11/04/07, etc...)
- colonne B : référence ( x1, y2, z3, etc...)
- colonne C : temps ( 3:01, 2:01, etc...)

J'arrive à cumuler le temps en fonction de la référence avec la formule
suivante :
=SOMME.SI($B:$B;"x1";$C:$C).
Je n'arrive plus à cumuler en fonction de la référence et deux dates, à savoir
connaître le temps cumulé pour une référence donnée entre le 8/04/07 et le
11/04/07.

Merci pour vos lumières.















rico34
Le #4392031
Un très grand merci.



bonjour,

correction: il ne faut jamais mettre une colonne entière en référecnce,
et les formats de date sont assez pointilleux sur excel, essaie comme ça,

=SOMMEPROD((A2:A2000>DATE(2007;4;8))*(A2:A2000<DATE(2007;4;11))*($B2:$B2000="x1")*($C2:$C2000))

isabelle


Merci pour la réponse rapide, mais elle ne fonctionne pas dans sa globalité.
J'ai essayé une variante avec succès
=SOMMEPROD(($B:$B="x1")*($C:$C))

Cette variante retourne 0.
=SOMMEPROD(($A:$A>=8/04/07)*($A:$A</04/07)*($B:$B="x1")*($C:$C))

J'ai essayé de mettre des guillemets pour la date, mais la conclusion est
identique.
Sans guillemets, la date est transformée en 8/4/7 dans la formule.






bonjour rico34,

=SOMMEPROD(($A:$A>=8/04/07)*($A:$A</04/07)*($B:$B="x1")*($C:$C))

isabelle



Bonjour,

Je possède une feuille avec 3 colonnes dont les intitulés sont les suivants :
- colonne A : date (10/04/07, 11/04/07, etc...)
- colonne B : référence ( x1, y2, z3, etc...)
- colonne C : temps ( 3:01, 2:01, etc...)

J'arrive à cumuler le temps en fonction de la référence avec la formule
suivante :
=SOMME.SI($B:$B;"x1";$C:$C).
Je n'arrive plus à cumuler en fonction de la référence et deux dates, à savoir
connaître le temps cumulé pour une référence donnée entre le 8/04/07 et le
11/04/07.

Merci pour vos lumières.















Publicité
Poster une réponse
Anonyme