somme.si ..... entre 2 dates ....

Le
SylVBA
Bonsoir,

Je n'arrive pas a écrire une formule qui prendrait dans le cadre de
somme.si le critère suivant:

SOMME.SI(A2:A200;(">=21/07/09 ET <=05/11/09");F2:F200)

Comment écrire ">=21/07/09 ET <=05/11/09" dans le critère ??
Un simple critère comme ">=21/07/09" fonctionne parfaitement, mais
comment le faire pour prendre en compte un critère qui prend en compte
2 dates entre x et y ?

Matricielle ? avec ET mais comment ???

Je vous remercie d'avance de votre éclairage par ce week end bien
mausade !

Je reste attentive à vos posts !!

Bonne soirée

SylVBA
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #20556741
Bonsoir,
=SOMME.SI(A2:A200;">!/07/09";F2:F200)-SOMME.SI(A2:A200;">/11/09";F2:F200)
devrait pouvoir convenir
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"SylVBA" news:
Bonsoir,

Je n'arrive pas a écrire une formule qui prendrait dans le cadre de
somme.si le critère suivant:

SOMME.SI(A2:A200;(">!/07/09 ET </11/09");F2:F200)

Comment écrire ">!/07/09 ET </11/09" dans le critère ??
Un simple critère comme ">!/07/09" fonctionne parfaitement, mais
comment le faire pour prendre en compte un critère qui prend en compte
2 dates entre x et y ?

Matricielle ? avec ET mais comment ???

Je vous remercie d'avance de votre éclairage par ce week end bien
mausade !

Je reste attentive à vos posts !!

Bonne soirée

SylVBA
Jol
Le #20556791
Bonsoir,

Essaye ceci,

B1!/07/09
B2/11/09

=SOMMEPROD((A2:A200>±)*(A2:A200<²)*(F2:F200))

"SylVBA" news:
Bonsoir,

Je n'arrive pas a écrire une formule qui prendrait dans le cadre de
somme.si le critère suivant:

SOMME.SI(A2:A200;(">!/07/09 ET </11/09");F2:F200)

Comment écrire ">!/07/09 ET </11/09" dans le critère ??
Un simple critère comme ">!/07/09" fonctionne parfaitement, mais
comment le faire pour prendre en compte un critère qui prend en compte
2 dates entre x et y ?

Matricielle ? avec ET mais comment ???

Je vous remercie d'avance de votre éclairage par ce week end bien
mausade !

Je reste attentive à vos posts !!

Bonne soirée

SylVBA
SylVBA
Le #20558941
Bonjour,

Merci à Philippe.R et à Jol les 2 solutions fonctionnent parfaitement,
je connais sommeprod et pourtant cela ne fonctionnait pas chez moi,
j'ai du faire une "fôte" de frappe !

La solution de Philippe est pourtant si évidente, on ne voit jamais ce
qui est devant nous !!

Désolée pour hier soir, j'ai eu une panne de box, et plus rien jusqu' à
ce matin !!!!

A plus tard sur ce forum sympa

SylVBA

PS: vous faites votre diner annuel bientôt ??
Publicité
Poster une réponse
Anonyme