Somme.si en fonction du contenu d'une cellule

Le
Fredo(67)
Bonjour,

J'ai un tableau représentant des dépenses en fonction de postes.
en face de chaque poste apparait le montant de la dépense

Je voudrais faire la somme des dépense de chaque poste contenant un
texte particulier

Par exemple :
Toto crepissage 25
Peinture Zaza 32
Tolerie Roger 65
solde Toto 82


total des lignes où apparait le texte toto : 107

J'ai pense à un somme.si, mais je n'arrive pas à trouver les arguments
qui me donne le bon résultat

MErci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #18651691
Tu adaptes les plages de cellules et toto est le mot que tu recherches

=SOMMEPROD((ESTNUM(TROUVE("toto";A1:A3;1)))*(B1:B3))


"Fredo(67)"
Bonjour,

J'ai un tableau représentant des dépenses en fonction de postes.
en face de chaque poste apparait le montant de la dépense

Je voudrais faire la somme des dépense de chaque poste contenant un
texte particulier

Par exemple :
Toto crepissage 25
Peinture Zaza 32
Tolerie Roger 65
solde Toto 82


total des lignes où apparait le texte toto : 107

J'ai pense à un somme.si, mais je n'arrive pas à trouver les arguments
qui me donne le bon résultat

MErci
JCA
Le #18651881
Bonjour,
Fred a écrit
=SOMMEPROD((ESTNUM(TROUVE("toto";A1:A3;1)))*(B1:B3))

Il me semble que la question était
A1:A3 Contient toto
et non pas A1:A3 = toto
car il a des champs du style "toto crepissage"

JCA


"michdenis"
Tu adaptes les plages de cellules et toto est le mot que tu recherches

=SOMMEPROD((ESTNUM(TROUVE("toto";A1:A3;1)))*(B1:B3))


"Fredo(67)" de discussion :

Bonjour,

J'ai un tableau représentant des dépenses en fonction de postes.
en face de chaque poste apparait le montant de la dépense

Je voudrais faire la somme des dépense de chaque poste contenant un
texte particulier

Par exemple :
Toto crepissage 25
Peinture Zaza 32
Tolerie Roger 65
solde Toto 82


total des lignes où apparait le texte toto : 107

J'ai pense à un somme.si, mais je n'arrive pas à trouver les arguments
qui me donne le bon résultat

MErci



michdenis
Le #18652041
Si le demandeur veut faire abstraction de la casse, il
remplace Trouve par Cherche.
garnote
Le #18652171
Salut,

Voici deux formules si tu t'intéresses au texte «toto» :

=SOMMEPROD((ESTNUM(CHERCHE("toto";A1:A4;1)))*(B1:B4))
Ne fait pas de distinction entre minuscules et majuscules.
toto, Toto, TOTO, TotO ,,, , c'est pareil.

=SOMMEPROD((ESTNUM(TROUVE("toto";A1:A4;1)))*(B1:B4))
Fait la distinction entre minuscules et majuscules,
Recherche exclusivement « toto».


Serge



"Fredo(67)"
Bonjour,

J'ai un tableau représentant des dépenses en fonction de postes.
en face de chaque poste apparait le montant de la dépense

Je voudrais faire la somme des dépense de chaque poste contenant un
texte particulier

Par exemple :
Toto crepissage 25
Peinture Zaza 32
Tolerie Roger 65
solde Toto 82


total des lignes où apparait le texte toto : 107

J'ai pense à un somme.si, mais je n'arrive pas à trouver les arguments
qui me donne le bon résultat

MErci
Fredo(67)
Le #18652141
Ca marche impec....

Merci beaucoup

On 12 fév, 14:54, "michdenis"
Tu adaptes les plages de cellules et toto est le mot que tu recherches

=SOMMEPROD((ESTNUM(TROUVE("toto";A1:A3;1)))*(B1:B3))

"Fredo(67)"
Bonjour,

J'ai un tableau représentant des dépenses en fonction de postes.
en face de chaque poste apparait le montant de la dépense

Je voudrais faire la somme des dépense de chaque poste contenant un
texte particulier

Par exemple :
Toto crepissage   25
Peinture Zaza      32
Tolerie Roger       65
solde Toto           82

total des lignes où apparait le texte toto : 107

J'ai pense à un somme.si, mais je n'arrive pas à trouver les argument s
qui me donne le bon résultat

MErci


Fredo(67)
Le #18652131
Merci à tous pour vos précisions.

Effectivement, le texte Toto peut avoir différentes écritures.

j'ai donc opté pour la version qui ne se soucie pas de la casse.

Mais encore merci pour vos réponses aussi éclairées que rapides.....

On 12 fév, 15:38, "Fredo(67)"
Ca marche impec....

Merci beaucoup

On 12 fév, 14:54, "michdenis"


> Tu adaptes les plages de cellules et toto est le mot que tu recherches

> =SOMMEPROD((ESTNUM(TROUVE("toto";A1:A3;1)))*(B1:B3))

> "Fredo(67)" >
> Bonjour,

> J'ai un tableau représentant des dépenses en fonction de postes.
> en face de chaque poste apparait le montant de la dépense

> Je voudrais faire la somme des dépense de chaque poste contenant un
> texte particulier

> Par exemple :
> Toto crepissage   25
> Peinture Zaza      32
> Tolerie Roger       65
> solde Toto           82

> total des lignes où apparait le texte toto : 107

> J'ai pense à un somme.si, mais je n'arrive pas à trouver les argume nts
> qui me donne le bon résultat

> MErci- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Publicité
Poster une réponse
Anonyme