Somme de valeurs d'une colonne sous condition

Le
Lulu
Bonjour,

J'ai une colonne avec des chiffres correspondants à la surface des parcelles
15
20
40
5
9
17
4
12
etc

j'ai réussi à trouver la formule pour dire combien (le nombre) de parcelles
entre 0 et 5ha / 5 et 10ha / 10 et 15ha / 15 et 20ha

maintenant devant le nombre de parcelles je voudrais indiquer la surface que
cela représente
exemple :
2 parcelles de 0 à 5 ha soit 9 ha
6 parcelles de 5 à 10 ha soit 25 ha

etc

Merci d'avance de vos lumières.

Luc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jero
Le #21231241
Salut,
si tes nombres sont en colonne A (et rien d'autre)
Une façon de faire (pas la seule !)
pour 0-5 :
=SOMME((A:A<=5)*(A:A))
à valider par CTRL+MAJ+ENTREE (formule matricielle)
pour 5-10 :
=SOMME((A:A>5)*(A:A<)*(A:A)) (formule matricielle)
etc.
Si tu utilises Excel 2007 :
pour 0-5 :
=SOMME.SI.ENS(A:A;A:A;"<=5")
pour 5-10 :
=SOMME.SI.ENS(A:A;A:A;">5";A:A;"<")
etc.
A+
"Lulu"
Bonjour,

J'ai une colonne avec des chiffres correspondants à la surface des
parcelles
15
20
40
5
9
17
4
12
etc

j'ai réussi à trouver la formule pour dire combien (le nombre) de
parcelles entre 0 et 5ha / 5 et 10ha / 10 et 15ha / 15 et 20ha

maintenant devant le nombre de parcelles je voudrais indiquer la surface
que cela représente
exemple :
2 parcelles de 0 à 5 ha soit 9 ha
6 parcelles de 5 à 10 ha soit 25 ha

etc

Merci d'avance de vos lumières.

Luc





Daniel.C
Le #21231231
Bonjour.
Voici la formule ppour les surfaces de 5 à 10 ha :
=SOMMEPROD((A1:A10>5)*(A1:A10<)*A1:A10)
et, si tu as XL2007 :
=SOMME.SI.ENS(A1:A10;A1:A10;">5";A1:A10;"<")
Daniel

Bonjour,

J'ai une colonne avec des chiffres correspondants à la surface des parcelles
15
20
40
5
9
17
4
12
etc

j'ai réussi à trouver la formule pour dire combien (le nombre) de parcelles
entre 0 et 5ha / 5 et 10ha / 10 et 15ha / 15 et 20ha

maintenant devant le nombre de parcelles je voudrais indiquer la surface que
cela représente
exemple :
2 parcelles de 0 à 5 ha soit 9 ha
6 parcelles de 5 à 10 ha soit 25 ha

etc

Merci d'avance de vos lumières.

Luc


Lulu
Le #21232941
ok ca marche
C'est surprenant la simplicité des formules matricielles
=SOMME((A:A<=5)*(A:A))

Merci Jero, merci Daniel

A+ Luc


"Daniel.C"
Bonjour.
Voici la formule ppour les surfaces de 5 à 10 ha :
=SOMMEPROD((A1:A10>5)*(A1:A10<)*A1:A10)
et, si tu as XL2007 :
=SOMME.SI.ENS(A1:A10;A1:A10;">5";A1:A10;"<")
Daniel

Bonjour,

J'ai une colonne avec des chiffres correspondants à la surface des
parcelles
15
20
40
5
9
17
4
12
etc

j'ai réussi à trouver la formule pour dire combien (le nombre) de
parcelles entre 0 et 5ha / 5 et 10ha / 10 et 15ha / 15 et 20ha

maintenant devant le nombre de parcelles je voudrais indiquer la surface
que cela représente
exemple :
2 parcelles de 0 à 5 ha soit 9 ha
6 parcelles de 5 à 10 ha soit 25 ha

etc

Merci d'avance de vos lumières.

Luc






Caetera
Le #21234351
> C'est surprenant la simplicité des formules matricielles
=SOMME((A:A<=5)*(A:A))



ok ca marche



*******
C'est vraiment pas le bon exemple !

Etc
isabelle
Le #21234381
t'as raison Caetera, Lulu aprendra vite à ces dépends qu'il vaut mieux
éviter les colonnes entières avec les matricielles... ;-)
isabelle

Le 2010-02-20 01:46, Caetera a écrit :
C'est surprenant la simplicité des formules matricielles
=SOMME((A:A<=5)*(A:A))ok ca marche



*******
C'est vraiment pas le bon exemple !

Etc





Lulu
Le #21242191
Bien recu

En fait je ne fais pas la colonne entière, mais

=SOMME((A2:A40<=5)*(A2:A40))

est ce cela pose problème ?

a+ Luc



"isabelle" a écrit dans le message de news:

t'as raison Caetera, Lulu aprendra vite à ces dépends qu'il vaut mieux
éviter les colonnes entières avec les matricielles... ;-)
isabelle

Le 2010-02-20 01:46, Caetera a écrit :
C'est surprenant la simplicité des formules matricielles
=SOMME((A:A<=5)*(A:A))ok ca marche



*******
C'est vraiment pas le bon exemple !

Etc







Daniel.C
Le #21242921
Bonjour.
Absolument aucun. Si tu gardes en tête que mes formules matricielles
consomment beaucoup de ressources. Tu peux fortement dégrader les
performances de ton classeur si tu en mets beaucoup (au moins quelques
centaines quand même).
Cordialement.
Daniel

Bien recu

En fait je ne fais pas la colonne entière, mais

=SOMME((A2:A40<=5)*(A2:A40))

est ce cela pose problème ?

a+ Luc



"isabelle" a écrit dans le message de news:

t'as raison Caetera, Lulu aprendra vite à ces dépends qu'il vaut mieux
éviter les colonnes entières avec les matricielles... ;-)
isabelle

Le 2010-02-20 01:46, Caetera a écrit :
C'est surprenant la simplicité des formules matricielles
=SOMME((A:A<=5)*(A:A))ok ca marche



*******
C'est vraiment pas le bon exemple !

Etc









jero
Le #21244821
Salut,
En réponse à Caetera et Isabelle à prospos de la formule :
=SOMME((A:A<=5)*(A:A))
Je suis bien d'accord avec eux, je suis allé un peu vite (d'ailleurs je
n'utilise jamais cette syntaxe, je préfère créer un nom - dynamique - avec
la fonction DECALER)
A+
"Lulu"
Bien recu

En fait je ne fais pas la colonne entière, mais

=SOMME((A2:A40<=5)*(A2:A40))

est ce cela pose problème ?

a+ Luc



"isabelle" a écrit dans le message de news:

t'as raison Caetera, Lulu aprendra vite à ces dépends qu'il vaut mieux
éviter les colonnes entières avec les matricielles... ;-)
isabelle

Le 2010-02-20 01:46, Caetera a écrit :
C'est surprenant la simplicité des formules matricielles
=SOMME((A:A<=5)*(A:A))ok ca marche



*******
C'est vraiment pas le bon exemple !

Etc











Publicité
Poster une réponse
Anonyme