Sommeprod : chaîne de caractèrs avec jockers

Le
Stéphan DuQuébec
Bonjour groupe,
Je planche, je patine.en rond. Je cherche à dénombrer les occurences
formées de la combinaison de 2 critères se trouvant dans 2 plages
différentes.J'aimerais utiliser un SOMMEPROD dont le premier critère, simple
est celui-ci: =SOMMEPROD((B2:B300046)* Ensuite, j'aimerais y combiner le
résultat, lorsque positif d'un NB.SI acceptant les jockers
NB.SI(E2:E3000;"*SAC*") La combinaison des 2 ne fonctionne pas
=SOMMEPROD((B2:B300046)*(NB.SI(E2:E3000;"*SAC*"))).
Quelque'un (une) aurait une iddée du problème, à la base ?
Merci !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #19182001
Bonjour,

=SOMMEPROD((B2:B1046)*(ESTNUM(CHERCHE("Sac";E2:E10))))

JB
http://boisgontierjacques.free.fr/

On 24 avr, 15:15, Stéphan DuQuébec
Bonjour groupe,
Je planche, je patine....en rond. Je cherche à dénombrer les occurenc es
formées de la combinaison de 2 critères se trouvant dans 2 plages
différentes.J'aimerais utiliser un SOMMEPROD dont le premier critère, simple
est celui-ci:  =SOMMEPROD((B2:B300046)*  Ensuite, j'aimerais y combiner le
résultat, lorsque positif d'un NB.SI acceptant les jockers
NB.SI(E2:E3000;"*SAC*")    La combinaison des 2 ne fonctionne pas
=SOMMEPROD((B2:B300046)*(NB.SI(E2:E3000;"*SAC*"))).
Quelque'un (une) aurait une iddée du problème, à la base ?
Merci !


Stéphan DuQuébec
Le #19182231
Monsieur,
Vraiment, vous faites ma journée !
C'est très exactement ce dont je souhaitais.
Salutations à vous, cousin.
Publicité
Poster une réponse
Anonyme