Sommeprod dans plage de cellules conteant du texte

Le
Gatchan
Bonsoir à tous.

Je cherche à faire la sommme des valeurs numeriques d'une colonne ou
d'un champs de données, selon certains criteres que permet normalement
la fonction sommeprod.

Les données sont de ce type :

a1= 1 matin
a2= 4 matin
a3= 6 soir
a4= 2 matin
a6= 8 soir
a8= 1 matin

Je cherche en un premier temps, à faire la somme de toutes les valeurs
des debuts de cellules contenant "matin". Ce qui donnerait de l'exemple
ci dessus = 8.

Puis si possible la somme des cellules contenant "matin" et la valeur 1
en debut, ce qui donnerait de l'exemple ci dessus = 2.

Je vous remercie pour toute astuce .
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Raoul VOLFONI
Le #18647911
Un truc du genre

Je cherche en un premier temps, à faire la somme de toutes les valeurs des
debuts de cellules contenant "matin". Ce qui donnerait de l'exemple ci
dessus = 8.



=SOMMEPROD((STXT(A1:A6;3;5)="matin")*GAUCHE(A1:A6;1))



Puis si possible la somme des cellules contenant "matin" et la valeur 1 en
debut, ce qui donnerait de l'exemple ci dessus = 2.



=SOMMEPROD((A1:A6="1 matin")*1)


--
Cordialement,
Raoul VOLFONI



"Gatchan"
Bonsoir à tous.

Je cherche à faire la sommme des valeurs numeriques d'une colonne ou d'un
champs de données, selon certains criteres que permet normalement la
fonction sommeprod.

Les données sont de ce type :

a1= 1 matin
a2= 4 matin
a3= 6 soir
a4= 2 matin
a6= 8 soir
a8= 1 matin

Je cherche en un premier temps, à faire la somme de toutes les valeurs des
debuts de cellules contenant "matin". Ce qui donnerait de l'exemple ci
dessus = 8.

Puis si possible la somme des cellules contenant "matin" et la valeur 1 en
debut, ce qui donnerait de l'exemple ci dessus = 2.

Je vous remercie pour toute astuce .




Michel Angelosanto
Le #18647901
Réponse dans le texte

"Gatchan" news:
Bonsoir à tous.

Je cherche à faire la sommme des valeurs numeriques d'une colonne ou d'un
champs de données, selon certains criteres que permet normalement la
fonction sommeprod.

Les données sont de ce type :

a1= 1 matin
a2= 4 matin
a3= 6 soir
a4= 2 matin
a6= 8 soir
a8= 1 matin

Je cherche en un premier temps, à faire la somme de toutes les valeurs des
debuts de cellules contenant "matin". Ce qui donnerait de l'exemple ci
dessus = 8.


=SOMMEPROD(--(DROITE(A1:A6;5)= "matin");--(CNUM(GAUCHE(A1:A6;2))))

Puis si possible la somme des cellules contenant "matin" et la valeur 1 en
debut, ce qui donnerait de l'exemple ci dessus = 2.


=SOMMEPROD(--(DROITE(A1:A6;5)= "matin");--(GAUCHE(A1:A6;1)="1"))

Je vous remercie pour toute astuce .





--
Michel Angelosanto, Bordeaux
Dernières mises à jour du site Voyage au pays Internet
http://angelosa.free.fr/index.php?t=8
Jacky
Le #18648481
Bonsoir,

Je propose ceci...
1-
=SOMMEPROD((DROITE(plage;NBCAR($D$2))=$D$2)*(CNUM(GAUCHE(plage;2))))
2-
=SOMMEPROD((DROITE(plage;NBCAR($D$2))=$D$2)*(CNUM(GAUCHE(plage;2))Ã)*CNUM(GAUCHE(plage;2)))
voir ici
http://www.cijoint.fr/cjlink.php?file=cj200902/cij7Zo9Byt.xls


--
Salutations
JJ


"Gatchan"
Bonsoir à tous.

Je cherche à faire la sommme des valeurs numeriques d'une colonne ou d'un
champs de données, selon certains criteres que permet normalement la
fonction sommeprod.

Les données sont de ce type :

a1= 1 matin
a2= 4 matin
a3= 6 soir
a4= 2 matin
a6= 8 soir
a8= 1 matin

Je cherche en un premier temps, à faire la somme de toutes les valeurs des
debuts de cellules contenant "matin". Ce qui donnerait de l'exemple ci
dessus = 8.

Puis si possible la somme des cellules contenant "matin" et la valeur 1 en
debut, ce qui donnerait de l'exemple ci dessus = 2.

Je vous remercie pour toute astuce .




Jacky
Le #18648531
Re...
E3:E12 est à supprimer dans l'exemple transmis
http://www.cijoint.fr/cjlink.php?file=cj200902/cijMtK8wUQ.xls
--
Salutations
JJ


"Jacky"
Bonsoir,

Je propose ceci...
1-
=SOMMEPROD((DROITE(plage;NBCAR($D$2))=$D$2)*(CNUM(GAUCHE(plage;2))))
2-
=SOMMEPROD((DROITE(plage;NBCAR($D$2))=$D$2)*(CNUM(GAUCHE(plage;2))Ã)*CNUM(GAUCHE(plage;2)))
voir ici
http://www.cijoint.fr/cjlink.php?file=cj200902/cij7Zo9Byt.xls


--
Salutations
JJ


"Gatchan"
Bonsoir à tous.

Je cherche à faire la sommme des valeurs numeriques d'une colonne ou d'un
champs de données, selon certains criteres que permet normalement la
fonction sommeprod.

Les données sont de ce type :

a1= 1 matin
a2= 4 matin
a3= 6 soir
a4= 2 matin
a6= 8 soir
a8= 1 matin

Je cherche en un premier temps, à faire la somme de toutes les valeurs
des
debuts de cellules contenant "matin". Ce qui donnerait de l'exemple ci
dessus = 8.

Puis si possible la somme des cellules contenant "matin" et la valeur 1
en
debut, ce qui donnerait de l'exemple ci dessus = 2.

Je vous remercie pour toute astuce .









Gatchan
Le #18654111
Bonsoir .

Grand merci à tous pour les solutions proposées.
Et pour le temps que vous y avez passé.

+
Publicité
Poster une réponse
Anonyme