sommeprod?

Le
JP
Bonjour à tous,

J'ai cette formule:
=ET(ET(H36>=1;I36>=1;J36>=1;K36>=1);SI(MOYENNE(H36:K36)>=2;VRAI=
;FAUX);SI(MOYENNE(H37:K37)>=2;VRAI;FAUX))

Elle porte sur 4 colonnes et 2 lignes, jusque là pas de problème.
Si j'ai sur le même principe, une formule qui porte sur plus de 20 colonn=
es.
Je me vois mal faire des ET(H36>=1; etc sur les 20 colonnes.
Est-ce qu'il y a moyen de faire autrement?
Je pensais à la fonction sommeprod mais je n'ai pas réussi à l'adapte=
r.

Merci pour votre aide.

JP
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #26053402
Bonsoir,

Une piste......
Pour compter le nombre de Colonne >=1
Pour 20 Colonnes "a1:t1"
=SOMMEPROD((A1:T1>=1)*1)

Retourne "vrai" ou "faux"
=SI(SOMMEPROD((A1:T1>=1)*1) ;VRAI;FAUX)
--
Salutations
JJ


"JP"
Bonjour à tous,

J'ai cette formule:
=ET(ET(H36>=1;I36>=1;J36>=1;K36>=1);SI(MOYENNE(H36:K36)>=2;VRAI;FAUX);SI(MOYENNE(H37:K37)>=2;VRAI;FAUX))

Elle porte sur 4 colonnes et 2 lignes, jusque là pas de problème.
Si j'ai sur le même principe, une formule qui porte sur plus de 20 colonnes.
Je me vois mal faire des ET(H36>=1; etc... sur les 20 colonnes.
Est-ce qu'il y a moyen de faire autrement?
Je pensais à la fonction sommeprod mais je n'ai pas réussi à l'adapter.

Merci pour votre aide.

JP
MichD
Le #26053392
Bonjour,

As-tu essayé quelque chose comme :

=ET(SOMMEPROD((H36:S36>=1)*1)=COLONNES(A3:J3);le reste de ta formule
MichD
Le #26053422
Faut lire :


=ET(SOMMEPROD((H36:S36>=1)*1)=COLONNES(H36:S36);le reste de ta formule
JP
Le #26053462
Merci à vous deux, le *1, je ne connaissais pas.

JP
JP
Le #26053642
Bonjour,

Je reviens vers vous car le résultat escompté n'est pas le même avec sommeprod. Ou alors je me suis trompé en mettant la formule en place.

Un fichier exemple avec les différentes formules:http://cjoint.com/?DCBiu vQKfGu


Merci

JP
MichD
Le #26053932
La formule que j'ai proposée est :

=ET(SOMMEPROD((H36:S36>=1)*1)=COLONNES(H36:S36); LE RESTE DE TA FORMULE)

Ce n'est pas celle que tu appliques dans ton fichier....
Jacky
Le #26053952
RE...
Autre piste..lignes 16-20
http://cjoint.com/?DCBmNELaV63
--
Salutations
JJ


"JP"
Bonjour,

Je reviens vers vous car le résultat escompté n'est pas le même avec sommeprod. Ou alors je me suis trompé en
mettant la formule en place.

Un fichier exemple avec les différentes formules:http://cjoint.com/?DCBiuvQKfGu


Merci

JP
JP
Le #26054662
Effectivement, j'ai cru que c'était l'explication comme quoi SOMMEPROD((H 36:S36>=1)*1)était égal à: COLONNES(H36:S36)

Jacky, il me semble que ta formule ne fonctionne pas dans un cas.
Si une cellule de la première ligne est vide, la formule renvoie "vrai" m algré tout.

En tout cas merci à tous les deux pour votre aide.

Je vais devoir intégrer cette formule dans un code pour qu'elle s'écriv e dans une plage de cellules. Ce n'est pas encore gagné.
Je reviendrai, au besoin, vous solliciter à ce moment là.

Merci encore

JP
MichD
Le #26054702
Au lieu de poser une question en te basant sur une formule qui ne donne pas
le résultat escompté, pourquoi ne nous expliques-tu pas ce que la formule
doit faire?
Jacky
Le #26054892
Re...

En K16 dans l'exemple
=ET(SOMMEPROD((B2:N2>=1)*1)=NBVAL(B1:N1);COLONNES(B1:N1)=NBVAL(B1:N1))
en K17
=ET(SOMMEPROD((B2:N2>=2)*1)=NBVAL(B1:N1);COLONNES(B1:N1)=NBVAL(B1:N1))

--
Salutations
JJ


"JP"
Effectivement, j'ai cru que c'était l'explication comme quoi SOMMEPROD((H36:S36>=1)*1)était égal à:
COLONNES(H36:S36)

Jacky, il me semble que ta formule ne fonctionne pas dans un cas.
Si une cellule de la première ligne est vide, la formule renvoie "vrai" malgré tout.

En tout cas merci à tous les deux pour votre aide.

Je vais devoir intégrer cette formule dans un code pour qu'elle s'écrive dans une plage de cellules. Ce n'est
pas encore gagné.
Je reviendrai, au besoin, vous solliciter à ce moment là.

Merci encore

JP
Publicité
Poster une réponse
Anonyme