SOMMEPROD....

Le
Clochard
Salut,

Ma formule fonctionne super bien sur la feuille1 en O57

=SOMMEPROD((L57þuil2!B$3:B$19)*(Feuil2!E$3:E$19))

En Feuil2!B$3:B$19, j'ai des noms
En Feuil2!E$3:E$19 des montants

Mais là j'essaie de faire le contrairegenre, au lieu de placer un nom
en O57 pour obtenir le montant approprié qui se trouve en Feuil2!E$3:E$19
Je cherche a placer un montant en O57 afin d'obtenir un nom en L57
Mais ça ne fonctionne pas d'après vous pourquoi?

--
Clochard
Aimerais bien savoir.
Merci!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #4852391
Bonsoir,

Je cherche a placer un montant en O57 afin d'obtenir un nom en L57


=INDEX(Feuil2!A3:A19;EQUIV(O57;Feuil2!B3:B19;0))

--
Salutations
JJ


"Clochard"
Salut,

Ma formule fonctionne super bien sur la feuille1 en O57

=SOMMEPROD((L57þuil2!B$3:B$19)*(Feuil2!E$3:E$19))

En Feuil2!B$3:B$19, j'ai des noms
En Feuil2!E$3:E$19 des montants

Mais là... j'essaie de faire le contraire...genre, au lieu de placer un
nom
en O57 pour obtenir le montant approprié qui se trouve en Feuil2!E$3:E$19
Je cherche a placer un montant en O57 afin d'obtenir un nom en L57
Mais ça ne fonctionne pas... d'après vous... pourquoi?

--
Clochard
Aimerais bien savoir....
Merci!


Philippe.R
Le #4852381
Bonsoir,
Sauf à dire une grosse ânerie, Sommeprod effectue la somme des produits,
donc la somme des nombres trouvés en regard pour chaque item correspondant à
la chaîne de caractère saisie en dans la plage de référence.
Elle ne peut donc renvoyer une chaîne de caractères .
Pour ce faire, tu devra recourir à la combinaison INDEX(Equiv())
=index(Feuil2!B$3:B$19;equiv(o57;Feuil2!E$3:E$19;0))
--
http://www.excelabo.net/mpfe/connexion.php
Avec plaisir
Philippe.R
"Clochard" news:
Salut,

Ma formule fonctionne super bien sur la feuille1 en O57

=SOMMEPROD((L57þuil2!B$3:B$19)*(Feuil2!E$3:E$19))

En Feuil2!B$3:B$19, j'ai des noms
En Feuil2!E$3:E$19 des montants

Mais là... j'essaie de faire le contraire...genre, au lieu de placer un
nom
en O57 pour obtenir le montant approprié qui se trouve en Feuil2!E$3:E$19
Je cherche a placer un montant en O57 afin d'obtenir un nom en L57
Mais ça ne fonctionne pas... d'après vous... pourquoi?

--
Clochard
Aimerais bien savoir....
Merci!


Jacky
Le #4852321
Oupps !!
=INDEX(Feuil2!B3:B19;EQUIV(O57;Feuil2!E3:E19;0))
évidemment
--
Salutations
JJ


"Jacky"
Bonsoir,

Je cherche a placer un montant en O57 afin d'obtenir un nom en L57


=INDEX(Feuil2!A3:A19;EQUIV(O57;Feuil2!B3:B19;0))

--
Salutations
JJ


"Clochard"
Salut,

Ma formule fonctionne super bien sur la feuille1 en O57

=SOMMEPROD((L57þuil2!B$3:B$19)*(Feuil2!E$3:E$19))

En Feuil2!B$3:B$19, j'ai des noms
En Feuil2!E$3:E$19 des montants

Mais là... j'essaie de faire le contraire...genre, au lieu de placer un
nom
en O57 pour obtenir le montant approprié qui se trouve en Feuil2!E$3:E$19
Je cherche a placer un montant en O57 afin d'obtenir un nom en L57
Mais ça ne fonctionne pas... d'après vous... pourquoi?

--
Clochard
Aimerais bien savoir....
Merci!






Clochard
Le #4852261
Merci à vous deux.... Philippe.R et Jacky

C'est exactement ce dont j'avais besoin...
--
Clochard
Merci!



Bonsoir,
Sauf à dire une grosse ânerie, Sommeprod effectue la somme des produits,
donc la somme des nombres trouvés en regard pour chaque item correspondant à
la chaîne de caractère saisie en dans la plage de référence.
Elle ne peut donc renvoyer une chaîne de caractères .
Pour ce faire, tu devra recourir à la combinaison INDEX(Equiv())
=index(Feuil2!B$3:B$19;equiv(o57;Feuil2!E$3:E$19;0))
--
http://www.excelabo.net/mpfe/connexion.php
Avec plaisir
Philippe.R
"Clochard" news:
Salut,

Ma formule fonctionne super bien sur la feuille1 en O57

=SOMMEPROD((L57þuil2!B$3:B$19)*(Feuil2!E$3:E$19))

En Feuil2!B$3:B$19, j'ai des noms
En Feuil2!E$3:E$19 des montants

Mais là... j'essaie de faire le contraire...genre, au lieu de placer un
nom
en O57 pour obtenir le montant approprié qui se trouve en Feuil2!E$3:E$19
Je cherche a placer un montant en O57 afin d'obtenir un nom en L57
Mais ça ne fonctionne pas... d'après vous... pourquoi?

--
Clochard
Aimerais bien savoir....
Merci!






Publicité
Poster une réponse
Anonyme