SOMMEPROD

Le
Anne
Bonjour,

J'ai besoin de votre expertise :)

Ma formule est la suivante :
= SOMMEPROD (B2:B10=$A$32)*(C2:C10=$B$31)*(D2:D10= *** )*(E2:E10))

*** = c'est ici que ça se complique. Si j'ajoute seulement une condition,
tel $C$31, cela fonctionne très bien. Par contre, je dois recherche 3
conditions, soit de C31 à C33. Alors j'ai fait $C$31:$C$33, j'ai comme
résultat #NA. J'ai alors fait :

= SOMMEPROD
(B2:B10=$A$32)*(C2:C10=$B$31)*(D2:D10Ã1)*(D2:D10Ã2)*(D2:D10Ã3)*(E2:E10)) J'obtiens le résultat 0, mais je sais que je devrais avoir un résultat.

Est-ce que vous avez la solution ?

Merci !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5241101
Bonjour.
A moins que C31Ã2Ã3, tu obtiens forcément 0
Si tu prends D2, si D2Ã1 est vrai (égal à 1), D2Ã2 est faux, donc
D2Ã2=0, la multiplication des deux donne 0 (1 * 0)
Je ne sais pas si je suis clair...
Essaie (formule matricielle, valider avec CTRL+MAEntrée) :
=SOMME((B2:B10=$A$32)*(C2:C10=$B$31)*(SI((D2:D10Ã1)+(D2:D10Ã2)+(D2:D10Ã3)>0;1;0))*(E2:E10))
Cordialement.
Daniel
"Anne"
Bonjour,

J'ai besoin de votre expertise :)

Ma formule est la suivante :
= SOMMEPROD (B2:B10=$A$32)*(C2:C10=$B$31)*(D2:D10= *** )*(E2:E10))

*** = c'est ici que ça se complique. Si j'ajoute seulement une condition,
tel $C$31, cela fonctionne très bien. Par contre, je dois recherche 3
conditions, soit de C31 à C33. Alors j'ai fait $C$31:$C$33, j'ai comme
résultat #NA. J'ai alors fait :

= SOMMEPROD
(B2:B10=$A$32)*(C2:C10=$B$31)*(D2:D10Ã1)*(D2:D10Ã2)*(D2:D10Ã3)*(E2:E10))
J'obtiens le résultat 0, mais je sais que je devrais avoir un résultat.

Est-ce que vous avez la solution ?

Merci !


Daniel.C
Le #5241091
Erratum, lire :
Essaie (formule matricielle, valider avec CTRL+MAJ+Entrée)
Daniel
"Daniel.C"
Bonjour.
A moins que C31Ã2Ã3, tu obtiens forcément 0
Si tu prends D2, si D2Ã1 est vrai (égal à 1), D2Ã2 est faux, donc
D2Ã2=0, la multiplication des deux donne 0 (1 * 0)
Je ne sais pas si je suis clair...
Essaie (formule matricielle, valider avec CTRL+MAEntrée) :
=SOMME((B2:B10=$A$32)*(C2:C10=$B$31)*(SI((D2:D10Ã1)+(D2:D10Ã2)+(D2:D10Ã3)>0;1;0))*(E2:E10))
Cordialement.
Daniel
"Anne"
Bonjour,

J'ai besoin de votre expertise :)

Ma formule est la suivante :
= SOMMEPROD (B2:B10=$A$32)*(C2:C10=$B$31)*(D2:D10= *** )*(E2:E10))

*** = c'est ici que ça se complique. Si j'ajoute seulement une condition,
tel $C$31, cela fonctionne très bien. Par contre, je dois recherche 3
conditions, soit de C31 à C33. Alors j'ai fait $C$31:$C$33, j'ai comme
résultat #NA. J'ai alors fait :

= SOMMEPROD
(B2:B10=$A$32)*(C2:C10=$B$31)*(D2:D10Ã1)*(D2:D10Ã2)*(D2:D10Ã3)*(E2:E10))
J'obtiens le résultat 0, mais je sais que je devrais avoir un résultat.

Est-ce que vous avez la solution ?

Merci !






Publicité
Poster une réponse
Anonyme