SOMMEPROD... mais avec critères...

Le
HD
Bonjour,

Je voudrais pouvoir utiliser l'équivalent de la fonction SOMMEPROD mais
avec un critère sur une colonne supplémentaire

Exemple:
FRUIT COUT QTE
Banane 20 50
Cerise 10 10
Fraise 50 25
Banane 60 30
Fraise 10 40
Je ne voudrais ici faire un SOMMEPROD que pour les lignes où j'ai Banane
(pour donc obtenir dans cet exemple le résultat de 20x50+50x25)

Comment faire ? La fonction existe-t-elle sur Excel ?

Merci d'avance pour votre aide
--
@+
HD
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #23250751
bonjour HD,

=SOMMEPROD((A2:A6="Banane")*(B2:B6)*(C2:C6))

tu voulais s'en doute écrire *=(20*50)+(60*30)*

isabelle
------------------------------------------------------------------

Le 2011-04-01 08:56, HD a écrit :
Bonjour,

Je voudrais pouvoir utiliser l'équivalent de la fonction SOMMEPROD... mais
avec un critère sur une colonne supplémentaire...

Exemple:
FRUIT COUT QTE
Banane 20 50
Cerise 10 10
Fraise 50 25
Banane 60 30
Fraise 10 40
Je ne voudrais ici faire un SOMMEPROD que pour les lignes où j'ai Banane...
(pour donc obtenir dans cet exemple le résultat de 20x50+50x25)

Comment faire ? La fonction existe-t-elle sur Excel ?

Merci d'avance pour votre aide

HD
Le #23250841
=SOMMEPROD((A2:A6="Banane")*(B2:B6)*(C2:C6))


Un grand MERCI à toi Isabelle. lol

tu voulais s'en doute écrire *=(20*50)+(60*30)*


Oups... oui... lol

--
@+
HD
Publicité
Poster une réponse
Anonyme