sommeprod sur multicriere

Le
somme.si et VBa
Bonjour

j ai constituer un tableau avec un détail d'écritures comptables structué
comme suit
colonne A : le compte
colonne B : le type pièce
colonne C : le montant

je cherche sans passer par un tableau croisé dynamique à obtenir sur un
onglet de synthèse, la somme basée sur un critère de la colonne A et un
critère de la colonneB

Il doit y avoir une solution via sommeprod ou somme si ou ET etc
mais je ne trouve pas

pouvez vous m'aider

merci
jm
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michel Gaboly
Le #4855441
Bonjour,

Voici un exemple :

=SOMMEPROD((A1:A20 = "41MARTIN") * (B1:B20 = "Fac") * C1:C20)

ou

=SOMMEPROD((A1:A20 = E1) * (B1:B20 = F1) * C1:C20)

Dans la première version, pour montrer le principe, les critère s ("41MARTIN" et "Fac") sont intégrés à la formule, ce
qui est à éviter. Dans le seconde, ils sont stockés dans l es cellules E1 et F1.

Une adaptation est nécessaire pour les numéros de lignes (ici, 1 à 20)

D'autre part, si les numéros de compte sont les seules données de la colonne A, ET qu'il n'y a pas de saut de ligne, on
peut définir ainsi 3 noms :

NumCptes =$A$1:DECALER($A$1;NBVAL($A:$A) - 1;0)
Catégories CALER(NumCptes;0;1)
Montants CALER(NumCptes;0;2)

ce qui permet l'emploi d'une facile plus facile à lire, et ne né cessitant pas d'adaptation si on ajoute des lignes au
tableau :

=SOMMEPROD((NumCptes = E1) * (Catégories = F1) * Montants)


Bonjour

j ai constituer un tableau avec un détail d'écritures comptab les structué
comme suit
colonne A : le compte
colonne B : le type pièce
colonne C : le montant

je cherche sans passer par un tableau croisé dynamique à obte nir sur un
onglet de synthèse, la somme basée sur un critère de la colonne A et un
critère de la colonneB

Il doit y avoir une solution via sommeprod ou somme si ou ET etc...
mais je ne trouve pas

pouvez vous m'aider

merci
jm



--
Cordialement,

Michel Gaboly
www.gaboly.com

JB
Le #4855411
Bonjour,

=SOMMEPROD((compte=$E8)*(produit=F$7)*Montant)

http://cjoint.com/?jDkZYSftjB

JB
http://boisgontierjacques.free.fr



On 29 sep, 08:55, somme.si et VBa
Bonjour

j ai constituer un tableau avec un détail d'écritures comptables stru ctué
comme suit
colonne A : le compte
colonne B : le type pièce
colonne C : le montant

je cherche sans passer par un tableau croisé dynamique à obtenir sur un
onglet de synthèse, la somme basée sur un critère de la colonne A e t un
critère de la colonneB

Il doit y avoir une solution via sommeprod ou somme si ou ET etc...
mais je ne trouve pas

pouvez vous m'aider

merci
jm


Publicité
Poster une réponse
Anonyme