Sommeprod pas adapté ou je sais pas faire ?

Le
Menibelus
Bonjour,

J'ai un classeur avec une feuille dans laquelle je souhaite mettre des
personnes de garde depuis une feuille qui se nomme donnée, j'ai essayé
la formule suivante =SOMMEPROD((Donnée!B4:O13="Oui")*(Donnée!
B2:O2="CAFPTGP")*(Donnée!P4:X13=1)*(Donnée!P2:X2=Garde!C1)*(Donn=
ée!
P3:X3=D1);Donnée!A4:A13) pour validé le fait que je souhaite en C5 le
nom de la colonne Donnée!A:A suivant plusieurs critères entre autre
que "Oui soit présent en colonne B, que 1 soit présent dans la colonne
du tableau P:X si en cellule Garde!C1 la date correspond et en Garde!
D1 la période correspond

Comment faire car ma formule ne fonctionne pas

http://cjoint.com/?dorBZl5vEe
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #21377671
Bonsoir
D'après mes souvenirs, SOMMEPROD sert à calculer le nombre de .... qui
répondent à une ou plusieurs conditions.
Jamais, AHMA, il n'ira vous placer un nom dans une cellule.
Ensuite, SOMMEPROD exige de travailler sur des plages de même longueur, ce
qui ne semble pas être le cas.

Pour vos gardes, SOMMEPROD vous calculera combien de fois Monsieur Machin a
été de garde, un lundi, au mois de janvier, pour l'année 2009....;par
exemple.

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Menibelus"
Bonjour,

J'ai un classeur avec une feuille dans laquelle je souhaite mettre des
personnes de garde depuis une feuille qui se nomme donnée, j'ai essayé
la formule suivante =SOMMEPROD((Donnée!B4:O13="Oui")*(Donnée!
B2:O2="CAFPTGP")*(Donnée!P4:X13=1)*(Donnée!P2:X2=Garde!C1)*(Donnée!
P3:X3Ñ);Donnée!A4:A13) pour validé le fait que je souhaite en C5 le
nom de la colonne Donnée!A:A suivant plusieurs critères entre autre
que "Oui soit présent en colonne B, que 1 soit présent dans la colonne
du tableau P:X si en cellule Garde!C1 la date correspond et en Garde!
D1 la période correspond

Comment faire car ma formule ne fonctionne pas

http://cjoint.com/?dorBZl5vEe
jero
Le #21377851
Salut,
Extrait aide Excel :
Les matrices spécifiées comme arguments doivent avoir la même dimension...
Donc=>Erreur !
a+
"Menibelus"
Bonjour,

J'ai un classeur avec une feuille dans laquelle je souhaite mettre des
personnes de garde depuis une feuille qui se nomme donnée, j'ai essayé
la formule suivante =SOMMEPROD((Donnée!B4:O13="Oui")*(Donnée!
B2:O2="CAFPTGP")*(Donnée!P4:X13=1)*(Donnée!P2:X2=Garde!C1)*(Donnée!
P3:X3Ñ);Donnée!A4:A13) pour validé le fait que je souhaite en C5 le
nom de la colonne Donnée!A:A suivant plusieurs critères entre autre
que "Oui soit présent en colonne B, que 1 soit présent dans la colonne
du tableau P:X si en cellule Garde!C1 la date correspond et en Garde!
D1 la période correspond

Comment faire car ma formule ne fonctionne pas

http://cjoint.com/?dorBZl5vEe
Menibelus
Le #21377911
Auriez vous 1 solution même en vba
Daniel.C
Le #21377901
Bonjour.
J'ai utiisé la formule suivante en C5 :

=INDEX(Donnée!$A$1:$A$13;SOMMEPROD(SI((Donnée!B4:O13="Oui")*(Donnée!B2:O2="CAFPTGP")*(Donnée!P4:AC13=1)*(Donnée!P2:AC2=Garde!C1)*(Donnée!P3:AC3Ñ)=1;LIGNE(4:13);""));)

(formule matricielle, à valider avec Ctrl+Maj+Entrée).

Vérifie le résultat, parce que j'ai redimensionné les plages pour
éviter les erreurs. Voici ton classeur modifié :

http://www.cijoint.fr/cjlink.php?file=cj201003/cijASmTVQ5.xlsx

Cordialement.
Daniel

Bonjour,

J'ai un classeur avec une feuille dans laquelle je souhaite mettre des
personnes de garde depuis une feuille qui se nomme donnée, j'ai essayé
la formule suivante =SOMMEPROD((Donnée!B4:O13="Oui")*(Donnée!
B2:O2="CAFPTGP")*(Donnée!P4:X13=1)*(Donnée!P2:X2=Garde!C1)*(Donnée!
P3:X3Ñ);Donnée!A4:A13) pour validé le fait que je souhaite en C5 le
nom de la colonne Donnée!A:A suivant plusieurs critères entre autre
que "Oui soit présent en colonne B, que 1 soit présent dans la colonne
du tableau P:X si en cellule Garde!C1 la date correspond et en Garde!
D1 la période correspond

Comment faire car ma formule ne fonctionne pas

http://cjoint.com/?dorBZl5vEe
Menibelus
Le #21396471
On 14 mar, 18:38, Daniel.C
Bonjour.
J'ai utiisé la formule suivante en C5 :

=INDEX(Donnée!$A$1:$A$13;SOMMEPROD(SI((Donnée!B4:O13="Oui")*(Donn ée!B2:O2=" CAFPTGP")*(Donnée!P4:AC13=1)*(Donnée!P2:AC2=Garde!C1 )*(Donnée!P3:AC3Ñ)=1; LIGNE(4:13);""));)

(formule matricielle, à valider avec Ctrl+Maj+Entrée).

Vérifie le résultat, parce que j'ai redimensionné les plages pour
éviter les erreurs. Voici ton classeur modifié :

http://www.cijoint.fr/cjlink.php?file=cj201003/cijASmTVQ5.xlsx

Cordialement.
Daniel



> Bonjour,

> J'ai un classeur avec une feuille dans laquelle je souhaite mettre des
> personnes de garde depuis une feuille qui se nomme donnée, j'ai essay é
> la formule suivante =SOMMEPROD((Donnée!B4:O13="Oui")*(Donnée!
> B2:O2="CAFPTGP")*(Donnée!P4:X13=1)*(Donnée!P2:X2=Garde!C1)*(D onnée!
> P3:X3Ñ);Donnée!A4:A13) pour validé le fait que je souhaite en C 5 le
> nom de la colonne Donnée!A:A suivant plusieurs critères entre autre
> que "Oui soit présent en colonne B, que 1 soit présent dans la colo nne
> du tableau P:X si en cellule Garde!C1 la date correspond et en Garde!
> D1 la période correspond

> Comment faire car ma formule ne fonctionne pas

>http://cjoint.com/?dorBZl5vEe



Cela fonctionne mais si je change la date le contenu ne se mets pas à
jour
Daniel.C
Le #21396621
Bonjour.
Donne-moi un exemple de modification et du résultat que je dois
obtenir. Je ne sais pas quoi modifier.
Cordialement.
Daniel

On 14 mar, 18:38, Daniel.C
Bonjour.
J'ai utiisé la formule suivante en C5 :

=INDEX(Donnée!$A$1:$A$13;SOMMEPROD(SI((Donnée!B4:O13="Oui")*(Donnée!B2:O2="
CAFPTGP")*(Donnée!P4:AC13=1)*(Donnée!P2:AC2=Garde!C1)*(Donnée!P3:AC3Ñ)=1;
LIGNE(4:13);""));)

(formule matricielle, à valider avec Ctrl+Maj+Entrée).

Vérifie le résultat, parce que j'ai redimensionné les plages pour
éviter les erreurs. Voici ton classeur modifié :

http://www.cijoint.fr/cjlink.php?file=cj201003/cijASmTVQ5.xlsx

Cordialement.
Daniel



Bonjour,



J'ai un classeur avec une feuille dans laquelle je souhaite mettre des
personnes de garde depuis une feuille qui se nomme donnée, j'ai essayé
la formule suivante =SOMMEPROD((Donnée!B4:O13="Oui")*(Donnée!
B2:O2="CAFPTGP")*(Donnée!P4:X13=1)*(Donnée!P2:X2=Garde!C1)*(Donnée!
P3:X3Ñ);Donnée!A4:A13) pour validé le fait que je souhaite en C5 le
nom de la colonne Donnée!A:A suivant plusieurs critères entre autre
que "Oui soit présent en colonne B, que 1 soit présent dans la colonne
du tableau P:X si en cellule Garde!C1 la date correspond et en Garde!
D1 la période correspond



Comment faire car ma formule ne fonctionne pas
http://cjoint.com/?dorBZl5vEe





Cela fonctionne mais si je change la date le contenu ne se mets pas à
jour
Publicité
Poster une réponse
Anonyme