sommeprod plante avec un critere nombre

Le
el_bodeguero
Bonjour à tous,
Je le répète a chaque fois mais merci à tout le monde de m'avoir fait
connaitre cette fonction.
J'ai le soucis suivant:


=SOMMEPROD((feuil1!A$2:A$10000=$A4)*(feuil1!AZ$2:AZ$10000="SLB")*(feuil1!AH$2:AH$10000))

dans feuil1 j'ai des valeurs diverses du style 0616162B et 530.
Aucune cellule vide ou nulle.

Quand dans A4 j'ai 0616162B la formule marche; quand j'ai 530 ca ne marche
pas.

on dirait que la formule n'accepte pas les criteres Nombres.

Merci pour votre collaboration.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ChristianM
Le #18994021
Peut-être : est-ce qua $A4 est en format texte ?
N'y a-t-il pas des espaces ?

--
ChristianM


"el_bodeguero" message de news:
Bonjour à tous,
Je le répète a chaque fois mais merci à tout le monde de m'avoir fait
connaitre cette fonction.
J'ai le soucis suivant:


=SOMMEPROD((feuil1!A$2:A$10000=$A4)*(feuil1!AZ$2:AZ$10000="SLB")*(feuil1!AH$2:AH$10000))

dans feuil1 j'ai des valeurs diverses du style 0616162B et 530.
Aucune cellule vide ou nulle.

Quand dans A4 j'ai 0616162B la formule marche; quand j'ai 530 ca ne marche
pas.

on dirait que la formule n'accepte pas les criteres Nombres.

Merci pour votre collaboration.





LSteph
Le #18994251
Bonjour,

mets ta colonne au format texte
ou saisis '530

...à suivre

--
lSteph


el_bodeguero a écrit :
Bonjour à tous,
Je le répète a chaque fois mais merci à tout le monde de m'avoir fait
connaitre cette fonction.
J'ai le soucis suivant:


=SOMMEPROD((feuil1!A$2:A$10000=$A4)*(feuil1!AZ$2:AZ$10000="SLB")*(feuil1!AH$2:AH$10000))

dans feuil1 j'ai des valeurs diverses du style 0616162B et 530.
Aucune cellule vide ou nulle.

Quand dans A4 j'ai 0616162B la formule marche; quand j'ai 530 ca ne marche
pas.

on dirait que la formule n'accepte pas les criteres Nombres.

Merci pour votre collaboration.





el_bodeguero
Le #18994641
"LSteph" wrote:

Bonjour,

mets ta colonne au format texte
ou saisis '530

....à suivre

--
lSteph





bravo ! ca marche
' signifie donc que xcel interprete ce qu'il y a derriere comme texte
merci
Publicité
Poster une réponse
Anonyme